Bug 7531 - CompaqPresarioV2417LA: Bus #06 (-#09) is hidden behind transparent bridge #05 (-#05)
CompaqPresarioV2417LA: Bus #06 (-#09) is hidden behind transparent bridge #05...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 low
Assigned To: Bernhard Kaindl
:
: 6783 7575 7831 8480 8748 8772 8899 8903 9049 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-15 06:25 UTC by Cristian Aravena Romero
Modified: 2007-10-24 07:29 UTC (History)
14 users (show)

See Also:
Kernel Version: 2.6.17
Tree: Mainline
Regression: ---


Attachments
$dmesg 2.6.17-10-generic (18.96 KB, text/plain)
2006-11-17 18:32 UTC, Cristian Aravena Romero
Details
$sudo cat /boot/grub/menu.lst (4.20 KB, text/plain)
2006-12-21 06:32 UTC, Cristian Aravena Romero
Details
$dmesg 2.6.17-10-generic (19.41 KB, text/plain)
2006-12-21 06:35 UTC, Cristian Aravena Romero
Details
$sudo cat /boot/grub/menu.lst (4.20 KB, text/plain)
2006-12-21 09:09 UTC, Cristian Aravena Romero
Details
$dmesg 2.6.17-10-generic with pci=assign-busses (19.15 KB, text/plain)
2006-12-21 09:10 UTC, Cristian Aravena Romero
Details
$dmesg 2.6.20-5-lowlatency (19.98 KB, text/plain)
2007-01-07 09:55 UTC, Cristian Aravena Romero
Details
Kernel command line: [...] pci=assign-busses (20.85 KB, text/plain)
2007-06-22 12:13 UTC, Cristian Aravena Romero
Details
Linux ubuntu 2.6.22-8-generic (23.64 KB, text/x-log)
2007-08-05 16:44 UTC, Cristian Aravena Romero
Details
$dmesg in kernel 2.23.1 (20.13 KB, text/x-log)
2007-10-24 07:29 UTC, Cristian Aravena Romero
Details

Description Cristian Aravena Romero 2006-11-15 06:25:54 UTC
Most recent kernel where this bug did *NOT* occur:
Distribution: Ubuntu Edgy
Hardware Environment:
https://wiki.ubuntu.com/LaptopTestingTeam/CompaqPresarioV2417LA/Hardware
Software Environment: Default + updates + automatix2
Problem Description: Message in log

[17179573.656000] Please report the result to linux-kernel to fix this permanently
[17179573.656000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[17179573.660000] ACPI: PCI Interrupt Link [LNKA] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKB] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKC] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKD] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKE] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKF] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKG] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: PCI Interrupt Link [LNKH] (IRQs 10 11) *0, disabled.
[17179573.660000] ACPI: Embedded Controller [EC0] (gpe 24) interrupt mode.
[17179573.664000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P2P_._PRT]
[17179573.664000] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
[17179573.664000] Linux Plug and Play Support v0.97 (c) Adam Belay

Steps to reproduce:
Comment 1 Cristian Aravena Romero 2006-11-15 06:37:24 UTC
Package: linux-image-2.6.17-10-generic
Version: 2.6.17-10.33


-- System Information:
Debian Release: testing/unstable
  APT prefers edgy-updates
  APT policy: (500, 'edgy-updates'), (500, 'edgy-security'), (500,
'edgy-backports'), (500, 'edgy')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/dash
Kernel: Linux 2.6.17-10-generic
Locale: LANG=es_CL.UTF-8, LC_CTYPE=es_CL.UTF-8 (charmap=UTF-8)

Versions of packages linux-image-2.6.17-10-generic depends on:
ii  coreutils [fileutils]     5.96-5ubuntu4  The GNU core utilities
ii  initramfs-tools           0.69ubuntu20   tools for generating an initramfs
ii  module-init-tools         3.2.2-3ubuntu3 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.17-10-generic recommends:
ii  grub                     0.97-11ubuntu14 GRand Unified Bootloader

-- debconf-show failed
Comment 2 Diego Calleja 2006-11-17 11:37:12 UTC
I think it'd be better if you attached the full dmesg
Comment 3 Cristian Aravena Romero 2006-11-17 18:32:12 UTC
Created attachment 9555 [details]
$dmesg 2.6.17-10-generic
Comment 4 Diego Calleja 2006-12-21 04:54:27 UTC
I'm not sure but i think you must try the 'pci=assign-busses' kernel boot option
and attach the dmesg again.
Comment 5 Cristian Aravena Romero 2006-12-21 06:32:35 UTC
Created attachment 9913 [details]
$sudo cat /boot/grub/menu.lst
Comment 6 Cristian Aravena Romero 2006-12-21 06:35:03 UTC
Created attachment 9914 [details]
$dmesg 2.6.17-10-generic
Comment 7 Cristian Aravena Romero 2006-12-21 06:36:42 UTC
Thanks Diego for you comment.
Comment 8 Cristian Aravena Romero 2006-12-21 09:09:10 UTC
Created attachment 9916 [details]
$sudo cat /boot/grub/menu.lst

Ups
Comment 9 Cristian Aravena Romero 2006-12-21 09:10:26 UTC
Created attachment 9917 [details]
$dmesg 2.6.17-10-generic with pci=assign-busses

ups
Comment 10 Cristian Aravena Romero 2007-01-07 09:55:13 UTC
Created attachment 10018 [details]
$dmesg 2.6.20-5-lowlatency

update linux. Now work with 2.6.20RC2
Comment 11 Cristian Aravena Romero 2007-02-13 13:18:15 UTC
I test proyect http://www.linuxfirmwarekit.org/

Unfo my BIOS:
http://www.bughost.org/pipermail/firmwarekit-results/2007-February/000094.html

(Revise file results-0001.xml)
Comment 12 Len Brown 2007-03-30 19:18:03 UTC
> Linux version 2.6.20-5-lowlatency
...
> PCI: Bus #06 (-#09) is hidden behind transparent bridge #05 (-#05) 
(try 'pci=assign-busses')
> Please report the result to linux-kernel to fix this permanently

assigning this to the PCI sub-system.
Comment 13 Cristian Aravena Romero 2007-06-22 12:13:43 UTC
Created attachment 11852 [details]
Kernel command line: [...] pci=assign-busses
Comment 14 Ben Collins 2007-07-18 06:38:57 UTC
So assigned to the PCI subsystem. Any hint of progress? Is this a hw bug that needs a workaround, or is this a kernel bug?
Comment 15 Ben Collins 2007-07-18 06:40:07 UTC
Original bug report:

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/78340
Comment 16 Bernhard Kaindl 2007-07-26 09:20:42 UTC
For Greg and others: This the same text as I used in bug 7831,
so you do not have to read it again.

Many thanks for the report, I reviewed it and have this result:

The message

Bus #06 (-#09) is hidden behind transparent bridge #05 (-#05)

indicates that some PCI busses may not reachable by your system, but it is
very likely that if these buses are allocated to a CardBus slot.

In this (likely case), yenta-socket fixes this in current kernels,
and your drivers see your Cardbus cards. This means that when they
are shown in lspci, there is no real issue except that the too
sensitve check for this message needs to be fixed or the message
removed.

Unless you have PCI hardware (such as CardBus cards, not old PCMCIA cards)
connected to your machine which is not shown by lspci after loading all
neccessary drivers (eg. yenta_socket), we can close this bug:

I'd then go forward and simply propose to either delete this warning check
or to change to it a PCI-internal warning message which is normally supressed
and only enabled when developers debug PCI bus scanning and refine it a bit
so that it only is triggered in cases which are not addressed by yenta-socket.

Not that if a secific driver is not working, then this is not in relation
to this bug report, this bug report is only about PCI devices which may
potentially not show up in lspci and for which the driver also will never see.

Unless the PCI device is not shown in PCI, open a new bug if you have an
issue with a driver.

With your laptop, there would only be an issue if you connect an external PCI
enclosure which itself has further internal PCI busses thru your cardbus
slot to your laptop, but that case is also adressed by yenta-socket in
current kernels.

Again many thanks for the report and if I hear nothing new regarding this
bug report, I'll close it when the 'bus hidden behind bridge' message is fixed.
Comment 17 Cristian Aravena Romero 2007-08-05 16:44:39 UTC
Created attachment 12261 [details]
Linux ubuntu 2.6.22-8-generic

I testing Ubuntu Tribe 3, Ubuntu tribe 3 work with kernel 2.6.22-8. I update attach of dmesg with pci=assign-busses. Thanks!
Comment 18 Bernhard Kaindl 2007-10-16 06:25:02 UTC
The PCI misconfiguration which is being indicated in this message only turned out to be an issue with CardBus and it is being fixed up within the possible limits of that approach in CardBus driver with yenta_fixup_parent_bridge() (since 2.6.18) and as that has turned out as sufficient, we changed the reporting of this misconfiguration to be printed only when debugging PCI:

In a patch which is merged mainline with 2.6.22.6 and 2.6.23, I improved the the message and changed it a PCI debugging message only, so it's not shown unless PCI is being debugged.

The issue can be considered to be closed now.

Is this just a warning which I left in to be sure that the reason for it is properly dealt with, but we removed it from the normal user's sight now because we found

* that the PCI misconfiguration which is being indicated in this message only
  seems to be an issue with CardBus.
* that the CardBus fixup code which we have in place since 2.6.18 with appears
  to be sufficient.

Thus, I submitted a patch which was merged mainline with 2.6.22.6 and 2.6.23
that turns it into a message which is only enabled when debugging PCI, so in
practical users terms, the warning is gone. 
Comment 19 Bernhard Kaindl 2007-10-16 06:25:34 UTC
*** Bug 8480 has been marked as a duplicate of this bug. ***
Comment 20 Bernhard Kaindl 2007-10-16 06:26:32 UTC
*** Bug 6783 has been marked as a duplicate of this bug. ***
Comment 21 Bernhard Kaindl 2007-10-16 06:27:51 UTC
*** Bug 9049 has been marked as a duplicate of this bug. ***
Comment 22 Bernhard Kaindl 2007-10-16 06:29:13 UTC
*** Bug 7575 has been marked as a duplicate of this bug. ***
Comment 23 Bernhard Kaindl 2007-10-16 06:29:39 UTC
*** Bug 8903 has been marked as a duplicate of this bug. ***
Comment 24 Bernhard Kaindl 2007-10-16 06:30:14 UTC
*** Bug 8899 has been marked as a duplicate of this bug. ***
Comment 25 Bernhard Kaindl 2007-10-16 06:32:18 UTC
*** Bug 8772 has been marked as a duplicate of this bug. ***
Comment 26 Bernhard Kaindl 2007-10-16 06:34:43 UTC
*** Bug 7831 has been marked as a duplicate of this bug. ***
Comment 27 Bernhard Kaindl 2007-10-16 06:35:22 UTC
*** Bug 8748 has been marked as a duplicate of this bug. ***
Comment 28 Cristian Aravena Romero 2007-10-24 07:29:55 UTC
Created attachment 13260 [details]
$dmesg in kernel 2.23.1

Hello, attach dmesg with kernel 2.6.23.1, now not message. Thanks

Note You need to log in before you can comment on or make changes to this bug.