Bug 6783 - Bus hidden behind transparent bridge on HP Compaq nx6125
Bus hidden behind transparent bridge on HP Compaq nx6125
Status: RESOLVED DUPLICATE of bug 7531
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 normal
Assigned To: Bernhard Kaindl
:
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2006-07-01 18:23 UTC by Jure Repinc
Modified: 2007-10-16 06:26 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.17-mm5
Tree: Mainline
Regression: ---


Attachments

Description Jure Repinc 2006-07-01 18:23:27 UTC
I get this message in dmesg output:

PCI: Transparent bridge - 0000:00:14.4
PCI: Bus #03 (-#06) is hidden behind transparent bridge #02 (-#03) 
(try 'pci=assign-busses')
Please report the result to linux-kernel to fix this permanently

This is the output of lspci without the pci=assign-busses option:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc Unknown device 5a37
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE 
Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio 
Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address 
Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 
5955 (PCIE)
02:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit 
Ethernet (rev 03)
02:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 
802.11g Wireless LAN Controller (rev 02)
02:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
02:04.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host 
Controller
02:04.3 Mass storage controller: Texas Instruments PCIxx21 Integrated 
FlashMedia Controller
02:04.4 Class 0805: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, 
PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller

And this is the output with the option:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc Unknown device 5a37
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE 
Controller ATI
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio 
Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc ATI SB400 - AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address 
Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc ATI Radeon XPRESS 200M 
5955 (PCIE)
04:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit 
Ethernet (rev 03)
04:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 
802.11g Wireless LAN Controller (rev 02)
04:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
04:04.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host 
Controller
04:04.3 Mass storage controller: Texas Instruments PCIxx21 Integrated 
FlashMedia Controller
04:04.4 Class 0805: Texas Instruments PCI6411, PCI6421, PCI6611, PCI6621, 
PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) Controller
Comment 1 Jure Repinc 2006-07-08 07:42:13 UTC
The report is also true for Linux kernel 2.6.18-rc1
Comment 2 Greg Kroah-Hartman 2006-07-11 12:19:24 UTC
Bernhard, this is due to your change, right?
Comment 3 Natalie Protasevich 2007-07-06 16:31:01 UTC
Any update on this problem? Is it still a problem with newest kernels (2.6.22+)?
Thanks.
Comment 4 Bernhard Kaindl 2007-10-16 06:26:32 UTC
Is this just a warning which I left in to be sure that the reason for it is
properly dealt with, but we removed it from the normal user's sight now because
we found

* that the PCI misconfiguration which is being indicated in this message only
  seems to be an issue with CardBus.
* that the CardBus fixup code which we have in place since 2.6.18 with appears
  to be sufficient.

Thus, I submitted a patch which was merged mainline with 2.6.22.6 and 2.6.23
that turns it into a message which is only enabled when debugging PCI, so in
practical users terms, the warning is gone. 


*** This bug has been marked as a duplicate of bug 7531 ***

Note You need to log in before you can comment on or make changes to this bug.