Bug 7218 - PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
Status: CLOSED DUPLICATE of bug 6539
Product: ACPI
Classification: Unclassified
Component: Config-Other
i386 Linux
: P2 high
Assigned To: acpi_config-interrupts
:
: 6305 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 15:04 UTC by Nan Wang
Modified: 2008-01-12 16:02 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.18
Tree: Mainline
Regression: ---


Attachments

Description Nan Wang 2006-09-27 15:04:07 UTC
Most recent kernel where this bug did not occur:
2.4?

Distribution:
Gentoo

Hardware Environment:
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
06:06.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit
Ethernet (rev 03)
06:07.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:07.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host
Controller
06:07.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia
Controller
06:08.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network
Connection (rev 05)


Software Environment:
UDEV 087, Bash 3.1

Problem Description:
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.2
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.1
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1c.2
  IO window: disabled.
  MEM window: disabled.
  PREFETCH window: disabled.
PCI: Bus 7, cardbus bridge: 0000:06:07.0
  IO window: 00002000-000020ff
  IO window: 00002400-000024ff
  PREFETCH window: 50000000-51ffffff
  MEM window: 54000000-55ffffff
PCI: Bridge: 0000:00:1e.0
  IO window: 2000-2fff
  MEM window: b0100000-b01fffff
  PREFETCH window: 50000000-51ffffff
ACPI: PCI Interrupt 0000:00:1c.0[A] -> GSI 17 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1c.0 to 64
ACPI: PCI Interrupt 0000:00:1c.1[B] -> GSI 16 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1c.1 to 64
ACPI: PCI Interrupt 0000:00:1c.2[C] -> GSI 18 (level, low) -> IRQ 185
PCI: Setting latency timer of device 0000:00:1c.2 to 64
PCI: Setting latency timer of device 0000:00:1e.0 to 64
ACPI: PCI Interrupt 0000:06:07.0[A] -> GSI 18 (level, low) -> IRQ 185

Steps to reproduce:
It always happen.
Comment 1 Andrew Morton 2006-09-27 15:57:55 UTC
I think this is a general PCI resource-management thing, not
an ACPI thing?
Comment 2 Len Brown 2007-03-30 19:20:50 UTC
Still an issue with "pnpacpi=off" or "acpi=off"?
Comment 3 Nan Wang 2007-03-30 20:42:53 UTC
"pnpacpi=off" does not solve the problem, but "acpi=off" solves.> Date: Fri, 30 Mar 2007 19:20:53 -0700> From: bugme-daemon@bugzilla.kernel.org> To: nanericwang@hotmail.com> Subject: [Bug 7218] PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0> > http://bugzilla.kernel.org/show_bug.cgi?id=7218> > len.brown@intel.com changed:> >            What    |Removed                     |Added> ---------------------------------------------------------------------------->                  CC|                            |acpi->                    |                            |bugzilla@lists.sourceforge.n>                    |                            |et>           Component|Config-Interrupts           |Config-Other>             Summary|Cannot allocate resource    |PCI: Cannot allocate>                    |region                      |resource region 7 of bridge>                    |                            |0000:00:1c.0> > > > ------- Additional Comments From len.brown@intel.com  2007-03-30 19:20 -------> Still an issue with "pnpacpi=off" or "acpi=off"?> > ------- You are receiving this mail because: -------> You reported the bug, or are watching the reporter.
_________________________________________________________________
Comment 4 Natalie Protasevich 2007-07-06 16:42:22 UTC
Nan,
Is it still a problem with newest kernels (2.6.22+)?
Can you attach boot traces for boot with and without acpi=off?
Also, when you see those errors - does the system boot afterwards?
Thanks.
Comment 5 Fu Michael 2007-11-05 21:34:53 UTC
*** Bug 6305 has been marked as a duplicate of this bug. ***
Comment 6 ykzhao 2007-11-26 21:21:46 UTC
*** Bug 6539 has been marked as a duplicate of this bug. ***
Comment 7 Fu Michael 2007-12-03 01:10:17 UTC

*** This bug has been marked as a duplicate of bug 6539 ***

Note You need to log in before you can comment on or make changes to this bug.