Bug 6305 - Cannot allocate resource region
Cannot allocate resource region
Status: CLOSED DUPLICATE of bug 7218
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: acpi_config-interrupts
:
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2006-03-30 03:42 UTC by Nan Wang
Modified: 2008-01-12 16:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.16.1
Tree: Mainline
Regression: ---


Attachments
output of dmesg (14.40 KB, text/plain)
2006-04-10 09:39 UTC, Luc Mo Costabella
Details

Description Nan Wang 2006-03-30 03:42:36 UTC
Most recent kernel where this bug did not occur:
Distribution:
Gentoo

Hardware Environment:
Celeron-M 1.3G
i915G
Acer TravelMate 3001

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High
Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
04:06.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit
Ethernet (rev 03)
04:07.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
04:07.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host
Controller
04:07.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia
Controller
04:08.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)


Software Environment:
2.6.16.1

Problem Description:
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.2
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0

Steps to reproduce:
always
Comment 1 Len Brown 2006-03-30 18:38:46 UTC
i expect that you'll still have this problem with acpi=off
assigning it to the PCI sub-system
Comment 2 Luc Mo Costabella 2006-04-10 08:56:19 UTC
I have exactly the same problem. I have already
submitted my data in bug 5813, which is very
similar (duplicate ?)

system : Acer aspire 1654WLMi notebook
distribution : FC5
kernel : 2.6.16-1.2080_FC5

First there is an error message :

PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.0
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.2
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.2

Then the boot freezes during udev initialization, it
doesn't save /var/log/messages or /var/log/dmesg,
and I don't know how to obtain them.

output of lspci -v :
--------------------

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information

00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 00003000-00003fff
	Memory behind bridge: c8100000-c81fffff
	Prefetchable memory behind bridge: d0000000-d7ffffff
	Capabilities: [88] #0d [0000]
	Capabilities: [80] Power Management version 2
	Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
	Capabilities: [a0] Express Root Port (Slot+) IRQ 0
	Capabilities: [100] Virtual Channel
	Capabilities: [140] Unknown (5)

00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 04) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=09, subordinate=09, sec-latency=0
	Capabilities: [40] Express Root Port (Slot+) IRQ 0
	Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
	Capabilities: [90] #0d [0000]
	Capabilities: [a0] Power Management version 2
	Capabilities: [100] Virtual Channel
	Capabilities: [180] Unknown (5)

00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 2 (rev 04) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=0a, subordinate=0a, sec-latency=0
	Capabilities: [40] Express Root Port (Slot+) IRQ 0
	Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
	Capabilities: [90] #0d [0000]
	Capabilities: [a0] Power Management version 2
	Capabilities: [100] Virtual Channel
	Capabilities: [180] Unknown (5)

00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 3 (rev 04) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=04, sec-latency=0
	Capabilities: [40] Express Root Port (Slot+) IRQ 0
	Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
	Capabilities: [90] #0d [0000]
	Capabilities: [a0] Power Management version 2
	Capabilities: [100] Virtual Channel
	Capabilities: [180] Unknown (5)

00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 04) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 20
	I/O ports at 1800 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 04) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 21
	I/O ports at 1820 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 04) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 18
	I/O ports at 1840 [size=32]

00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 04) (prog-if 00 [UHCI])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 16
	I/O ports at 1860 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 04) (prog-if 20 [EHCI])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 20
	Memory at c8000000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4) (prog-if
01 [Subtractive decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=06, subordinate=07, sec-latency=216
	I/O behind bridge: 00004000-00004fff
	Memory behind bridge: c8200000-c82fffff
	Prefetchable memory behind bridge: 0000000050000000-0000000051f00000
	Capabilities: [50] #0d [0000]

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 04)
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 10
	I/O ports at 1c00 [size=256]
	I/O ports at 1880 [size=64]
	Memory at c8000800 (32-bit, non-prefetchable) [size=512]
	Memory at c8000400 (32-bit, non-prefetchable) [size=256]
	Capabilities: [50] Power Management version 2

00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 04) (prog-if 00 [Generic])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: medium devsel, IRQ 19
	I/O ports at 2400 [size=256]
	I/O ports at 2000 [size=128]
	Capabilities: [50] Power Management version 2

00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE
Controller (rev 04) (prog-if 8a [Master SecP PriP])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 0, IRQ 18
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at <unassigned>
	I/O ports at 18c0 [size=16]

00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 04)
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: medium devsel, IRQ 11
	I/O ports at 20a0 [size=32]

01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility
M300] (prog-if 00 [VGA])
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, fast devsel, latency 0, IRQ 10
	Memory at d0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 3000 [size=256]
	Memory at c8100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at c8120000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Express Endpoint IRQ 0
	Capabilities: [80] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
	Capabilities: [100] Advanced Error Reporting

06:01.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, medium devsel, latency 168, IRQ 18
	Memory at c8208000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=06, secondary=07, subordinate=08, sec-latency=176
	Memory window 0: 50000000-51fff000 (prefetchable)
	Memory window 1: 52000000-53fff000
	I/O window 0: 00004000-000040ff
	I/O window 1: 00004400-000044ff
	16-bit legacy interface ports at 0001

06:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
	Subsystem: Intel Corporation Unknown device 2701
	Flags: medium devsel, IRQ 11
	Memory at c820b000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [dc] Power Management version 2

06:08.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 02)
	Subsystem: Acer Incorporated [ALI] Unknown device 0066
	Flags: bus master, fast devsel, latency 32, IRQ 16
	Memory at c8206000 (32-bit, non-prefetchable) [size=8K]
	Capabilities: [40] Power Management version 2
Comment 3 Luc Mo Costabella 2006-04-10 09:39:48 UTC
Created attachment 7833 [details]
output of dmesg

If I use boot option acpi=off, my system loads correctly, and I don't see the
error messages anymore. Notice the "Disabling IRQ #10" in dmesg output...
Comment 4 Greg Kroah-Hartman 2006-08-30 01:20:14 UTC
Ok, that's an ACPI issue then, punting back to them :)
Comment 5 Fu Michael 2007-11-05 21:34:53 UTC

*** This bug has been marked as a duplicate of bug 7218 ***

Note You need to log in before you can comment on or make changes to this bug.