Bug 6362 - Kernel inconrrectly detects pci bus
Kernel inconrrectly detects pci bus
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
i386 Linux
: P2 normal
Assigned To: Greg Kroah-Hartman
:
: 6363 (view as bug list)
Depends on:
Blocks: 5829
  Show dependency treegraph
 
Reported: 2006-04-09 07:24 UTC by Dimitar Kosev
Modified: 2006-08-30 00:53 UTC (History)
0 users

See Also:
Kernel Version: 2.6.15.1
Tree: Mainline
Regression: ---


Attachments

Description Dimitar Kosev 2006-04-09 07:24:05 UTC
Most recent kernel where this bug did not occur: none
Distribution: Gentoo
Hardware Environment: Pentium D 805, VIA P4M800CE + VT8251 (Asus P5VDC-MX)
Software Environment:
Problem Description:

I have this board and this "VIA Technologies, Inc. VIA High Definition Audio
Controller" is I think uncorrectly recognised and this makes the two PCI slots
unusable (anything pluged in this slots wont work, lspci wont show it), couse
kernel thinks there is this VIA HDA, but it's not. I compiled kernel with "PCI
access mode"=BIOS and now they works. 

Here my lspci with "PCI Access mode = ANY"
00:00.0 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8251 PCI to ISA Bridge
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 70)
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCIE Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCI Bridge
01:00.0 VGA compatible controller: ATI Technologies Inc RV410 [Radeon X700 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV410 [Radeon X700 (PCIE)]
(Secondary)
02:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:00.1 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller

And here with "PCI access mode = BIOS"

00:00.0 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. P4M800CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
(rev 90)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 90)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8251 PCI to ISA Bridge
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 70)
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCIE Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8251 PCI to PCI Bridge
01:00.0 VGA compatible controller: ATI Technologies Inc RV410 [Radeon X700 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV410 [Radeon X700 (PCIE)]
(Secondary)
02:00.0 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
02:00.1 PCI bridge: VIA Technologies, Inc. VT8251 PCIE Root Port
05:08.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
05:09.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio
Decoder (rev 05)


This fake "02:01.0 Audio device: VIA Technologies, Inc. VIA High Definition
Audio Controller" seem to represend 05:08.0 and 05:09.0. Also from alsa-project
advise me to bug this here because the onboard sound is not workind and they
think it is some "ACPI IRQ routing bug"

Steps to reproduce: Compile any kernel with "PCI Access mode = ANY" and use this
board. Same on x86 and x86_64
Comment 1 Adrian Bunk 2006-04-09 08:01:35 UTC
*** Bug 6363 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Ritz 2006-08-17 07:33:20 UTC
fist, please try a more recent kernel. if not working, please post a full dmesg
from non-working and working config. also a lspci -vvv from both configs please.

the HD audio is not really fake, but the HD audio controller integrated in the
vt8251 (which should be disabled since an additional PCI audio is used). so it's
not really surprising to see it when bypassing the BIOS. the question is more why
bus 5 is not seen w/o BIOS.
Comment 3 Dimitar Kosev 2006-08-18 02:25:24 UTC
In fact the onboard sound controler IS disabled on both lspci outputs. I've
changed the board just few weeks after I buged that here, so aditional test are
imposible for me. I think this was fixed some time ago.
Comment 4 Greg Kroah-Hartman 2006-08-30 00:53:32 UTC
Ok, am closing.

Note You need to log in before you can comment on or make changes to this bug.