Bug 15770

Summary: PS/2 peripherals not powered off - Asus M2N-E motherboard
Product: Drivers Reporter: Bruno Jacquet (maxijac)
Component: Input DevicesAssignee: Lan Tianyu (tianyu.lan)
Status: NEEDINFO ---    
Severity: blocking CC: acelists, alan, bonesisaac1982, dmitry.torokhov, florian, lenb, m.b.anti666, maciej.rutecki, patryk, rjw, rui.zhang, tianyu.lan
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.10 Subsystem:
Regression: No Bisected commit-id:
Bug Depends on:    
Bug Blocks: 14885    
Attachments: acpidump

Description Bruno Jacquet 2010-04-12 17:17:22 UTC

Since I'm on the 2.6.33 kernel My PS/2 keyboard (and mouse when I use an adaptater USB to PS/2) don't get powered off when I shut down my PC. NumLock light and the red light of my mouse are still here. USB has no problem.

I'm using the 2.6.33 kernel on an x86_64 CPU. My motherboard is an Asus M2N-E.

I thought it was a problem of configuration so I opened a bug report on the ArchLinux bugzilla but they told me to report it here.

If you need more infos or experimentations, ask.

Comment 1 Len Brown 2010-04-13 01:52:39 UTC
the lights went out on 2.6.32 and stopped going out using 2.6.33?

Please show the output from "cat /proc/acpi/wakeup"
for the old and new kernels.
Comment 2 Bruno Jacquet 2010-04-13 11:19:29 UTC
I don't have the 2.6.32 installed right now but I think it started when I switched to 2.6.33.

I have another kernel installed :, with this one, no problem, lights go out (all of the 3 LED blink then all shut doww with previous kernels, with 2.6.33 there's no blink, it just stays with NumLock on and nothing happens)

If you want me to reinstall a 2.6.32 I can.

Here are my results for /proc/acpi/wakeup :
Device  S-state   Status   Sysfs node
HUB0      S5     disabled  pci:0000:00:06.0
XVR0      S5     disabled  pci:0000:00:0f.0
XVR1      S5     disabled  
XVR2      S5     disabled  
XVR3      S5     disabled  
XVR4      S5     disabled  
XVR5      S5     disabled  
UAR1      S5     disabled  pnp:00:08
PS2K      S4     disabled  pnp:00:0a
USB0      S4     disabled  pci:0000:00:02.0
USB2      S4     disabled  pci:0000:00:02.1
AZAD      S5     disabled  pci:0000:00:06.1
MMAC      S5     disabled  pci:0000:00:08.0

Both 2.6.27 and 2.6.33 gave the same output ( I diffed them )

Could it be a kernel .config in ACPI section problem ? (I've tried to find an option about shutdown of peripherals but didn't find any)
Comment 3 Dmitry Torokhov 2010-04-13 16:57:22 UTC
In 2.6.33 input switched from full reset to "light" reset for keyboards and mice. During full reset of the keyboard LEDs blink and then are turned off automatically, "light" reset does not do that.

However the fact that LEDs on keyboard are turned off does not prove that we powered off PS/2 ports...
Comment 4 Bruno Jacquet 2010-04-14 11:48:57 UTC
It looks like you're right Dmitry.
With 2.6.27 (that I thought was successfully shutting down my keyboard), LEDs are reinitialized and then none are glowing but if I plug my USB (converted to PS/2) mouse, the light on it is still glowing... So even with 2.6.27 my PS/2 peripherals are still powered.

So where can the problem be ? Is it really a kernel bug ? Or a BIOS configuration ? Or even a Motherboard/Alimentation hardware problem ?
Comment 5 Dmitry Torokhov 2010-04-14 16:12:53 UTC
I _think_ that we should be powering off PS/2 ports unless they are configured as wakeup sources, but I'll let Len to decide...
Comment 6 Bruno Jacquet 2010-04-14 18:58:30 UTC
In my bios configuration, I have :
Power on by PS/2 Mouse -> [Disabled]
Power on by PS/2 Keyboard -> [Disabled]
Comment 7 Dmitry Torokhov 2010-04-17 08:30:51 UTC
*** Bug 15710 has been marked as a duplicate of this bug. ***
Comment 8 Zhang Rui 2010-05-20 06:51:42 UTC
please attach the output of "grep . /sys/bus/*/devices/*/power/wakeup"
Comment 9 Bruno Jacquet 2010-05-20 19:45:47 UTC
grep . /sys/bus/*/devices/*/power/wakeup:

Note that I am now using a 2.6.34 kernel.
Comment 10 Zhang Rui 2010-05-21 01:12:29 UTC
please try "echo disabled > /sys/bus/pnp/devices/00:0a/power/wakeup" and see if the problem still exists.
Comment 11 Zhang Rui 2010-05-21 01:36:16 UTC
in /proc/acpi/wakeup:
PS2K      S4     disabled  pnp:00:0a

in sysfs:

this seems to be a problem, I'll look at the code first and update my findings later.
Comment 12 Bruno Jacquet 2010-05-21 13:16:15 UTC
I did and the problem still exists. I even tried to disable all the devices.

Thanks for your implication ;)
Comment 13 Len Brown 2010-07-13 02:10:38 UTC
per comment #4, clearing the "regression" flag

> In my bios configuration, I have :
> Power on by PS/2 Mouse -> [Disabled]
> Power on by PS/2 Keyboard -> [Disabled]

Hmm, then perhaps Linux is doing something wrong...
I would think we'd D3 these devices on a proper shutdown...

please provide the output from acpidump
Comment 14 Bruno Jacquet 2010-07-13 12:06:20 UTC
Created attachment 27085 [details]
Comment 15 aceman 2010-08-07 12:20:12 UTC
Not fixed in 2.6.35.
Comment 16 aceman 2010-10-23 16:08:47 UTC
I also have an ASUS motherboard (M2N68) - AM2+ based. The original reporter also mentions a x86_64 CPU. Maybe there is a common BIOS/ACPI problem on these boards?
Comment 17 Bruno Jacquet 2010-10-26 22:02:48 UTC
Issue still present in 2.6.36

Regarding what aceman told, could it be the DSDT or something similar ? (I have no clue, just suggesting)
Comment 18 Bruno Jacquet 2011-01-08 17:31:24 UTC
Not fixed in 2.6.37
Comment 19 Zhang Rui 2012-01-18 02:02:55 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
Comment 20 Bruno Jacquet 2012-01-19 22:07:21 UTC
Yes, the bug is still in 3.2
Comment 21 aceman 2012-02-08 17:51:32 UTC
Confirming, still exists.
Comment 22 Lan Tianyu 2013-04-03 01:30:12 UTC
Sorry, please check again whether the problem still exists in the latest kernel (v3.9-rc5). From your comments, there is no problem when use usb mouse and keyboard, right?
Comment 23 aceman 2013-04-07 13:45:18 UTC
The problem still exists in 3.8.
I do not have USB keyboard, but the original reported seems to say USB is fine.
We both report the problem is on PS/2.
Comment 24 Lan Tianyu 2013-04-07 14:02:03 UTC
How about these device status after cool shut down and not boot up?
Comment 25 aceman 2013-04-07 14:28:48 UTC
What do you mean?
The computer is completely shut down but the Num lock keyboard LED still glows.
Of course the computer is still plugged to the mains and devides that charge through USB ports get power.
Comment 26 Lan Tianyu 2013-04-08 03:48:33 UTC
(In reply to comment #25)
> What do you mean?
I mean power off the machine 
> The computer is completely shut down but the Num lock keyboard LED still
> glows.
> Of course the computer is still plugged to the mains and devices that charge
> through USB ports get power.
How about cut the power (unplugged to the mains) and then repower the machine but not boot? What's these devices state?

From the acpi table on this machine, there is no power resource for PS2K and PS2M. This means linux ACPI can't power off these devices.
Comment 27 Bruno Jacquet 2013-04-08 07:24:57 UTC
Cut power (for at least 1 min or capacitors remain charged and it is not relevant I guess) and then replug power but no boot : LED stay off.

Windows can bring these devices off, would it be some kind of broken ACPI table as usual?
Comment 28 Lan Tianyu 2013-04-08 08:41:05 UTC
I have no idea how windows does it. Do you have a usb keyboard and mouse?
If yes, Can you try to unload these device driver and check these devices's state?
Or not load drivers after boot up and check devices' states again?
Comment 29 Lan Tianyu 2013-05-27 14:03:49 UTC
Any update?
Comment 30 Lan Tianyu 2013-06-03 07:00:20 UTC
Since no response for a long time, close this bug as will_fix_later.
Comment 31 aceman 2013-06-03 19:58:17 UTC
What response did you expect? What kind of bug closure is this? Is the bug fixed now?
Comment 32 Lan Tianyu 2013-06-04 01:48:41 UTC
Please follow Comment #28 to debug. Reopen this bug.
Comment 33 aceman 2013-06-04 16:24:13 UTC
Comment 28 is not applicable, as I have a PS/2 keyboard.
Comment 34 Lan Tianyu 2013-08-06 02:52:47 UTC
Sorry, for later response. Currently, I have no good idea and hope some PS/2 expert can help.
Comment 35 Patryk Rządziński 2014-03-26 10:44:40 UTC

I'm actually having the same problem. I've just switched to a new keyboard which is ps/2 in turn (previously had usb keyboard and there was no problem).

I have no wake-on-* enabled in bios. I have also no suspend/resume functionality compiled into the kernel.

My system is: 3.10.33 #2 SMP PREEMPT Tue Mar 25 10:58:35 CET 2014 x86_64

Can I help with any debug info?
Comment 36 Mahdi Bahrami Motlagh 2020-04-12 09:31:20 UTC
*** Bug 207027 has been marked as a duplicate of this bug. ***
Comment 37 Mahdi Bahrami Motlagh 2020-04-12 09:32:07 UTC
*** Bug 206937 has been marked as a duplicate of this bug. ***
Comment 38 Andy Shevchenko 2020-04-23 13:25:12 UTC
*** Bug 207029 has been marked as a duplicate of this bug. ***
Comment 39 Andy Shevchenko 2020-04-23 13:28:00 UTC
(In reply to Mahdi Bahrami Motlagh from comment #37)
> *** Bug 206937 has been marked as a duplicate of this bug. ***

Simply stop opening bugs which are duplicates of this one!
Comment 40 Mahdi Bahrami Motlagh 2020-04-25 08:54:13 UTC

I have a USB keyboard and mouse, and I have the same problem.
It's unfortunate that the bug hasn't gone away in ten years, so where's the legendary power of Linux and its professional programmers?
Alas, it is embarrassing. Woe to you

Mr. Lan Tianyu, there is no driver for my keyboard and mouse for Linux, but it is for Windows.

I tested Unix Free BSD, this problem did not exist there, since the source is open, you can get help from them to solve this problem.

In addition, this problem is due to sabotage when Mr. Linus Torvalds wrote code for the inputs.