Bug 207029 - Trouble turning off input devices
Summary: Trouble turning off input devices
Status: RESOLVED DUPLICATE of bug 15770
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: other_other
URL:
Keywords:
: 207405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-03-30 14:47 UTC by Mahdi Bahrami Motlagh
Modified: 2020-04-23 13:25 UTC (History)
17 users (show)

See Also:
Kernel Version: 2.6.33 till now 5.6
Tree: Mainline
Regression: No


Attachments
dmesg For USBs (4.76 KB, text/plain)
2020-04-05 17:17 UTC, Mahdi Bahrami Motlagh
Details

Description Mahdi Bahrami Motlagh 2020-03-30 14:47:46 UTC
When I turn off the computer, the mouse light and the num lock button I switched on are still on and will not turn off when the computer is turned off.


This bug has been present in version 2.6.33 to date. The bug report by Bruno Jacquet also indicates a problem that has existed since 2010 and has been reported id = 15770
Comment 1 Larry Finger 2020-04-05 15:11:41 UTC
We need more information. I assume this is not a notebook/laptop. Is that correct?

If a desktop, are the keyboard and mouse connected wirelessly? What drivers are used for those devices?

Please post the dmesg output from a short run.
Comment 2 Mahdi Bahrami Motlagh 2020-04-05 17:10:29 UTC
Yes, it's not a notebook or laptop, it's a desktop
The keyboard and mouse are USB
I do not use any drivers
This problem exists in all GNU Linux distributions. If you have a desktop system, you can test it.
  I use Kali distribution as a live boot
This is a problem even if I install this distribution
Comment 3 Mahdi Bahrami Motlagh 2020-04-05 17:17:38 UTC
Created attachment 288213 [details]
dmesg For USBs
Comment 4 Mahdi Bahrami Motlagh 2020-04-05 17:29:38 UTC
Was this attachment what you wanted? Did I send it correctly?
I think this is a problem with the Linux kernel programming code
Let's solve this problem once and for all
Comment 5 Larry Finger 2020-04-05 17:48:44 UTC
I suspect that your system is remaining in a low-power state waiting for an event to wake it up, and not really in full shutdown. See Documentation/driver-api/pm/devices.rst, particularly the paragraph below:

The initial value in the :file:`power/wakeup` file is "disabled" for the
majority of devices; the major exceptions are power buttons, keyboards, and
Ethernet adapters whose WoL (wake-on-LAN) feature has been set up with ethtool.
It should also default to "enabled" for devices that don't generate wakeup
requests on their own but merely forward wakeup requests from one bus to another
(like PCI Express ports).

Does your BIOS have a setting to control USB power for wakeup?

After shutdown, do those lights remain on when you cut the power to the computer?
Comment 6 Mahdi Bahrami Motlagh 2020-04-05 19:56:18 UTC
My BIOS does not have such settings
When I disconnect the power cord from the computer
The mouse light turns off after 8 seconds, as well as the keyboard
Comment 7 Mahdi Bahrami Motlagh 2020-04-22 15:35:01 UTC
The problem seems to be in this direction. By changing the programming files in this place, the problem can be solved.

linux-5.6.2\drivers\input
Comment 8 Andy Shevchenko 2020-04-23 13:23:25 UTC
*** Bug 207405 has been marked as a duplicate of this bug. ***
Comment 9 Andy Shevchenko 2020-04-23 13:25:12 UTC

*** This bug has been marked as a duplicate of bug 15770 ***

Note You need to log in before you can comment on or make changes to this bug.