Bug 9760 - Firewire Card Not Detected by JuJu Stack.
Firewire Card Not Detected by JuJu Stack.
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: IEEE1394
All Linux
: P1 normal
Assigned To: Stefan Richter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 19:18 UTC by Joshua Schmidlkofer
Modified: 2008-02-09 09:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc7
Tree: Mainline
Regression: ---


Attachments

Description Joshua Schmidlkofer 2008-01-15 19:18:08 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution:
Hardware Environment:
Dual Quad Xeon, PCI-Express TI: TSB82AA2 (0c00: 104c:8025 (rev 01)), Maxtor OneTouch III external drives
Software Environment:
Gentoo, up to date.
Problem Description:
JuJu Stack appears to detect my card, but does not configure/operate it.It gives this message:
[  112.508000] firewire_ohci: Added fw-ohci device 0000:0f:02.0, OHCI version 1.10
[  113.004177] firewire_core: created new fw device fw0 (0 config rom retries, S800)
[  144.038242] firewire_core: giving up on config rom for node id ffc0
[  144.142736] firewire_core: giving up on config rom for node id ffc1

Steps to reproduce:
Boot w/ old stack blacklisted, after boot up disks not detected.  Remove the JuJu modules, load ohci1394 and sbp2 - now devices are correctly detected.


[  112.508000] firewire_ohci: Added fw-ohci device 0000:0f:02.0, OHCI version 1.10
[  112.838704] eth1: Broadcom NetXtreme II BCM5708 1000Base-T (B2) PCI-X 64-bit 133MHz found at mem f8000000, IRQ 16, node addr 0019b9ed7670
[  112.840981] net eth1_rename: device_rename: sysfs_create_symlink failed (-17)
[  113.004177] firewire_core: created new fw device fw0 (0 config rom retries, S800)
[  113.672681] net eth1: device_rename: sysfs_create_symlink failed (-17)
[  113.672729] udev: renamed network interface eth0 to eth1
[  113.692225] net eth0: device_rename: sysfs_create_symlink failed (-17)
[  113.692276] udev: renamed network interface eth1_rename to eth0
[  114.322997] Filesystem "dm-5": Disabling barriers, not supported by the underlying device
[  114.706628] Filesystem "dm-3": Disabling barriers, not supported by the underlying device
[  114.720217] XFS mounting filesystem dm-3
[  114.795866] Ending clean XFS mount for filesystem: dm-3
[  114.897802] Adding 42877444k swap on /dev/evms/swap0.  Priority:-1 extents:1 across:42877444k
[  120.920862] bnx2: eth0: using MSI
[  122.520834] bnx2: eth0 NIC Copper Link is Up, 100 Mbps full duplex
[  144.038242] firewire_core: giving up on config rom for node id ffc0
[  144.142736] firewire_core: giving up on config rom for node id ffc1
Comment 1 Stefan Richter 2008-01-15 23:53:42 UTC
After the two "giving up" messages, do /dev/fw0 and /sys/bus/firewire/devices/fw0/ still exist?
Comment 2 Joshua Schmidlkofer 2008-01-23 07:59:02 UTC
I am waiting for the next Maintenance Window to get this info.  Is there anything else I can do at the same time?
Comment 3 Stefan Richter 2008-01-23 08:15:13 UTC
If access to the hardware is limited, then this is troublesome.  It's already difficult to go after this without me having direct access to affected hardware to directly experiment with it to get to an idea about it.

However, if we are lucky then this is the same problem as Jarod is currently working on.  https://bugzilla.redhat.com/show_bug.cgi?id=429598
So maybe we get a patch for your testing pleasure some time soon.  Since you run Gentoo and 2.6.24-rc and have both FireWire stacks installed --- and if you don't need FireWire 24/7 --- you could hopefully switch between the working old drivers and patched new drivers when we get a patch out before a maintenance window at your site, right?
Comment 4 Jarod Wilson 2008-01-23 10:58:16 UTC
Yep, this looks like the same thing I'm debugging right now. Hoping to have the fix isolated by the end of the day... :)
Comment 5 Stefan Richter 2008-01-25 00:25:06 UTC
We have a patch series now which fixes similar or same issues on Jarod's test setup.  I will prepare a combo patch for you to test later today.
Comment 6 Stefan Richter 2008-01-25 10:20:20 UTC
Please try patch v610 or later from http://me.in-berlin.de/~s5r6/linux1394/updates/.  The patch for 2.6.24 is also applicable to late 2.6.24-rc*s.  If you have the firewire-* drivers configured as modules, you only need to "make modules; sudo make modules_install" after patching and to reload the firewire modules.  I.e. no reboot necessary.
Comment 7 Stefan Richter 2008-02-09 09:44:34 UTC
The mentioned patches have been committed to Linus' tree.  Please reopen the bug if the problem persists with either Linus' latest or with a kernel patched with my updates.

Note You need to log in before you can comment on or make changes to this bug.