Bug 6321 - Kernel oops unplugging external liteon dvd/cdrw combo drive
Kernel oops unplugging external liteon dvd/cdrw combo drive
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 normal
Assigned To: Pete Zaitcev
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2006-04-03 04:08 UTC by Priit Laes
Modified: 2007-01-31 09:35 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.16-gentoo
Tree: Mainline
Regression: ---


Attachments

Description Priit Laes 2006-04-03 04:08:51 UTC
Distribution: Gentoo
Hardware Environment: Dell Latitude D610
Software Environment: Gentoo GNU/Linux
Problem Description: Removed the drive, plugged in again, noticed oops.


Buffer I/O error on device uba, logical block 277
lost page write due to I/O error on uba
end_request: I/O error, dev uba, sector 1120
end_request: I/O error, dev uba, sector 1124
end_request: I/O error, dev uba, sector 1156
end_request: I/O error, dev uba, sector 1176
end_request: I/O error, dev uba, sector 1192
end_request: I/O error, dev uba, sector 1196
end_request: I/O error, dev uba, sector 1208
end_request: I/O error, dev uba, sector 1224
Unable to handle kernel paging request at virtual address 00007301
 printing eip:
b01fcff0
*pde = 00000000
Oops: 0000 [#1]
PREEMPT
Modules linked in: fglrx ipw2200 ieee80211 ieee80211_crypt intel_agp agpgart
CPU:    0
EIP:    0060:[<b01fcff0>]    Tainted: P      VLI
EFLAGS: 00010286   (2.6.16-gentoo #2)
EIP is at kobject_get_path+0x20/0xb4
eax: 00000000   ebx: 00000001   ecx: ffffffff   edx: 000000d0
esi: c3fed67c   edi: 00007301   ebp: bea73edc   esp: bea73ebc
ds: 007b   es: 007b   ss: 0068
Process umount (pid: 32046, threadinfo=bea72000 task=b6036570)
Stack: <0>c3fed67c 0000001a bea73edc cfd02380 c3fed614 c4e7d658 bea73edc b01f84f0
       00000002 00000012 ce43984d b03e0ab0 b01f8435 cfd02410 b01fd2cf 0000001a
       ce43984d 000007b3 b0396999 c4e7d640 ce439800 b63f0ec0 b03e0a54 b03e0a40
Call Trace:
 [<b01f84f0>] block_uevent+0xbb/0x150
 [<b01f8435>] block_uevent+0x0/0x150
 [<b01fd2cf>] kobject_uevent+0x1d8/0x3b1
 [<b0150627>] kill_block_super+0x16/0x2d
 [<b01506dc>] deactivate_super+0x4d/0x60
 [<b016294e>] sys_umount+0x1df/0x1e9
 [<b01129c2>] do_page_fault+0x164/0x4ba
 [<b0102a73>] sysenter_past_esp+0x54/0x75
Code: ff ff eb 02 31 f6 5b 89 f0 5e c3 55 57 56 89 c6 53 bb 01 00 00 00 83 ec 0c
89 04 24 8b 3e 85 ff 0f 84 8c 00 00 00 31 c0 83 c9 ff <f2> ae f7 d1 49 8b 76 24
8d 5c 19 01 85 f6 75 e1 85 db 74 73 89
 <6>usb 1-5: new high speed USB device using ehci_hcd and address 5
usb 1-5: configuration #2 chosen from 1 choice
ub(1.5): GetMaxLUN returned 0, using 1 LUNs
 ubb: unknown partition table
UDF-fs INFO UDF 0.9.8.1 (2004/29/09) Mounting volume 'Star Wreck: In the
Pirkinning', timestamp 2005/08/22 08:17 (10b4)
VFS: busy inodes on changed media.
end_request: I/O error, dev ubb, sector 1056
end_request: I/O error, dev ubb, sector 256
printk: 12 messages suppressed.
Buffer I/O error on device ubb, logical block 64
lost page write due to I/O error on ubb
end_request: I/O error, dev ubb, sector 256
Buffer I/O error on device ubb, logical block 64
lost page write due to I/O error on ubb
usb 1-5: USB disconnect, address 5
Comment 1 Greg Kroah-Hartman 2006-08-30 01:12:44 UTC
ub issue...
Comment 2 Andrew Morton 2007-01-31 01:52:36 UTC
ub dude added.

I think ub is being abandoned.  What should Priit do?
Comment 3 Priit Laes 2007-01-31 02:08:33 UTC
I don't have that drive anymore :(
Comment 4 Pete Zaitcev 2007-01-31 09:29:47 UTC
The good thing about ub is how it exposes issues like this. Personally, I suspect
Jens playing with lifetime rules in block API again, like in the last CFQ case.
Comment 5 Pete Zaitcev 2007-01-31 09:35:48 UTC
I just noticed that it's 2.6.16. Then it _is_ that lifetime issue.
I was able to work around it in ub.

http://marc.theaimsgroup.com/?l=linux-usb-devel&m=114664063712228&w=2

Note You need to log in before you can comment on or make changes to this bug.