Bug 5788 - ASUS A6k Notebook hangs on boot while initializing ehci_hcd
ASUS A6k Notebook hangs on boot while initializing ehci_hcd
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
i386 Linux
: P2 blocking
Assigned To: acpi_bios
:
Depends on:
Blocks: USB
  Show dependency treegraph
 
Reported: 2005-12-27 12:32 UTC by Christoph Goesgens
Modified: 2007-03-07 23:27 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.12-2.6.15-rc5
Tree: Mainline
Regression: ---


Attachments
Kernel config for 2.6.15-rc5 where this bug occurs (33.07 KB, text/plain)
2005-12-27 12:35 UTC, Christoph Goesgens
Details

Description Christoph Goesgens 2005-12-27 12:32:25 UTC
Most recent kernel where this bug did not occur: untested
Distribution: Debian Sarge
Hardware Environment: 
ASUS A6K Turion64 MT 30
lspci output: 
0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS]: Unknown device 0756
(rev 02)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 0004
0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media
IO] (rev 36)
0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
0000:00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
Controller (rev a0)
0000:00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
0000:00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
0000:00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
0000:00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
0000:00:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless
LAN Controller (rev 03)
0000:00:0a.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
0000:00:0a.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
0000:00:0a.2 0805: Ricoh Co Ltd: Unknown device 0822 (rev 17)
0000:00:0a.3 System peripheral: Ricoh Co Ltd: Unknown device 0592 (rev 08)
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0167
(rev a1)

Software Environment: During Boot-up
Problem Description: Kernel stalls while initializing ehci_hcd
last output while booting:
GSI 19 sharing vector 0xC1 and IRQ 19
ACPI: PCI Interrupt 0000:00:03.3[D] -> GSI 23 (level, low) -> IRQ 19
ehci_hcd 0000:00:03.3: EHCI Host Controller

this has been tested with both gcc-3.3 and gcc-3.4.
Odd enough, sometimes this happens when the notebook is plugged in, and as of
yet failed every time to boot as soon as it runs on battery.

Steps to reproduce:
Comment 1 Christoph Goesgens 2005-12-27 12:35:41 UTC
Created attachment 6893 [details]
Kernel config for 2.6.15-rc5 where this bug occurs
Comment 2 Maxxer 2006-01-02 13:34:02 UTC
This updated DSDT

http://acpi.sourceforge.net/dsdt/view.php?id=528

SOLVES THE PROBLEM!!
Comment 3 Maxxer 2006-01-03 02:02:36 UTC
well, should... I still have bios 206 and further tests tell me it's not enough
(ehci still crashes). I'll try the new bios and report back.
Comment 4 Greg Kroah-Hartman 2006-01-04 14:31:23 UTC
Marking closed.
Comment 5 Maxxer 2006-01-05 01:06:09 UTC
why did you close the bug? It's still unsolved!

I tried upgrading bios but sadly it didn't solve the problem.
I tried 2.6.12 and it seems not to crash. I booted at least 4 or 5 times, from
battery, without problems. 
Comment 6 Greg Kroah-Hartman 2006-01-07 15:42:02 UTC
Sorry, I saw comment #2 and thought it was fixed.
Comment 7 Maxxer 2006-01-19 07:41:48 UTC
someone reported me that completely disabling ACPI from kernel makes the pc boot
fine and correctly load the ehci module.


This guy in Gentoo forum 
http://forums.gentoo.org/viewtopic-t-414765-highlight-a6k.html
said he solved the problem by fixing the dsdt. Sadly I can't contact him.
Comment 8 Greg Kroah-Hartman 2006-01-23 12:39:07 UTC
Sounds like an acpi issue, reassigning...
Comment 9 Greg Kroah-Hartman 2006-02-14 17:51:13 UTC
This might be fixed in 2.6.16-rc4.  Can you test that out and let us know?
Comment 10 Maxxer 2006-02-15 08:51:54 UTC
You can bet I will, as soon as it get available! :-)
Comment 11 Maxxer 2006-02-19 02:03:22 UTC
I've installed the kernel yesterday, and IT SEEMS TO SOLVE THE PROBLEM!
I tried warm and cold boot, from battery and AC, and every time it loaded the
ehci module correctly without crashing.
I will do further tests today and tomorrow, and will report back again!

So far, THANK YOU A LOT!
Comment 12 Maxxer 2006-02-23 03:05:40 UTC
I've been using the new kernel for some time right now.
I've done cold and warm boots, with and without AC, and the module was loaded
every time without crashing. 
I've also attached an USB2 device, and worked fine.

To me, the thing is solved, THANK YOU AGAIN!


I got negative response from a french friend using an ASUS A6Km still concerning
ACPI/EHCI, but I don't know if it's strictly related to this bug.

I also wrote a mail to two other friends who experienced the kernel hang, but I
still have to get a reply from them.
I will post here any other news.
Comment 13 Paweł Szczekutowicz 2006-03-02 11:06:55 UTC
On A6Km / AC connected - when booting with usb mouse pluged-in kernel hangs just
after infomartion about processor type. When nothing is connected to usb
everything works fine ( battery status, processor stepting, acpi thermal shows
correct temperature ) and after full system boot when i connect usb mouse it
works without any problems...
Comment 14 Paweł Szczekutowicz 2006-03-03 09:14:24 UTC
it hangs on evxfevnt ( evxfevnt-0091 )
Comment 15 Greg Kroah-Hartman 2006-03-06 10:53:46 UTC
Ok, closing as fixed, as the original bios fix is in the kernel tree.

If you still have other problems, please open them as new bugs.

Note You need to log in before you can comment on or make changes to this bug.