Bug 55901 - AR9485 Poor Performance with ath9k driver
AR9485 Poor Performance with ath9k driver
Status: CLOSED DUPLICATE of bug 49201
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-29 00:32 UTC by Ilya
Modified: 2013-10-15 16:02 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.8.4
Tree: Mainline
Regression: No


Attachments

Description Ilya 2013-03-29 00:32:16 UTC
The issue is a weak signal and dropped connections with AR9485 wireless card and the ath9k driver on Ubuntu 12.10. The same device booted in Win8 has good performance along with other devices connected to the same access point. Below are the details of the issue:

First, here are some data points showing distance from the AP and signal strength:

0 feet:           Link Quality=61/70  Signal level=-49 dBm

10 feet:           Link Quality=37/70  Signal level=-73 dBm

20 feet:           Link Quality=30/70  Signal level=-80 dBm

30 feet:           Link Quality=29/70  Signal level=-81 dBm

40 feet:           Link Quality=31/70  Signal level=-79 dBm

At 50 feet the connection dropped

1. I opened the laptop and verified that both antennas are correctly connected.

2. Laptop model: Asus S400CA

3. OS: Ubuntu 12.10, kernel version 3.8.4-030804

4. Access Point:

Manufacturer: NETGEAR, Inc.
Model: WNDR3300
Model Number: WNDR3300

5. Loaded latest ath9k driver from

https://www.kernel.org/pub/linux/kernel/projects/backports/2013/03/26/

(downloaded compat-drivers-2013-03-26-u.tar.gz)

6. lspci -nn 

02:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)

7.iw dev wlan0 scan (roommate chosen ssid :)

BSS 30:46:9a:67:e9:d7 (on wlan0) -- associated
	TSF: 332971938415 usec (3d, 20:29:31)
	freq: 2462
	beacon interval: 100
	capability: ESS Privacy ShortSlotTime (0x0411)
	signal: -87.00 dBm
	last seen: 1224 ms ago
	Information elements from Probe Response frame:
	SSID: CIA
	Supported rates: 1.0* 2.0* 5.5* 11.0* 18.0 24.0 36.0 54.0 
	DS Parameter set: channel 11
	ERP: Barker_Preamble_Mode
	RSN:	 * Version: 1
		 * Group cipher: TKIP
		 * Pairwise ciphers: CCMP TKIP
		 * Authentication suites: PSK
		 * Capabilities: 16-PTKSA-RC (0x000c)
	Extended supported rates: 6.0 9.0 12.0 48.0 
	WPS:	 * Version: 1.0
		 * Wi-Fi Protected Setup State: 2 (Configured)
		 * Selected Registrar: 0x0
		 * Response Type: 3 (AP)
		 * UUID: 1900f435-2062-8334-31c4-448994e5aa5c
		 * Manufacturer: NETGEAR, Inc.
		 * Model: WNDR3300
		 * Model Number: WNDR3300
		 * Serial Number: 01
		 * Primary Device Type: 6-0050f204-1
		 * Device name: WNDR3300
		 * Config methods: Label, PBC
		 * RF Bands: 0x3
	WPA:	 * Version: 1
		 * Group cipher: TKIP
		 * Pairwise ciphers: CCMP TKIP
		 * Authentication suites: PSK
		 * Capabilities: 16-PTKSA-RC (0x000c)
	WMM:	 * Parameter version 1
		 * u-APSD
		 * BE: CW 15-1023, AIFSN 3
		 * BK: CW 15-1023, AIFSN 7
		 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
		 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

8. dmesg | grep wlan0

[   21.932648] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   26.891333] wlan0: authenticate with 30:46:9a:67:e9:d7
[   26.908968] wlan0: send auth to 30:46:9a:67:e9:d7 (try 1/3)
[   26.914636] wlan0: authenticated
[   26.918506] wlan0: associate with 30:46:9a:67:e9:d7 (try 1/3)
[   26.956682] wlan0: RX AssocResp from 30:46:9a:67:e9:d7 (capab=0x411 status=0 aid=5)
[   26.956746] wlan0: associated
[   26.956761] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  145.733016] wlan0: authenticate with 30:46:9a:67:e9:d7
[  145.736609] wlan0: send auth to 30:46:9a:67:e9:d7 (try 1/3)
[  145.741075] wlan0: authenticated
[  145.743115] wlan0: associate with 30:46:9a:67:e9:d7 (try 1/3)
[  145.747366] wlan0: RX AssocResp from 30:46:9a:67:e9:d7 (capab=0x411 status=0 aid=1)
[  145.747522] wlan0: associated

9. dmesg | grep ath9k

[   19.668649] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
Comment 1 Ilya 2013-03-29 00:34:19 UTC
Similar bug:

https://bugzilla.kernel.org/show_bug.cgi?id=49201
Comment 2 Sujith 2013-06-03 01:56:04 UTC
Can you disable PowerSave and see if things improve ?
("iw dev wlan0 set power_save off).
Comment 3 Sujith 2013-06-14 02:20:33 UTC
This is a duplicate of 49201, which has been fixed. So this bug can be closed.
Comment 4 John W. Linville 2013-10-15 16:02:42 UTC

*** This bug has been marked as a duplicate of bug 49201 ***

Note You need to log in before you can comment on or make changes to this bug.