Bug 5067 - [Patch] asus_acpi hotkeys do not work on Samsung P30
[Patch] asus_acpi hotkeys do not work on Samsung P30
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Platform
i386 Linux
: P2 normal
Assigned To: Karol Kozimor
:
: 5092 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 07:26 UTC by Peter Baumann
Modified: 2010-10-08 18:17 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.13-rc5
Tree: Mainline
Regression: ---


Attachments
Here is the patch mentioned in the URL (1.07 KB, patch)
2005-08-15 07:28 UTC, Peter Baumann
Details | Diff
Updated comments (1.44 KB, patch)
2005-09-14 01:06 UTC, Karol Kozimor
Details | Diff
Fix for 2.6.14 (1.51 KB, patch)
2005-10-29 08:20 UTC, Hanno Boeck
Details | Diff
my previous patch rediffed, updated (1.58 KB, patch)
2005-12-22 09:13 UTC, Karol Kozimor
Details | Diff

Description Peter Baumann 2005-08-15 07:26:52 UTC
Distribution: debian sarge
Hardware Environment: Samsung P30
Software Environment:
Problem Description:
I get an OOPS if I try to load asus_acpi as modul. After a little googling I find 
this link with the a patch wich solved my problem. Applying this made my hotkeys
work again.

http://sourceforge.net/mailarchive/message.php?msg_id=12203231
Comment 1 Peter Baumann 2005-08-15 07:28:24 UTC
Created attachment 5642 [details]
Here is the patch mentioned in the URL
Comment 2 Karol Kozimor 2005-09-12 13:03:53 UTC
Would you mind checking this link:  
http://bugzilla.kernel.org/show_bug.cgi?id=5092#c6  
Comment 3 Peter Baumann 2005-09-13 14:37:10 UTC
The patch mentioned in comment 6 in #5092
(http://bugzilla.kernel.org/attachment.cgi?id=5982&action=view) didn't fix my
problem, but the tip to specify acpi=strict as kernel parameter helped me and I
was able to boot my notebook (asus_acpi is compiled in; the notebook will boot
if asus_acpi is compiled as a module, but I get an oops).

This seems strange because the patch does specify acpi=strict inside asus_acpi.c.
I even tried to move the statement  [...] acpi_strict = 1;  a little higher in
the function (after the declaration of   acpi_status status;) but it didn't
help.  Tomorrow I'll try to have the acpi_strict=1; for the whole function. If
this will fix my problem you'll hear from me :-)
Comment 4 Karol Kozimor 2005-09-14 00:54:49 UTC
OK, my bad, I missed the fact that acpi_gbl_enable_interpreter_slack (which is  
what we're after) is set only at boot. Working that out would require either a  
few changes to drivers/acpi/dispatcher/dsutils.c or exporting  
acpi_gbl_enable_interpreter_slack. 
Comment 5 Karol Kozimor 2005-09-14 01:00:31 UTC
*** Bug 5092 has been marked as a duplicate of this bug. ***
Comment 6 Karol Kozimor 2005-09-14 01:06:14 UTC
Created attachment 6006 [details]
Updated comments

This is functionally identical to the first patch, but the comments are updated
appropriately. 

Please note that this patch is still only a workaround and I believe we need a
mechanism to make the interpreter behave deterministically (i.e. disable
implicit return) at run-time (just as we can disable higher Cx states).
Comment 7 Benjamin Eikel 2005-10-29 08:12:24 UTC
I wanted to install the new kernel 2.6.14. Without the patch I still get the
oops. But I think there were changes to the asus_acpi.c because the patch does
not work:

root@hostname:/usr/src# patch linux-2.6.14/drivers/acpi/asus_acpi.c asus_acpi.patch
patching file linux-2.6.14/drivers/acpi/asus_acpi.c
Hunk #1 FAILED at 990.
Hunk #2 FAILED at 1019.
2 out of 2 hunks FAILED -- saving rejects to file
linux-2.6.14/drivers/acpi/asus_acpi.c.rej
Comment 8 Hanno Boeck 2005-10-29 08:20:25 UTC
Created attachment 6418 [details]
Fix for 2.6.14

New patch for 2.6.14, got it from Christian Aichinger (so all credits to him).
Comment 9 Benjamin Eikel 2005-10-29 09:50:27 UTC
The new fix for 2.6.14 is working. Thank you! (VERIFIED)
Comment 10 Karol Kozimor 2005-12-22 09:13:32 UTC
Created attachment 6879 [details]
my previous patch rediffed, updated

Rediffed against 2.6.15-rc6, also plugs a leak my previous patch introduced.
Note: I still prefer this patch from the other one.
Comment 11 Benjamin Eikel 2005-12-27 09:05:34 UTC
I just compiled kernel 2.6.14.5 with your new patch and it works without problems.

Will this patch be integrated into the kernel sources? Because without the patch
I still get the kernel oops.
Comment 12 Len Brown 2005-12-28 23:44:01 UTC
applied patch in comment #10 to acpi-test tree
Comment 13 Len Brown 2007-03-07 22:58:58 UTC
shipped in linux-2.6.16
closed.

Note You need to log in before you can comment on or make changes to this bug.