Bug 43190 - Syslog fills with message about reading an empty SD card slot.
Syslog fills with message about reading an empty SD card slot.
Status: RESOLVED DUPLICATE of bug 43191
Product: Drivers
Classification: Unclassified
Component: MMC/SD
All Linux
: P1 normal
Assigned To: drivers_mmc-sd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 18:58 UTC by Chris Fahlman
Modified: 2012-05-02 04:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.4.0-030400rc4-generic
Tree: Mainline
Regression: No


Attachments
cpu info (1.47 KB, text/plain)
2012-05-01 18:59 UTC, Chris Fahlman
Details
modules (3.76 KB, text/plain)
2012-05-01 19:00 UTC, Chris Fahlman
Details
ioports (1.55 KB, text/plain)
2012-05-01 19:00 UTC, Chris Fahlman
Details
iomem (2.46 KB, text/plain)
2012-05-01 19:01 UTC, Chris Fahlman
Details
lspci (57.01 KB, text/plain)
2012-05-01 19:01 UTC, Chris Fahlman
Details
scsi (495 bytes, text/plain)
2012-05-01 19:02 UTC, Chris Fahlman
Details

Description Chris Fahlman 2012-05-01 18:58:48 UTC
My Laptop has an SD card slot.

If there is no card in the slot, the syslog repeatedly, every 50 seconds or so, records messages like:

May  1 11:40:41 dellie-linux kernel: [ 8793.621511] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
May  1 11:40:41 dellie-linux kernel: [ 8793.623878] sd 6:0:0:0: [sdb] Asking for cache data failed
May  1 11:40:41 dellie-linux kernel: [ 8793.623886] sd 6:0:0:0: [sdb] Assuming drive cache: write through
May  1 11:41:33 dellie-linux kernel: [ 8845.337522] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
May  1 11:41:33 dellie-linux kernel: [ 8845.339930] sd 6:0:0:0: [sdb] Asking for cache data failed
May  1 11:41:33 dellie-linux kernel: [ 8845.339939] sd 6:0:0:0: [sdb] Assuming drive cache: write through


Additional info:
Linux version 3.4.0-030400rc4-generic (apw@gomeisa) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5.1) ) #201204230908 SMP Mon Apr 23 13:10:03 UTC 2012
Comment 1 Chris Fahlman 2012-05-01 18:59:44 UTC
Created attachment 73146 [details]
cpu info
Comment 2 Chris Fahlman 2012-05-01 19:00:17 UTC
Created attachment 73147 [details]
modules
Comment 3 Chris Fahlman 2012-05-01 19:00:45 UTC
Created attachment 73148 [details]
ioports
Comment 4 Chris Fahlman 2012-05-01 19:01:17 UTC
Created attachment 73149 [details]
iomem
Comment 5 Chris Fahlman 2012-05-01 19:01:46 UTC
Created attachment 73150 [details]
lspci
Comment 6 Chris Fahlman 2012-05-01 19:02:18 UTC
Created attachment 73151 [details]
scsi
Comment 7 Chris Ball 2012-05-01 19:13:22 UTC
Thanks for the report -- this SD controller is presenting itself as a SCSI device, and these messages are coming from the SCSI layer.  So, the MMC stack isn't involved, and you should report this to the Linux SCSI maintainers, please.

It looks like the linux-scsi@vger.kernel.org is a good way to do that:  mailing lists tend to get read more than Bugzilla, in my experience.
Comment 8 Chris Fahlman 2012-05-02 04:07:43 UTC

*** This bug has been marked as a duplicate of bug 43191 ***

Note You need to log in before you can comment on or make changes to this bug.