Bug 43088 - [965GM] hang at DPMS time
[965GM] hang at DPMS time
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
https://bugs.freedesktop.org/show_bug...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 20:28 UTC by Martin Senft
Modified: 2012-04-18 22:12 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.2.14
Tree: Mainline
Regression: No


Attachments
lspci -vvnn (25.57 KB, text/x-log)
2012-04-10 20:28 UTC, Martin Senft
Details
dmesg output (96.81 KB, text/plain)
2012-04-10 20:28 UTC, Martin Senft
Details
Wait for pending fb operations before any modeset. (2.89 KB, patch)
2012-04-10 22:04 UTC, Chris Wilson
Details | Diff

Description Martin Senft 2012-04-10 20:28:00 UTC
Created attachment 72873 [details]
lspci -vvnn

Hello,

I have the Ubuntu 12.04 beta2 x86_64 with a mainline kernel 3.2.14 installed on a FUJITSU SIEMENS ESPRIMO Mobile M9400 notebook with an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (lspci -vvnn attached), and I'm experiencing GPU hangups several times a day (dmesg output attached).

Everything is well as long as I don't leave the computer for long enough for a DPMS powersaving to kick in (set to 5 minutes in Unity). If I'm away long enough, there is a good chance I'll find the GPU hanged up upon return. Unfortunately, I'm not able to reproduce this issue at will and have to wait for it to happen.

If there is anything I can do to help to resolve this, I'll gladly do so.

Martin Senft
Comment 1 Martin Senft 2012-04-10 20:28:32 UTC
Created attachment 72874 [details]
dmesg output
Comment 2 Daniel Vetter 2012-04-10 20:49:00 UTC
Well, first can you please try 3.4-rc2 (or newer) and rehang your system? That improves the error handling and should dump you a big i915_error_state into debugfs somewhere when the issue happens. Please grab that file and attach it to the bug report.
Comment 3 Chris Wilson 2012-04-10 20:54:31 UTC
Likely to be danvet/drm-intel-fixes:

commit 14667a4bde4361b7ac420d68a2e9e9b9b2df5231
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Apr 3 17:58:35 2012 +0100

    drm/i915: Finish any pending operations on the framebuffer before disabling
 
http://cgit.freedesktop.org/~danvet/drm-intel/commit/?h=drm-intel-fixes&id=14667a4bde4361b7ac420d68a2e9e9b9b2df5231
Comment 4 Chris Wilson 2012-04-10 22:04:17 UTC
Created attachment 72875 [details]
Wait for pending fb operations before any modeset.

In addition it would also be useful to try this patch on top of what we already have queued for drm-intel-fixes. Oh, and there is a further patch in xf86-video-intel/sna to reduce the race window even further.
Comment 5 Martin Senft 2012-04-16 21:17:36 UTC
I would like to thank you both for your quick response and suggestions.

I have tried kernel version 3.4 before submitting this bug and it was much better than version 3.2. There was only one hang in several days. However, version 3.4-rc2 looks even better and offered a hang-free experience for the last six days. I will be testing other release candidates when available and report if they hang on my system.
Comment 6 Daniel Vetter 2012-04-16 21:36:44 UTC
You need 3.4-rc3 for the patch mentioned in comment #3.
Comment 7 Jesse Barnes 2012-04-18 22:12:24 UTC
Cool, sounds like it's fixed then.  Thanks for testing!  Please re-open if 3.4-rc3 or newer still gives you trouble.

Note You need to log in before you can comment on or make changes to this bug.