Bug 27322 - [i915G] "render error detected" after resume
[i915G] "render error detected" after resume
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 16444
  Show dependency treegraph
 
Reported: 2011-01-22 06:47 UTC by Artem Anisimov
Modified: 2012-04-18 20:21 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.38
Tree: Mainline
Regression: Yes


Attachments
output of lspci (11.99 KB, text/plain)
2011-01-22 06:47 UTC, Artem Anisimov
Details

Description Artem Anisimov 2011-01-22 06:47:26 UTC
Created attachment 44752 [details]
output of lspci

After resume I see the following error in my dmesg:

PM: early resume of devices complete after 2.512 msecs
i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
i915 0000:00:02.0: setting latency timer to 64
render error detected, EIR: 0x00000010
page table error
  PGTBL_ER: 0x00000001
[drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
render error detected, EIR: 0x00000010
page table error
  PGTBL_ER: 0x00000001

  There is another bug #15187 concerning render error after resume, but my PFTBL_ER is different so I decided to file a separate report. Fortunately, in my case this error does not lead to system hang.

  I have not encountered this error with 2.6.35 and xf86-video-intel-2.12.0. Now I am using 2.6.37 and xf86-video-intel 2.14.0.

  I have attached output of lspci.
Comment 1 Rafael J. Wysocki 2011-01-22 20:32:50 UTC
Can you check if the 2.6.36.y kernels are affected too, please?
Comment 2 Artem Anisimov 2011-01-23 08:40:31 UTC
I have checked 2.6.36 and 2.6.36.3. Unfortunately, both these kernels exhibit this behaviour.

I've also tried to downgrade xf86-video-intel to 2.13.0, but the bug persisted.
Comment 3 Chris Wilson 2011-01-23 10:56:00 UTC
The reported error is a "host memory access through an invalid PTE". Which is very bizarre because all the PTEs point to a real page (the unused entries point to the same scratch page). We do that because the GPU doesn't respect page boundaries when prefetching....

But this a violation during CPU access!
Comment 4 Artem Anisimov 2011-03-26 15:06:40 UTC
In 2.6.38.1 the bug has changed: now I get the following:

render error detected, EIR: 0x00000010
page table error
  PGTBL_ER: 0x00000003
[drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
render error detected, EIR: 0x00000010
page table error
  PGTBL_ER: 0x00000003
Comment 5 Maksim 2011-08-08 13:58:36 UTC
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)

having this problem, im using 3.0.0 kernel
Comment 6 Daniel Vetter 2012-03-25 13:43:39 UTC
Please retest on 3.3.
Comment 7 Jesse Barnes 2012-04-18 20:21:58 UTC
Probably fixed by now.  Please re-open if not.

Note You need to log in before you can comment on or make changes to this bug.