Bug 23702 - [945GM] System locks when running glxgears, mplayer, screensavers
[945GM] System locks when running glxgears, mplayer, screensavers
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
i386 Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-25 02:50 UTC by nettxzl
Modified: 2012-04-18 21:39 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35, 2.6.36
Tree: Mainline
Regression: No


Attachments
syslog report of the bug (3.17 KB, text/plain)
2010-11-25 02:50 UTC, nettxzl
Details
other reports of the bug (2.69 KB, text/plain)
2010-11-25 02:55 UTC, nettxzl
Details

Description nettxzl 2010-11-25 02:50:42 UTC
Created attachment 38112 [details]
syslog report of the bug

Hardware: Acer TravelMate 6291 with Intel 945GM graphics
OS: Linux (self-built, LFS/BLFS), 
  using Xorg 7.2 and driver xf86-video-intel-2.1.1

The system locks up completely when I start running e.g., mplayer to play videos (audio is ok), glxgears, or when a screensaver activates in Xscreensaver. (If I set Xscreensaver to give a blank screen rather than running a screensaver, then it's ok, there's no crash.) Everything freezes. The display is frozen and there's no response to the keyboard and touchpad.
Comment 1 nettxzl 2010-11-25 02:55:28 UTC
Created attachment 38122 [details]
other reports of the bug
Comment 2 Chris Wilson 2010-12-16 15:04:53 UTC

*** This bug has been marked as a duplicate of bug 23712 ***
Comment 3 Chris Wilson 2010-12-16 15:05:22 UTC

*** This bug has been marked as a duplicate of bug 23172 ***
Comment 4 nettxzl 2011-03-20 03:34:24 UTC
I've tried out the patch (applied to 2.6.38) that was attached to the bug 23172 report, but the system still crashes when I run glxgears, play videos, etc. I can only restart after disconnecting and reconnecting the power.
The sys.log for the entire session only shows gibberish like this: 

<CA>^@^@^@<83><BF>da^A^@^Z^O<85><BB>^@^@^@LJda^A^@^@^@^@^@j^@j,jX<FF>u^P<FF>u<F0>
W<E8><FD><A8>^F^@<83><C4>^X<85><C0><89><C6>^O<85><94>^@^@^@<83><BF>da^A^@^Z^O
<85><85>^@^@^@LJda^A^@^@^@^@^@j^@j^Tjn<FF>u^P<FF>u<F0>W<E8>Ǩ^F^@<83><C4>^X<85>
<C0><89><C6>ub<83><B
Comment 5 Chris Wilson 2011-03-21 08:58:06 UTC
The patch fixed the bug you first reported, after that we need new info. But seriously consider upgrading the userspace components of the driver as well.
Comment 6 nettxzl 2011-03-21 12:10:09 UTC
Yes, I know I should send more new info. I would if I knew how to get it. And yes, you're right, I need to upgrade the userspace components of the driver as well. But dependencies need to be upgraded as well. Basically, everything needs to be upgraded and I have to rebuild the whole system from scratch which I'm in the middle of doing now but it will take a while. So I guess I'll live with 2.6.34 until I have a new sytem.
Comment 7 Jesse Barnes 2012-04-18 21:39:53 UTC
Ok sounds like this is either fixed or you're getting new hardware, so I'll close. :)

Note You need to log in before you can comment on or make changes to this bug.