Bug 18382 - Webcam LIC-300 do not work
Webcam LIC-300 do not work
Status: RESOLVED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-13 05:48 UTC by Ruben Carlo Benante
Modified: 2012-08-13 16:31 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32-24
Tree: Mainline
Regression: No


Attachments

Description Ruben Carlo Benante 2010-09-13 05:48:12 UTC
Webcam:
  LG LIC-300
lsusb:
  Bus 002 Device 010: ID 0c45:60fc Microdia PC Camera with Mic (SN9C105)
Recommended driver from gspca:
  sonixj 0c45:60fc LG-LIC300
  gspca_main

System:
  Ubuntu lucid lynx

Problem:
  When plugged, the module sn9c102.ko is wrongly up automatically.
  I recall that this module used to work when I worked on an OpenSuse 11.0, together with gspca.ko.

dmesg:

[39466.232628] usb 2-1: new full speed USB device using uhci_hcd and address 10
[39466.417153] usb 2-1: configuration #1 chosen from 1 choice
[39466.433713] Linux video capture interface: v2.00
[39466.438158] sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
[39466.452357] usb 2-1: SN9C105 PC Camera Controller detected (vid:pid 0x0C45:0x60FC)
[39466.479014] usb 2-1: HV7131R image sensor detected
[39466.818999] usb 2-1: Initialization succeeded
[39466.819111] usb 2-1: V4L2 device registered as /dev/video0
[39466.819115] usb 2-1: Optional device control through 'sysfs' interface disabled
[39466.819156] usbcore: registered new interface driver sn9c102
[39466.821744] gspca: no symbol version for module_layout


  But here, even telling me /dev/video0 is registered, programs like camorama, camstrem and xawtv do not work. 

lsmod | grep video
videodev               40518  1 sn9c102
v4l1_compat            15495  1 videodev
v4l2_compat_ioctl32    12020  1 videodev
video                  20623  1 i915
output                  2503  1 video

xawtv -hwscan
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.32-24-generic)
looking for available devices
port 80-95
    type : Xvideo, image scaler
    name : Intel(R) Textured Video

port 96-96
    type : Xvideo, image scaler
    name : Intel(R) Video Overlay

/dev/video0: OK                         [ -device /dev/video0 ]
    type : v4l2
    name : SN9C1xx PC Camera
    flags:  capture  

camorama:
  Could not connect to video device (/dev/video0). Please check connection.

  Now, it's advised to modprobe gspca_sonixj. So I blacklisted the sn9c102 and modprobed the correct module.

dmesg:
[40911.530032] usb 2-1: new full speed USB device using uhci_hcd and address 12
[40911.697164] usb 2-1: configuration #1 chosen from 1 choice
[40911.714829] Linux video capture interface: v2.00
[40911.716375] gspca: no symbol version for module_layout
[40930.616504] gspca: main v2.7.0 registered
[40930.618587] usbcore: registered new interface driver sonixj
[40930.618654] sonixj: registered


And here again, nothing works.


lsmod | grep video
videodev               40518  1 gspca_main
v4l1_compat            15495  1 videodev
v4l2_compat_ioctl32    12020  1 videodev
video                  20623  1 i915
output                  2503  1 video


lsmod | grep spca
gspca_sonixj           22336  0 
gspca_main             25031  1 gspca_sonixj
videodev               40518  1 gspca_main



xawtv -hwscan
This is xawtv-3.95.dfsg.1, running on Linux/x86_64 (2.6.32-24-generic)
looking for available devices
port 80-95
    type : Xvideo, image scaler
    name : Intel(R) Textured Video

port 96-96
    type : Xvideo, image scaler
    name : Intel(R) Video Overlay
Comment 1 Jean-Francois Moine 2011-05-16 10:17:26 UTC
Does it work with newer kernels?

Note You need to log in before you can comment on or make changes to this bug.