Bug 1677 - boot hang: "ACPI: IRQ9 SCI: Level Trigger" - ATI
boot hang: "ACPI: IRQ9 SCI: Level Trigger" - ATI
Status: REJECTED DUPLICATE of bug 1269
Product: ACPI
Classification: Unclassified
Component: BIOS
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-12 21:50 UTC by Gustavo Michels
Modified: 2004-08-13 19:37 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0-test11
Tree: Mainline
Regression: ---


Attachments
dmesg -s40000 (acpi=off) (8.78 KB, text/plain)
2003-12-12 21:51 UTC, Gustavo Michels
Details
dmidecode (11.33 KB, text/plain)
2003-12-12 21:54 UTC, Gustavo Michels
Details
acpidmp (115.70 KB, text/plain)
2003-12-12 21:54 UTC, Gustavo Michels
Details
lspci -vv (9.19 KB, text/plain)
2003-12-12 21:55 UTC, Gustavo Michels
Details
cat /proc/interrupts (519 bytes, text/plain)
2003-12-12 21:55 UTC, Gustavo Michels
Details
patch to enable verbose3 messages (677 bytes, patch)
2003-12-15 09:09 UTC, Len Brown
Details | Diff

Description Gustavo Michels 2003-12-12 21:50:34 UTC
Distribution: Gentoo Linux
Hardware Environment: Laptop HP Pavilion ze4430us

Problem Description: Kernel hangs with message "ACPI: IRQ9 SCI: Level Trigger". 
Only bootable if acpi=off is passed as option. I applied the latest patch 
available (acpi-20031203-2.6.0-test11.diff.bz2) with the same results.

I tried pci=noacpi and noapic also, no luck.

Also tried 2.6.0.test10-mm1, same thing.
Comment 1 Gustavo Michels 2003-12-12 21:51:25 UTC
Created attachment 1660 [details]
dmesg -s40000 (acpi=off)
Comment 2 Gustavo Michels 2003-12-12 21:54:10 UTC
Created attachment 1661 [details]
dmidecode
Comment 3 Gustavo Michels 2003-12-12 21:54:41 UTC
Created attachment 1662 [details]
acpidmp
Comment 4 Gustavo Michels 2003-12-12 21:55:13 UTC
Created attachment 1663 [details]
lspci -vv
Comment 5 Gustavo Michels 2003-12-12 21:55:37 UTC
Created attachment 1664 [details]
cat /proc/interrupts
Comment 6 Shaohua 2003-12-14 16:23:14 UTC
try acpi_pic_sci=level, please
Comment 7 Len Brown 2003-12-15 09:07:17 UTC
Does it still fail if you boot with pci=noacpi? 
 
> ACPI: IRQ9 SCI: Level Trigger 
This means that the kernel found IRQ 9 already set to level triggered, 
so "acpi_pic_sci=level" should not have any effect.  (acpi_pic_sci=edge may effect 
the problem, but there is no indication that it is the right thing to do) 
 
Seems more like we're getting some sort of event before we're ready -- should 
be able to confirm by enabling debugging output. 
 
 
Comment 8 Len Brown 2003-12-15 09:09:31 UTC
Created attachment 1667 [details]
patch to enable verbose3 messages

Please apply this patch to enable verbose debugging and report the last thing
it prints before the hang.

thanks,
-Len
Comment 9 Gustavo Michels 2003-12-15 09:40:32 UTC
I am currently compiling KDE so currently I can't give you results for the tests 
you asked.

I can add one thing: ACPI works if I disable Local APIC support on uniprocessors 
and IO-APIC support on uniprocessors on a test11 kernel (unpatched).

I'll come back when KDE finishes so I can send your test results.
Comment 10 Gustavo Michels 2003-12-15 14:07:17 UTC
Hi guys

I patched the kernel as you asked but I get no debug messages. I am using the 
plain test11 source (I didn't apply the latest patch available at SF) and I 
don't get that SCI message anymore. Now all I get is "spurious 8259A interrupt: 
IRQ7." right after "ACPI: Subsystem revision 20031002" and it hangs.

That "acpi_pic_sci=level" didn't change anything. Also pci=noacpi produces the 
same problem.

I'll try to get a serial console so I can put the entries here.
Comment 11 Georg Greve 2004-01-22 06:17:16 UTC
Identical to

http://bugzilla.kernel.org/show_bug.cgi?id=1774

? Fixed there...
Comment 12 Len Brown 2004-01-22 10:54:10 UTC
please re-open if the patch in bug #1269 does not address the problem.

thanks,
-Len


*** This bug has been marked as a duplicate of 1269 ***
Comment 13 Gustavo Michels 2004-01-22 16:43:55 UTC
Yes, the patch in bug #1269 solved the problem. Now running 2.6.1 with APIC and 
IO-APIC.

Note You need to log in before you can comment on or make changes to this bug.