Bug 1363 - Acer Aspire 1310 laptop hot-add failure - VIA VT8633 PIC
Acer Aspire 1310 laptop hot-add failure - VIA VT8633 PIC
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Config-Hotplug
i386 Linux
: P2 high
Assigned To: Len Brown
:
: 1362 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-15 07:59 UTC by Pau
Modified: 2005-01-03 15:20 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0test7
Tree: Mainline
Regression: ---


Attachments
dmidecode, acpidmp, messages, lspci -vvv, /proc/nterrupts, /proc/iomem (87.22 KB, text/plain)
2003-10-15 08:02 UTC, Pau
Details
dmesg of 2.6.0test7 withou any boot parametres (11.89 KB, text/plain)
2003-10-16 00:56 UTC, Pau
Details

Description Pau 2003-10-15 07:59:46 UTC
Distribution: RH 9
Hardware Environment: Acer Aspire 1310 laptop
Software Environment:Fully updated RH9
Problem Description: Booting without any parametres the kernel prints messages
suggesting to add pci=biosirq, next time to add pci=usepirqmask and at the end
to add pci=noacpi. Of course I have those in my kernel boot params.

I attach the relevant information about it as suggested by Len Brown
<len.brown@intel.com> (thanks Len).

Steps to reproduce: just boot
Comment 1 Pau 2003-10-15 08:02:22 UTC
Created attachment 1063 [details]
dmidecode, acpidmp, messages, lspci -vvv, /proc/nterrupts, /proc/iomem
Comment 2 Len Brown 2003-10-15 13:25:27 UTC
*** Bug 1362 has been marked as a duplicate of this bug. ***
Comment 3 Shaohua 2003-10-16 00:10:28 UTC
please attach the dmesg without any boot parameter.
Comment 4 Pau 2003-10-16 00:56:06 UTC
Created attachment 1065 [details]
dmesg of 2.6.0test7 withou any boot parametres

If you need again the output of dmidecode and friends just let me know.
Comment 5 Pau 2003-10-17 14:30:46 UTC
The pcmcia slots are unusable: when I insert a wireles card (Buffalo
WLI-CB-G54A), not only it's not detected, but if I remove it the computer hungs,

When inserting a xircom_cb card, I get a warning from the kernel:

Oct 17 23:23:44 pau kernel: PCI: Enabling device 0000:02:00.0 (0000 -> 0003)
Oct 17 23:23:44 pau kernel: eth1: Xircom cardbus revision 3 at irq 11 
Oct 17 23:23:44 pau kernel: xircom_cb: Receiver failed to re-activate
Oct 17 23:23:44 pau kernel: PCI: Enabling device 0000:02:00.1 (0000 -> 0003)
Oct 17 23:23:44 pau /etc/hotplug/net.agent: NET add event not supported
Oct 17 23:23:44 pau kernel: ttyS4 at I/O 0x1080 (irq = 11) is a 16550A
Oct 17 23:23:44 pau /etc/hotplug/pci.agent: Setup xircom_cb for PCI slot
0000:02:00.0
Oct 17 23:23:45 pau /etc/hotplug/pci.agent: ... no modules for PCI slot 0000:02:00.1
Oct 17 23:24:06 pau kernel: irq 9: nobody cared!
Oct 17 23:24:06 pau kernel: Call Trace:
Oct 17 23:24:06 pau kernel:  [<c010c734>] __report_bad_irq+0x24/0x90
Oct 17 23:24:06 pau kernel:  [<c010c821>] note_interrupt+0x61/0x90
Oct 17 23:24:06 pau kernel:  [<c010ca10>] do_IRQ+0xe0/0x100
Oct 17 23:24:06 pau kernel:  [<c010b05c>] common_interrupt+0x18/0x20
Oct 17 23:24:06 pau kernel:  [<c010c6d3>] handle_IRQ_event+0x23/0x60
Oct 17 23:24:06 pau kernel:  [<c010c9a8>] do_IRQ+0x78/0x100
Oct 17 23:24:06 pau kernel:  [<c010b05c>] common_interrupt+0x18/0x20
Oct 17 23:24:06 pau kernel:  [<c012028d>] do_softirq+0x3d/0x90
Oct 17 23:24:06 pau kernel:  [<c010c9fc>] do_IRQ+0xcc/0x100
Oct 17 23:24:06 pau kernel:  [<c0105000>] _stext+0x0/0x20
Oct 17 23:24:06 pau kernel:  [<c010b05c>] common_interrupt+0x18/0x20
Oct 17 23:24:06 pau kernel:  [<c0105000>] _stext+0x0/0x20
Oct 17 23:24:06 pau kernel:  [<c01088c3>] default_idle+0x23/0x40
Oct 17 23:24:06 pau kernel:  [<c0108954>] cpu_idle+0x34/0x40
Oct 17 23:24:06 pau kernel:  [<c035071e>] start_kernel+0x15e/0x190
Oct 17 23:24:06 pau kernel:  [<c0350470>] unknown_bootoption+0x0/0x120
Oct 17 23:24:06 pau kernel: 
Oct 17 23:24:06 pau kernel: handlers:
Oct 17 23:24:06 pau kernel: [<c01b2b87>] (acpi_irq+0x0/0x14)
Oct 17 23:24:06 pau kernel: Disabling IRQ #9
Comment 6 Pau 2003-10-17 14:33:40 UTC
Sorry to insist, but removing the card produces this warning too (amy I shoul
post it to the lkml, but I think that all my problems with pcmcia and usb are
due to bad irq routing caused by acpi, maybe I'm wrong):

Oct 17 23:31:01 pau kernel: Unable to handle kernel NULL pointer dereference at
virtual address 00000068
Oct 17 23:31:01 pau kernel:  printing eip:
Oct 17 23:31:01 pau kernel: c018112d
Oct 17 23:31:01 pau kernel: *pde = 00000000
Oct 17 23:31:01 pau kernel: Oops: 0002 [#1]
Oct 17 23:31:01 pau kernel: CPU:    0
Oct 17 23:31:01 pau kernel: EIP:    0060:[<c018112d>]    Not tainted
Oct 17 23:31:01 pau kernel: EFLAGS: 00010246
Oct 17 23:31:01 pau kernel: EIP is at sysfs_hash_and_remove+0x2d/0x8e
Oct 17 23:31:01 pau kernel: eax: 00000000   ebx: 00000068   ecx: 00000068   edx:
00000077
Oct 17 23:31:01 pau kernel: esi: 00000000   edi: c02c970a   ebp: c973c4b4   esp:
ea419e98
Oct 17 23:31:01 pau kernel: ds: 007b   es: 007b   ss: 0068
Oct 17 23:31:01 pau kernel: Process pccardd (pid: 531, threadinfo=ea418000
task=ea49ac80)
Oct 17 23:31:01 pau kernel: Stack: c0320264 c973c4b4 c031ff64 d36400d8 c018243c
c973c4b4 c03202c0 c018253e 
Oct 17 23:31:01 pau kernel:        da566710 da5668a4 c0246363 da566710 ea419ee0
c0243c97 c0243ee1 d36400d8 
Oct 17 23:31:01 pau kernel:        ee9ef2e0 c03208e0 ea419ee0 ea419ee0 da566900
da566710 d3640084 ee9ef2e7 
Oct 17 23:31:01 pau kernel: Call Trace:
Oct 17 23:31:01 pau kernel:  [<c018243c>] remove_files+0x1c/0x30
Oct 17 23:31:01 pau kernel:  [<c018253e>] sysfs_remove_group+0x1e/0x60
Oct 17 23:31:01 pau kernel:  [<c0246363>] netdev_unregister_sysfs+0x53/0x60
Oct 17 23:31:01 pau kernel:  [<c0243c97>] netdev_run_todo+0xf7/0x1f0
Oct 17 23:31:01 pau kernel:  [<c0243ee1>] unregister_netdevice+0xf1/0x1bc
Oct 17 23:31:01 pau kernel:  [<ee9ef2e0>] xircom_remove+0x80/0xb0 [xircom_cb]
Oct 17 23:31:01 pau kernel:  [<ee9ef2e7>] xircom_remove+0x87/0xb0 [xircom_cb]
Oct 17 23:31:01 pau kernel:  [<c01afbb8>] pci_device_remove+0x28/0x30
Oct 17 23:31:01 pau kernel:  [<c01f4126>] device_release_driver+0x56/0x60
Oct 17 23:31:01 pau kernel:  [<c01f4271>] bus_remove_device+0x61/0xb0
Oct 17 23:31:01 pau kernel:  [<c01f2ff2>] device_del+0x62/0x90
Oct 17 23:31:01 pau kernel:  [<c01f3028>] device_unregister+0x8/0x10
Oct 17 23:31:01 pau kernel:  [<c01ad530>] pci_destroy_dev+0x10/0x60
Oct 17 23:31:01 pau kernel:  [<c01ad628>] pci_remove_behind_bridge+0x28/0x40
Oct 17 23:31:01 pau kernel:  [<ee9bebab>] shutdown_socket+0x6b/0x120 [pcmcia_core]
Oct 17 23:31:01 pau kernel:  [<ee9bf248>] socket_remove+0x8/0x40 [pcmcia_core]
Oct 17 23:31:01 pau kernel:  [<ee9bf2d8>] socket_detect_change+0x58/0x80
[pcmcia_core]
Oct 17 23:31:01 pau kernel:  [<ee9bf4b7>] pccardd+0x1b7/0x1f0 [pcmcia_core]
Oct 17 23:31:01 pau kernel:  [<c0119ed0>] default_wake_function+0x0/0x20
Oct 17 23:31:01 pau kernel:  [<c0119ed0>] default_wake_function+0x0/0x20
Oct 17 23:31:01 pau kernel:  [<ee9bf300>] pccardd+0x0/0x1f0 [pcmcia_core]
Oct 17 23:31:01 pau kernel:  [<c0108b05>] kernel_thread_helper+0x5/0x10
Oct 17 23:31:01 pau kernel: 
Oct 17 23:31:01 pau kernel: Code: ff 4e 68 78 5c 89 fa 89 e8 e8 55 ff ff ff 3d
18 fc ff ff 89 
Comment 7 Len Brown 2003-11-13 10:44:20 UTC
ACPI disabled config really struggles with this machine: 
--- 
Linux version 2.6.0-0.test7.1.52 
Kernel command line: ro root=LABEL=/ pci=noacpi pci=usepirqmask pci=biosirq 
 
PCI: Using IRQ router default [1106/3177] at 0000:00:11.0 
PCI: Cannot allocate resource region 0 of device 0000:00:0a.0 
 
PCI: Via IRQ fixup for 0000:00:10.1, from 255 to 0 
 
PCI: No IRQ known for interrupt pin D of device 0000:00:10.3. 
drivers/usb/core/hcd-pci.c: Found HC with no IRQ.  Check BIOS/PCI 0000:00:10.3 
setup! 
 
PCI: No IRQ known for interrupt pin B of device 0000:00:10.1. 
drivers/usb/core/hcd-pci.c: Found HC with no IRQ.  Check BIOS/PCI 0000:00:10.1 
setup! 
 
Yenta: ISA IRQ list 0098, PCI irq11 
 
  0:   58055254          XT-PIC  timer 
  1:      40202          XT-PIC  i8042 
  2:          0          XT-PIC  cascade 
  5:      12401          XT-PIC  ohci1394, VIA8233 
  8:          1          XT-PIC  rtc 
  9:       1851          XT-PIC  acpi 
 11:     291078          XT-PIC  uhci-hcd, eth0, yenta 
 12:     279317          XT-PIC  i8042 
 14:     141898          XT-PIC  ide0 
 15:       2675          XT-PIC  ide1 
--- 
What exactly fails in this configuration? 
==== 
Enabling ACPI (no boot parameters)... 
 
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 10 *11 14 15) 
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 *10 11 14 15) 
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 7 10 11 14 15) 
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 10 11 14 15) 
Linux Plug and Play Support v0.97 (c) Adam Belay 
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11 
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5 
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11 
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 10 
ACPI: No IRQ known for interrupt pin A of device 0000:00:11.1 
 
PCI: Via IRQ fixup for 0000:00:10.1, from 255 to 10 
 
VP_IDE: IDE controller at PCI slot 0000:00:11.1 
ACPI: No IRQ known for interrupt pin A of device 0000:00:11.1 
 
Linux Kernel Card Services 
  options:  [pci] [cardbus] [pm] 
Yenta: CardBus bridge found at 0000:00:0a.0 [10cf:10e7] 
Yenta: ISA IRQ list 0098, PCI irq11 
Socket status: 30000827 
 
and  10.1 is the USB controller, and 11.1 is IDE, which is hard-coded. 
00:10.1 USB Controller: VIA Technologies 
00:11.1 IDE interface: VIA Technologies, 
--- 
Nothing jumps out at me as broken in the interrupt configuration. 
Can you attach the /proc/interrupts from this acpi (no cmdline flags) config? 
=== 
Is the hot-add system hang you describe above in the config with 
ACPI interrupt routing disabled, or with ACPI interrupt routing enabled (no cmdline flags). 
Is that the only failing symptom here, or is something else not working? 
 
Does this add-in card work properly if the system is booted with it already present? 
 
Looks like you're running a 2.6 kernel from Red Hat? 
Can you try the baseline 2.6.0 kernel? 
 
thanks, 
-Len 
 
Comment 8 Shaohua 2003-12-25 21:22:47 UTC
For add-in card issue, please try the patch in bug 1564
Comment 9 Len Brown 2004-05-17 22:01:27 UTC
still an issue with a recent kernel? 
Comment 10 Len Brown 2004-11-15 20:49:05 UTC
please test linux-2.6.9 
Comment 11 Len Brown 2005-01-03 15:20:40 UTC
Please re-open if still an issue with linux-2.6.10 or later.

Note You need to log in before you can comment on or make changes to this bug.