Bug 13607 - (vaio) No ACPI events for power button and lid-switch on sony vaio vgn-sz61mn
(vaio)
No ACPI events for power button and lid-switch on sony vaio vgn-sz61mn
Status: CLOSED DUPLICATE of bug 1752
Product: ACPI
Classification: Unclassified
Component: Other
i386 Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 08:36 UTC by Sebastian Pohl
Modified: 2009-08-29 22:24 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.29
Tree: Mainline
Regression: No


Attachments
Output of acpidump. (172.51 KB, application/octet-stream)
2009-06-23 08:36 UTC, Sebastian Pohl
Details
patch: always register fixed power button devices (752 bytes, patch)
2009-06-26 02:57 UTC, Zhang Rui
Details | Diff
grep -R . /sys/firmware/acpi/interrupts/* before pressing the buttons (2.08 KB, text/plain)
2009-06-26 21:28 UTC, Sebastian Pohl
Details
grep -R . /sys/firmware/acpi/interrupts/* after pressing the buttons (2.08 KB, application/octet-stream)
2009-06-26 21:28 UTC, Sebastian Pohl
Details
lspci output (31.49 KB, application/octet-stream)
2009-06-26 21:29 UTC, Sebastian Pohl
Details

Description Sebastian Pohl 2009-06-23 08:36:16 UTC
Created attachment 22064 [details]
Output of acpidump.

The power button and the lid-switch on the vaio vgn-sz61mn does not generate any acpi events.
Comment 1 ykzhao 2009-06-26 02:26:13 UTC
Will you please also attach the output of lspci -vxxx?
Will you please do the following test on your box?
    a. kill the process using /proc/acpi/event (use the command of "lsof /proc/acpi/event" to get the process ID)
    b. grep -R . /sys/firmware/acpi/interrupts/* > interrupts_before
    c. press the LID/power button several times
    d. grep -R . /sys/firmware/acpi/interrupts/* > interrupts_after

   After the test, please attach the above outputs.
   thanks.
Comment 2 Zhang Rui 2009-06-26 02:57:08 UTC
Created attachment 22098 [details]
patch: always register fixed power button devices

please apply this patch and attach the content of /sys/firmware/acpi/interrupts/ff_pwr_btn after pressing the power button for several times.
Comment 3 Sebastian Pohl 2009-06-26 21:28:16 UTC
Created attachment 22109 [details]
grep -R . /sys/firmware/acpi/interrupts/* before pressing the buttons
Comment 4 Sebastian Pohl 2009-06-26 21:28:41 UTC
Created attachment 22110 [details]
grep -R . /sys/firmware/acpi/interrupts/* after pressing the buttons
Comment 5 Sebastian Pohl 2009-06-26 21:29:13 UTC
Created attachment 22111 [details]
lspci output
Comment 6 Sebastian Pohl 2009-06-26 21:35:22 UTC
I applied the patch from comment #2 and the output of the mentioned file is 

0 enabled

no matter how often i press the power button.
Comment 7 Zhang Rui 2009-06-29 01:15:51 UTC
hmmm, what do you get when you run "ls /sys/bus/acpi/drivers/button/"?
Comment 8 ykzhao 2009-06-29 01:42:51 UTC
Hi, Sebastian
    Can you confirm whether the button driver is loaded after applying the patch in comment #2? Please add the boot option of "initcall_debug" and attach the output of dmesg.

    Will you please also the do the test again after executing the command of " setpci -s 00:00:1f.0 b9.b=0x80"?

 
    Thanks.
Comment 9 Sebastian Pohl 2009-07-01 12:54:57 UTC
ls /sys/bus/acpi/drivers/button/ gives the following:
LNXPWRBN:00  PNP0C0C:00  PNP0C0D:00  bind  uevent  unbind
Comment 10 Sebastian Pohl 2009-07-01 12:56:22 UTC
Hey after executing

setpci -s 00:00:1f.0 b9.b=0x80

The Power button works!
Comment 11 ykzhao 2009-07-03 03:14:46 UTC
Hi, Sebastian
    thanks for the test.
    From the test it seems that the power button event is triggered by the power button device defined in AML code, which is controlled by EC. And after the EC can work well, the power button event can be generated correctly.
    
    And from the test it seems that this issue is also related with the incorrect GPIO routing, which is defined in 00:00:1f.0 LPC bridge. If it is not configured correctly, there is no EC GPE interrupt. In such case the EC notification event can't be processed, which also causes that the power button event can't be sent.
   
   From the above analysis it seems that this is a duplicated bug of 1752.
Hi, Rui
   How about marking this bug as the duplicated bug of 1752?
 
thanks.
Comment 12 Zhang Rui 2009-07-06 03:08:44 UTC

*** This bug has been marked as a duplicate of bug 1752 ***

Note You need to log in before you can comment on or make changes to this bug.