Bug 11737 - boot fails unless acpi=off - asus m51ta-x2 notebook, Turion Ultra zm-82
boot fails unless acpi=off - asus m51ta-x2 notebook, Turion Ultra zm-82
Status: CLOSED DUPLICATE of bug 11541
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
All Linux
: P1 blocking
Assigned To: acpi_acpica-core@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 02:47 UTC by slavo
Modified: 2008-11-30 20:20 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.26-2.6.27
Tree: Mainline
Regression: ---


Attachments
dmesg, acpidump, lspci -vxx , hwinfo (191.23 KB, application/x-zip-compressed)
2008-10-15 15:44 UTC, slavo
Details
skip redundant RootPrefix (889 bytes, patch)
2008-10-20 23:56 UTC, Lin Ming
Details | Diff
Ignore the _INI object in course of ACPI initialization (757 bytes, patch)
2008-10-23 19:57 UTC, ykzhao
Details | Diff
hang (420.65 KB, image/jpeg)
2008-10-28 01:15 UTC, slavo
Details
dmesg.acpioff (39.23 KB, application/octet-stream)
2008-10-31 02:45 UTC, slavo
Details
dmesg.nolapic (44.08 KB, application/octet-stream)
2008-10-31 02:45 UTC, slavo
Details

Description slavo 2008-10-11 02:47:57 UTC
Latest working kernel version:n
Earliest failing kernel version:
Distribution: ubuntu , opensuse 11.0
Hardware Environment:32bit 
Software Environment:
Problem Description:

i have tried many distributions but all have the same problem with this notebook... it is new notebook from asus with Turion Ultra zm-82 and with 2 gprahic cards ...

short after boot screen goes blank a it is all ...
if i use acpi=off  it can boot corectly


hardware specifocation
http://www.newegg.com/Product/Product.aspx?Item=N82E16834220349


there are links to some distributions bugsystems with this bug 
https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/274196

https://bugzilla.novell.com/show_bug.cgi?id=433606

i have reported it to opensuse bugzilla ... but they told me that it seems like "upstream bug"

there is hwinfo https://bugzilla.novell.com/attachment.cgi?id=244392

thanks for resolving this bug.
Comment 1 ykzhao 2008-10-12 06:22:07 UTC
Will you please boot the system with the option of "acpi=off" and attach the output of dmesg, acpidump, lspci -vxxx?

It will be great if you can attach the screenshot when the system hang with ACPI enabled.

Thanks.
Comment 2 ykzhao 2008-10-14 18:23:43 UTC
Will you please try the boot option of "idle=poll" or "processor.max_cstate=1" and see whether the system can be booted normally?
Thanks.
Comment 3 slavo 2008-10-15 15:43:15 UTC
i have tried "idle=poll" and "processor.max_cstate=1" but it did nothing ...
the newest beta of kubuntu doesnt boot with acpi=off (openususe 11.1 beta 2 can start with acpi=off) but it can boot normally with parameter "nolapic", opensuse can start with this option too ...
but with nolapic parameter network card does not work and only 1 core of processor is active

i have added dmesg , acpidump,laspci -vxxx ... 
Comment 4 slavo 2008-10-15 15:44:23 UTC
Created attachment 18334 [details]
dmesg, acpidump, lspci -vxx , hwinfo
Comment 5 slavo 2008-10-15 15:52:29 UTC
some screens when system hang are there

https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/274196
Comment 6 ykzhao 2008-10-20 01:56:46 UTC
Hi, Slavo
    Thanks for the info.
    From the hang screenshot in comment #5 it seems that the system hangs while executing the _INI object.
    At the same time there exists the following error about the ECDT table in BIOS.
   > Namepath : \\_SB.PCI0.SBRG.EC0 (Namepath should be  \_SB.PCI0.SBRG.EC0).
    thanks.
    
Comment 7 ykzhao 2008-10-20 02:19:19 UTC
Hi, Slavo
    Will you please try the 2.6.24.x stable?
    thanks.
Comment 8 Lin Ming 2008-10-20 23:56:38 UTC
Created attachment 18390 [details]
skip redundant RootPrefix

Hi, Slavo

Would you please have a try this patch to verify if it's caused by the wrong EC namepath(\\_SB.PCI0.SBRG.EC0)?
Comment 9 slavo 2008-10-21 05:05:55 UTC
ykzhao 2.6.24 does not work ... 

Ling Ming ... ok i will try it 
Comment 10 slavo 2008-10-21 06:31:52 UTC
Ling ming,
i have tried to apply this patch to lastes stable 2.6.27.2. it compiled successfuly but there is the same problem ... it can boot only with acpi=off or nolapic (but with nolapic is active only one core of cpu an ethernet card does not work)...

Comment 11 ykzhao 2008-10-23 19:57:36 UTC
Created attachment 18421 [details]
Ignore the _INI object in course of ACPI initialization

Will you please try the debug patch on the latest stable kernel(2.6.27.2) and see whether the system can be booted with ACPI enabled? (Please add the boot option of "initcall_debug").
   If it still hangs, please capture the screenshot.
   Of course the patch in comment #8 is still required.
   Thanks.
Comment 12 slavo 2008-10-28 01:15:07 UTC
it still does not work :( ... screenshot ( start with initcall_debug) is in attachement. i had only few seconds to get screenshot , because after 3 secs screen goes blank 
Comment 13 slavo 2008-10-28 01:15:45 UTC
Created attachment 18479 [details]
hang
Comment 14 ykzhao 2008-10-31 00:22:17 UTC
thanks for the info.
From the screenshot it seems that the system hangs in the function of pci_init, in which the quirk function for some PCI devices are called.
    Will you please enable "CONFIG_PCI_DEBUG" in kernel configuration and do the test as mentioned in comment #11?
    It will be great if you can attach the output of dmesg with the option of "acpi=off".
    Thanks.
Comment 15 slavo 2008-10-31 02:44:39 UTC
with config_pci_debug enabled in kernel configuration nothig has changed (hang screen is same as before) , i have attached dmesg when it starts with acpi=off and when it starts with nolapic...
Comment 16 slavo 2008-10-31 02:45:21 UTC
Created attachment 18553 [details]
dmesg.acpioff
Comment 17 slavo 2008-10-31 02:45:51 UTC
Created attachment 18554 [details]
dmesg.nolapic
Comment 18 Ondrej Kozina 2008-11-05 09:59:56 UTC
Hi,

i don`t know if it helps, but i can boot the notebook with acpi enabled and "nosmp" boot option. (Same results when you compile kernel without SMP support) Do you want some debug info with this option during boot?
Comment 19 slavo 2008-11-05 10:06:08 UTC
yes i can boot with "nosmp" option too , but i thing that acpi does not work correctly ... for example there is very big power consumption ...
Comment 20 Len Brown 2008-11-12 01:10:34 UTC
"nosmp" = "maxcpus=1" + "nolapic"
and we already know that "nolapic" helps this box boot.

Please try just "nolapic_timer"
Comment 21 slavo 2008-11-12 17:13:47 UTC
it does not work ... no change ... (kernel 2.6.27.x)

but i have found some new information : 

centos 5.2 with kerenel 2.6.18 sometimes work with acpi enabled ... i now it is funny but it is true ... i thing that it depends of cpu temperature... because it starts when notebook is cold ... 

Comment 22 Daniele Benucci 2008-11-13 01:25:57 UTC
(In reply to comment #21)
> centos 5.2 with kerenel 2.6.18 sometimes work with acpi enabled

As stated in comment #10 of bug 11541 (http://bugzilla.kernel.org/show_bug.cgi?id=11541#c10) the problem with acpi and these asus laptops (m51tr and m51ta differs only in video card) starts with kernel 2.6.22
Comment 23 Zhang Rui 2008-11-25 18:52:38 UTC
mark this bug as a duplicate of bug #11541

*** This bug has been marked as a duplicate of bug 11541 ***

Note You need to log in before you can comment on or make changes to this bug.