Bug 42956 - crash dump memory reservation regression
crash dump memory reservation regression
Status: RESOLVED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 42644
  Show dependency treegraph
 
Reported: 2012-03-18 19:20 UTC by Maciej Rutecki
Modified: 2012-08-31 17:18 UTC (History)
6 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2012-03-18 19:20:46 UTC
Subject    : crash dump memory reservation regression
Submitter  : CAI Qian <caiqian@redhat.com>
Date       : 2012-03-12 3:00
Message-ID : 65a23329-d843-4859-8b7b-430f12882492@zmail14.collab.prod.int.phx2.redhat.com
References : http://marc.info/?l=linux-kernel&m=133152130517052&w=2

This entry is being used for tracking a regression from 3.2. Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 3661ca66a42e306aaf53246fb75aec1ea01be0f0
Author: Yinghai Lu <yinghai@kernel.org>
Date:   Wed Sep 15 13:05:29 2010 -0700

    memblock: Fix section mismatch warnings
    
    Stephen found a bunch of section mismatch warnings with the
    new memblock changes.
    
    Use __init_memblock to replace __init in memblock.c and remove
    __init in memblock.h. We should not use __init in header files.
    
    Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
    Tested-by: Stephen Rothwell <sfr@canb.auug.org.au>
    Signed-off-by: Yinghai Lu <Yinghai@kernel.org>
    Cc: Peter Zijlstra <peterz@infradead.org>
    Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    LKML-Reference: <4C912709.2090201@kernel.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 3661ca66a42e306aaf53246fb75aec1ea01be0f0

Note You need to log in before you can comment on or make changes to this bug.