Bug 41292 - scaling_min_freq reverts to cpuinfo_min_freq after wake up
scaling_min_freq reverts to cpuinfo_min_freq after wake up
Status: CLOSED DUPLICATE of bug 15295
Product: Power Management
Classification: Unclassified
Component: cpufreq
All Linux
: P1 normal
Assigned To: Aaron Lu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-17 15:58 UTC by Bill Longman
Modified: 2013-06-09 08:22 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.39
Tree: Mainline
Regression: No


Attachments
dmesg output (1.37 KB, text/plain)
2011-08-17 16:15 UTC, Bill Longman
Details
sys cpufreq values before shutdown (2.85 KB, text/plain)
2012-12-03 20:00 UTC, Bill Longman
Details
sys cpufreq values after shutdown (2.85 KB, text/plain)
2012-12-03 20:01 UTC, Bill Longman
Details

Description Bill Longman 2011-08-17 15:58:47 UTC
Environment: Core i7 M620; ondemand; acpi-cpufreq; microcode/version == 0xc

Description: When I set scaling_min_freq on all cores, only cpu0 retains its value after awaking from suspend-to-ram. All other cores revert to the minimum frequency.

Expected behaviour: Cores would retain scaling_min_freq after waking.
Comment 1 Bill Longman 2011-08-17 16:15:19 UTC
Created attachment 69062 [details]
dmesg output

Snippet of dmesg at sleep/wake border.
Comment 2 Zhang Rui 2012-01-18 05:34:22 UTC
It's great that the kernel bugzilla is back.

Can you please verify if the problem still exists in the latest upstream
kernel?
Comment 3 Bill Longman 2012-02-09 23:10:13 UTC
On 3.2.5, all the cores >0 have scaling_min_freq at cpuinfo_min_freq.
Comment 4 Zhang Rui 2012-11-28 06:58:09 UTC
please attach the output of "grep . /sys/devices/system/cpu/cpu*/cpufreq/*" both before and after suspend.
Comment 5 Bill Longman 2012-12-03 19:58:58 UTC
The same behaviour is seen in 3.6.1 kernel. See attached before and after results.
Comment 6 Bill Longman 2012-12-03 20:00:34 UTC
Created attachment 88311 [details]
sys cpufreq values before shutdown
Comment 7 Bill Longman 2012-12-03 20:01:37 UTC
Created attachment 88321 [details]
sys cpufreq values after shutdown

FWIW, I use KDE's hibernate command to go to sleep.
Comment 8 Aaron Lu 2013-04-01 06:00:31 UTC
Hi Bill,

Do you still have this problem on latest mainline kernel? Thanks.
Comment 9 Lan Tianyu 2013-04-18 12:55:29 UTC
Hi Bill:
       Any update on this bug? Does this bug take place during s2ram?
Comment 10 Aaron Lu 2013-06-09 08:19:37 UTC

*** This bug has been marked as a duplicate of bug 15295 ***
Comment 11 Aaron Lu 2013-06-09 08:22:13 UTC
Hi Bill,

I think this is a duplicate of bug 15295, and should have been fixed by latest upstream kernel v3.10-rc2+. If you are still available, please test it and report back, thanks.

Note You need to log in before you can comment on or make changes to this bug.