Bug 203937 - Program that sets FS register makes a Linux Hyper-V Instance crash
Summary: Program that sets FS register makes a Linux Hyper-V Instance crash
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Virtualization
Classification: Unclassified
Component: kvm (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: virtualization_kvm
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-20 01:12 UTC by Jong Hyun Park
Modified: 2019-10-11 08:37 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.19-rc1
Tree: Mainline
Regression: No


Attachments

Description Jong Hyun Park 2019-06-20 01:12:56 UTC
I found out that a simple program makes a Linux Hyper-V instance crash.

The program that crashes.
- it is simple. creates threads, sets ldt entry, stores it to fs register, and does simple work.
- you can find it on my github. (https://github.com/jonhpark7966/test_codes)

Linux versions that is installed over hyper-v
- 4.18.20 has no problem, but 4.19-rc1 crashes
- 64bit also has no probelm, but 32bit crashes


Thanks,

Jong Hyun Park
Comment 1 Jong Hyun Park 2019-07-16 02:03:13 UTC
I tested with "nopti" option as a kernel parameter, then this problem does not happen.

I asked to Tianyu Lan <Tianyu.Lan@microsoft.com> about this issue,
because he commited some codes about hyper-v at 4.19-rc1 version.
He noticed me about this page table isolation issues. thanks to Lan.
Comment 2 Jong Hyun Park 2019-07-18 01:28:16 UTC
I also tested on vmware, but it works well.
Comment 3 Tianyu Lan 2019-10-11 02:48:12 UTC
The issue has been fixed in v5.3 by commit 4030b4c58 x86/hyper-v: Fix overflow bug in fill_gva_list().
Comment 4 Jong Hyun Park 2019-10-11 08:37:42 UTC
The issue has been resolved!

Note You need to log in before you can comment on or make changes to this bug.