Bug 58341

Summary: iwlwifi: intel 6200 does not connect to WPA-EAP WIFI.
Product: Drivers Reporter: Hinnerk van Bruinehsen (h.v.bruinehsen)
Component: network-wirelessAssignee: drivers_network-wireless (drivers_network-wireless)
Status: CLOSED CODE_FIX    
Severity: normal CC: alan, fbcyborg, ilw, linville
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 3.8.12-3.9.2 Tree: Mainline
Regression: Yes
Attachments: log when NetworkManager times out
log with commit reversed: NetworkManager works
fix for EAP

Description Hinnerk van Bruinehsen 2013-05-16 15:09:28 UTC
With kernels with a version greater than 3.8.12 I can't connect to my university's WIFI (eduroam: https://www.eduroam.org/) anymore. Networkmanager just times out after 90 seconds.

My wifi-card is:
Network controller: Intel Corporation Centrino Advanced-N 6200 (rev 35)

With kernel 3.8.11 or older it works with the same userland.

I've tracked down the issue to commit 63b77bf489881747c5118476918cc8c29378ee63 (http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/drivers/net/wireless/iwlwifi/dvm/sta.c?h=linux-3.9.y&id=c30f37f8f1f8d06c142d67ba74955fd48b5cf5a4)
If I revert that patch it's working fine again. Therefore I'd guess that it's a regression on the kernel side.
Comment 1 Emmanuel Grumbach 2013-05-16 19:59:14 UTC
can you please send the logs of the driver?
please load with debugs:

modprobe iwlwifi debug=0x1001

thanks
Comment 2 Hinnerk van Bruinehsen 2013-05-16 20:04:30 UTC
Is there an easy way to enable debugging if I'm using a monolithic kernel?
Comment 3 Emmanuel Grumbach 2013-05-16 20:07:12 UTC
I don't really see how...
you can play with the code to enable debugging hard coded...
You also need to make sure that you have CONFIG_IWLWIFI_DEBUG set
Comment 4 Johannes Berg 2013-05-16 21:26:17 UTC
Pass "iwlwifi.debug=0x1001" on the kernel command line (without the quotes)
Comment 5 Johannes Berg 2013-05-16 21:29:03 UTC
Actually, the parameter should also be writable in sysfs:

echo 0x1001 > /sys/module/iwlwifi/parameters/debug

(if the file doesn't exist, you don't have CONFIG_IWLWIFI_DEBUG set)
Comment 6 Hinnerk van Bruinehsen 2013-05-17 10:52:46 UTC
Created attachment 101851 [details]
log when NetworkManager times out
Comment 7 Hinnerk van Bruinehsen 2013-05-17 10:53:28 UTC
Created attachment 101861 [details]
log with commit reversed: NetworkManager works
Comment 8 Hinnerk van Bruinehsen 2013-05-17 10:56:44 UTC
I've attached two logs:
The first is with the problem. NetworkManager can't get a connection and times out after 90 seconds.
The second is with essentially the same kernel  but the commit reversed (via patch -R). Connection is established and works well.

Note: in both cases there is a connection to a open WIFI before trying to establish connection.
Command used to establish the connection was is both cases:
nmcli con up id <networkname>
Comment 9 Emmanuel Grumbach 2013-05-19 06:56:22 UTC
I am afraid I will need a bit more logs:
debug=0x0020100f

Please send again a working scenario along with a failing one.
Thanks
Comment 10 Hinnerk van Bruinehsen 2013-05-21 08:13:52 UTC
Here are the log - due to size constraints I've uploaded them externally:
http://hvbruinehsen.userpage.fu-berlin.de/iwl-debug-verbose-works.txt
http://hvbruinehsen.userpage.fu-berlin.de/iwl-debug-verbose-fail.txt
Comment 11 Emmanuel Grumbach 2013-05-22 08:16:07 UTC
Created attachment 102221 [details]
fix for EAP

please try the attached patch
Comment 12 Hinnerk van Bruinehsen 2013-05-22 08:39:18 UTC
I can confirm that your patch fixes the issue for me.

Thank you!
Comment 13 Flavio 2013-06-19 20:18:37 UTC
Hello, 

I am still having this problem. 
I applied the patch on gentoo-sources linux kernel, 3.9.4.
I use wicd.
Comment 14 Emmanuel Grumbach 2013-06-19 20:23:07 UTC
can you try 3.9.6?
Comment 15 Flavio 2013-06-19 21:02:16 UTC
(In reply to comment #14)
> can you try 3.9.6?
Ok, it seems to be OK with it. At least for the first attempt (after the first reboot with the new kernel).

Thank you for the suggestion.