Bug 215744

Summary: Regression on amd_sfh on kernel 5.17
Product: Drivers Reporter: Marco (rodomar705)
Component: Input DevicesAssignee: drivers_input-devices
Status: RESOLVED OBSOLETE    
Severity: high CC: basunatikar, ecstaticmorse
Priority: P1    
Hardware: All   
OS: Linux   
Kernel Version: 5.17 Tree: Mainline
Regression: Yes
Attachments: Logs from stock arch kernel
Custom not reverted kernel logs
Custom and reverted kernel logs

Description Marco 2022-03-25 15:22:19 UTC
After updating to 5.17, the input from the accelerometer disappeared, completely. No devices available from IIO tree. First bad commit causing it is https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/hid/amd-sfh-hid/amd_sfh_pcie.c?id=b300667b33b2b5a2c8e5f8f22826befb3d7f4f2b. Reverting this and the the other two on top fixed this. Tried to not revert only the above mentioned commit, but it's still not working.

Marco.
Comment 1 Marco 2022-04-04 17:33:27 UTC
Created attachment 300689 [details]
Logs from stock arch kernel
Comment 2 Marco 2022-04-04 17:34:08 UTC
Created attachment 300690 [details]
Custom not reverted kernel logs
Comment 3 Marco 2022-04-04 17:34:35 UTC
Created attachment 300691 [details]
Custom and reverted kernel logs
Comment 4 Marco 2022-04-04 17:36:18 UTC
I've added three dmesg and monitor-sensor output from the stock 5.17.1 kernel from arch, one custom zen patched kernel with identical configuration with and without the three aforementioned patches applied. The accelerometer data is present only in the reverted custom patches, as seen from the monitor-sensor logs.
Comment 5 basavaraj 2022-04-26 13:09:49 UTC
Please close this BIOS/firmware bug and find ASUS BIOS details for this fix in below link or mail.

https://lore.kernel.org/all/DM4PR12MB5040B29E23073FF0E55A055FE6FB9@DM4PR12MB5040.namprd12.prod.outlook.com/

Thanks,
Basavaraj
Comment 6 Marco 2022-04-26 13:26:15 UTC
After flashing the provided BIOS file, I can confirm that the issue is fixed and the sensor is now working!

Thanks for your time,

Marco.