Bug 29372 - (Spina) KMS - radeon (Uhhuh. NMI received for unknown reason)
(Spina)
KMS - radeon (Uhhuh. NMI received for unknown reason)
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
x86-64 Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-18 10:11 UTC by Emanuele Tomasi
Modified: 2012-08-16 11:00 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.37.x
Tree: Mainline
Regression: No


Attachments

Description Emanuele Tomasi 2011-02-18 10:11:49 UTC
I noticed that when I run:
  xset dpms force standby
or
  echo "low" > /sys/class/drm/card0/device/power_profile
for my ATI Radeon Mobile X1400 (I think r5xx) I receive this advise from kernel:
---
  Uhhuh. NMI received for unknown reason a1 on CPU 0.
  You have some hardware problem, likely on the PCI bus.
  Dazed and confused, but trying to continue
---
or something like. With latest commit on master branch of xf86-video-ati:
   http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/
my PC go on freeze after some stanby. Now I'm using the xf86-video-ati at latest commit at 2011-02-15 16:24:23 (4d7e1498f7d9eb50e2eddabca193fc27bde24f0e)

Best regards,
Emanuele
Comment 1 Alex Deucher 2011-02-18 16:50:38 UTC
This sounds like two different issues that should be filed separately.

1. The NMI when changing the pcie lanes

2. Problems with the latest ddx.


For 1., that is due to changing the number of PCIE lanes.  I'm not sure how to avoid it. Tt should be ok as the GPU is idle and all buffers are unmapped when we changes the lanes.  You can disable the PCIE lane changes by removing the call to radeon_set_pcie_lanes() in rs600_pm_misc() in rs600.c.

For 2., Are you saying 4d7e1498f7d9eb50e2eddabca193fc27bde24f0e is the last working commit or the last commit you tried.  What version were you previously using that did not cause a problem?  Can you bisect?  Are you sure it's a ddx issue and not a drm issue (i.e., does using an older ddx on the same kernel work ok)?
Comment 2 Emanuele Tomasi 2011-02-18 22:17:46 UTC
Hi Alex,
I made new tests. With 2.6.37 I receive the message 'Uhhuh' from kernel on standby and the PC freezes with the commit d7c2ba4286ea32401c0026cb92ec167f7b5753d8. (With 4d7e1498f7d9eb50e2eddabca193fc27bde24f0e I haven't freezing).
With 2.6.37.1 I keep getting 'Uhhuh' message but I'm not having freezing, even with d7c2ba4286ea32401c0026cb92ec167f7b5753d8.
If I disable the PCIE lane changes as you suggested, also the message 'Uhhuh' goes away.

So, wath do you think about? Do you need additional infos or tests?

Best regards,
Emanuele

P.S. I'm on x86_64
Comment 3 Alan 2012-08-16 11:00:21 UTC
If this is still seen with a modern (3.2 etc) kernel please updare/re-open thanks

Note You need to log in before you can comment on or make changes to this bug.