Bug 9980 - 2.6.25-rc1 on Sun Ultra 40- HPET clocksource which causes it to hang
Summary: 2.6.25-rc1 on Sun Ultra 40- HPET clocksource which causes it to hang
Status: CLOSED CODE_FIX
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-13 16:18 UTC by Rafael J. Wysocki
Modified: 2008-04-06 13:48 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-13 16:18:02 UTC
Subject         : 2.6.25-rc1 on Sun Ultra 40
Submitter       : Jasper Bryant-Greene <jasper@unix.geek.nz>
Date            : 2008-02-13 12:25
References      : http://lkml.org/lkml/2008/2/13/181

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline or the report is rejected.
Comment 1 Rafael J. Wysocki 2008-02-24 16:10:48 UTC
Handled-By : Yinghai Lu <Yinghai.Lu@sun.com>
Comment 2 Natalie Protasevich 2008-03-11 18:30:37 UTC
On Thu, 2008-02-14 at 00:25 +1300, Jasper Bryant-Greene wrote:
> I have been attempting to test 2.6.25-rc1 on my Sun Ultra 40 (two
> dual-core Opteron 2222 CPUs).
> 
> There is some issue with the HPET clocksource which causes it to hang
> the boot process if enabled, which I will look into in due course (the
> HPET works fine on at least 2.6.19).
> 
> More pressing is that the system will not boot at all even with HPET
> disabled - kernel gets no further than "NET: Registered protocol family
> 2".
> 
> I cannot think of a way to find out what the problem is, because the
> system has only USB ports, and the USB keyboard is not working at this
> stage, either because the system has locked up hard, or because the USB
> support has not yet loaded (I tried both standard USB-HID and boot
> protocol keyboard support, both compiled in). Thus I cannot use
> magic-sysrq, or even scrollback to look at boot messages. There is also
> no serial port to assist with the latter...

I can confirm neither the boot hang with HPET enabled nor the other
unexplained boot hang after "NET: Registered protocol family 2" occur on
2.6.24.2 on the same hardware. I still don't have an appropriate way to
debug the issue on 2.6.25-rc1, though...
Comment 3 Yinghai Lu 2008-03-12 22:49:50 UTC
boot log and config please
Comment 4 Rafael J. Wysocki 2008-04-06 13:48:01 UTC
References : http://lkml.org/lkml/2008/4/6/72

Jasper Bryant-Greene said:

No longer reproducible on 2.6.25-rc8.

Note You need to log in before you can comment on or make changes to this bug.