Bug 99651 - third monitor connected via dvi does not work on radeonhd 7770
Summary: third monitor connected via dvi does not work on radeonhd 7770
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-08 19:39 UTC by Gluzskiy Alexandr
Modified: 2016-03-23 18:34 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.0.5 and higher (tested on 4.1-rc7 also)
Tree: Mainline
Regression: Yes


Attachments
dmesg with some drm errors (138.94 KB, application/octet-stream)
2015-06-08 19:39 UTC, Gluzskiy Alexandr
Details
xrandr --verbose on 4.0.4 (12.69 KB, application/octet-stream)
2015-06-10 05:12 UTC, Gluzskiy Alexandr
Details
xorg log on 4.0.4 (82.95 KB, application/octet-stream)
2015-06-10 05:14 UTC, Gluzskiy Alexandr
Details
xrandr --verbose on 4.0.5 (12.69 KB, application/octet-stream)
2015-06-10 05:26 UTC, Gluzskiy Alexandr
Details
xorg log on 4.0.5 (78.29 KB, application/octet-stream)
2015-06-10 05:27 UTC, Gluzskiy Alexandr
Details

Description Gluzskiy Alexandr 2015-06-08 19:39:10 UTC
Created attachment 179171 [details]
dmesg with some drm errors

after kernel update to 4.0.5 my third monitor stopped working (black screen with blinking standby indicator), but console resolution is adjusted to lowest monitor resolution, the one which is not working, so i guess driver see it and trying to use, look in dmesg in attachment
Comment 1 Alex Deucher 2015-06-09 19:46:03 UTC
what type of monitors/adapters are you using?  I suspect the following commits may be at fault:
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a10f0df0615abb194968fc08147f3cdd70fd5aa5
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=7fe04d6fa824ccea704535a597dc417c8687f990
Please attach your xorg log and xrandr --verbose output.
Comment 2 Gluzskiy Alexandr 2015-06-10 05:12:25 UTC
Created attachment 179381 [details]
xrandr --verbose on 4.0.4

all working fine here, just for monitor info
Comment 3 Gluzskiy Alexandr 2015-06-10 05:14:35 UTC
Created attachment 179391 [details]
xorg log on 4.0.4

xorg log on working system, just to get config info
Comment 4 Gluzskiy Alexandr 2015-06-10 05:26:55 UTC
Created attachment 179401 [details]
xrandr --verbose on 4.0.5

on broken system, third monitor does not work, the one with 1280x1024 resolution
Comment 5 Gluzskiy Alexandr 2015-06-10 05:27:28 UTC
Created attachment 179411 [details]
xorg log on 4.0.5

on broken system, third monitor does not work, the one with 1280x1024 resolution
Comment 6 Gluzskiy Alexandr 2015-06-10 05:38:34 UTC
i have reverted both commits and it's fixes a problem

Note You need to log in before you can comment on or make changes to this bug.