Bug 9965 - drivers/built-in.o: In function `v4l2_i2c_attach': undefined reference to `i2c_attach_client'
drivers/built-in.o: In function `v4l2_i2c_attach': undefined reference to `i2...
Status: CLOSED DUPLICATE of bug 9833
Product: v4l-dvb
Classification: Unclassified
Component: v4l-core
All Linux
: P1 normal
Assigned To: v4l-dvb_v4l-core@kernel-bugs.osdl.org
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-13 14:23 UTC by Alex J. Ivasyuv
Modified: 2008-02-17 03:28 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments
/usr/src/linux/.config (36.87 KB, application/octet-stream)
2008-02-13 14:26 UTC, Alex J. Ivasyuv
Details
make CONFIG_DEBUG_SECTION_MISMATCH=y (55.72 KB, text/plain)
2008-02-13 14:27 UTC, Alex J. Ivasyuv
Details

Description Alex J. Ivasyuv 2008-02-13 14:23:31 UTC
Latest working kernel version: 2.6.24
Earliest failing kernel version: 2.6.25-rc1
Distribution: Gentoo
Hardware Environment: AverMedia 305 (SAA7134)
Software Environment:
Problem Description: Can't compile kernel when enable I2C & Video For Linux

===skip===
  CC      arch/x86/lib/msr-on-cpu.o
  LD      arch/x86/lib/built-in.o
  CC      arch/x86/lib/bitops_32.o
  CC      arch/x86/lib/delay_32.o
  AS      arch/x86/lib/getuser_32.o
  CC      arch/x86/lib/memcpy_32.o
  AS      arch/x86/lib/putuser_32.o
  CC      arch/x86/lib/string_32.o
  CC      arch/x86/lib/strstr_32.o
  CC      arch/x86/lib/usercopy_32.o
  AR      arch/x86/lib/lib.a
  LD      vmlinux.o
  MODPOST vmlinux.o
WARNING: modpost: Found 18 section mismatch(es).
To see full details build your kernel with:
'make CONFIG_DEBUG_SECTION_MISMATCH=y'
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o: In function `v4l2_i2c_attach':
(.text+0x48d5e): undefined reference to `i2c_attach_client'
make: *** [.tmp_vmlinux1] Error 1
siegerstein linux # 

Steps to reproduce:

make && make modules_install && make install
Comment 1 Alex J. Ivasyuv 2008-02-13 14:26:02 UTC
Created attachment 14803 [details]
/usr/src/linux/.config
Comment 2 Alex J. Ivasyuv 2008-02-13 14:27:52 UTC
Created attachment 14804 [details]
make CONFIG_DEBUG_SECTION_MISMATCH=y
Comment 3 Alex J. Ivasyuv 2008-02-13 14:29:18 UTC
02:0b.0 Multimedia controller: Philips Semiconductors SAA7130 Video Broadcast Decoder (rev 01)
	Subsystem: Avermedia Technologies Inc Unknown device a115
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (63750ns min, 63750ns max)
	Interrupt: pin A routed to IRQ 5
	Region 0: Memory at fbffbc00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [40] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=3 PME-
Comment 4 Adrian Bunk 2008-02-13 15:40:39 UTC

*** This bug has been marked as a duplicate of bug 9833 ***
Comment 5 Alex J. Ivasyuv 2008-02-14 02:57:13 UTC
git-clone git://git.kernel.org/pub/scm/linux/kernel/git/mchehab/v4l-dvb.git

===skip===
  CC      arch/x86/lib/msr-on-cpu.o
  LD      arch/x86/lib/built-in.o
  CC      arch/x86/lib/bitops_32.o
  AS      arch/x86/lib/checksum_32.o
  CC      arch/x86/lib/delay_32.o
  AS      arch/x86/lib/getuser_32.o
  CC      arch/x86/lib/memcpy_32.o
  AS      arch/x86/lib/putuser_32.o
  AS      arch/x86/lib/semaphore_32.o
  CC      arch/x86/lib/string_32.o
  CC      arch/x86/lib/strstr_32.o
  CC      arch/x86/lib/usercopy_32.o
  AR      arch/x86/lib/lib.a
  LD      vmlinux.o
  MODPOST vmlinux.o
WARNING: modpost: Found 18 section mismatch(es).
To see full details build your kernel with:
'make CONFIG_DEBUG_SECTION_MISMATCH=y'
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
  KSYM    .tmp_kallsyms1.S
  AS      .tmp_kallsyms1.o
  LD      .tmp_vmlinux2
  KSYM    .tmp_kallsyms2.S
  AS      .tmp_kallsyms2.o
  LD      vmlinux
  SYSMAP  System.map
  SYSMAP  .tmp_System.map
  CC      arch/x86/boot/a20.o
  CC      arch/x86/boot/cmdline.o
  AS      arch/x86/boot/copy.o
  HOSTCC  arch/x86/boot/mkcpustr
  CPUSTR  arch/x86/boot/cpustr.h
  CC      arch/x86/boot/cpu.o
  CC      arch/x86/boot/cpucheck.o
  CC      arch/x86/boot/edd.o
  AS      arch/x86/boot/header.o
  CC      arch/x86/boot/main.o
  CC      arch/x86/boot/mca.o
  CC      arch/x86/boot/memory.o
  CC      arch/x86/boot/pm.o
  AS      arch/x86/boot/pmjump.o
  CC      arch/x86/boot/printf.o
  CC      arch/x86/boot/string.o
  CC      arch/x86/boot/tty.o
  CC      arch/x86/boot/video.o
  CC      arch/x86/boot/version.o
  CC      arch/x86/boot/video-vga.o
  CC      arch/x86/boot/video-vesa.o
  CC      arch/x86/boot/video-bios.o
  LD      arch/x86/boot/setup.elf
  OBJCOPY arch/x86/boot/setup.bin
  AS      arch/x86/boot/compressed/head_32.o
  CC      arch/x86/boot/compressed/misc.o
  OBJCOPY arch/x86/boot/compressed/vmlinux.bin
  GZIP    arch/x86/boot/compressed/vmlinux.bin.gz
  LD      arch/x86/boot/compressed/piggy.o
  LD      arch/x86/boot/compressed/vmlinux
  OBJCOPY arch/x86/boot/vmlinux.bin
  HOSTCC  arch/x86/boot/tools/build
  BUILD   arch/x86/boot/bzImage
Root device is (8, 5)
Setup is 11224 bytes (padded to 11264 bytes).
System is 1580 kB
Kernel: arch/x86/boot/bzImage is ready  (#2)
  Building modules, stage 2.
  MODPOST 59 modules
ERROR: "release_firmware" [drivers/media/video/tuner-xc2028.ko] undefined!
ERROR: "request_firmware" [drivers/media/video/tuner-xc2028.ko] undefined!
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2
siegerstein linux # 

same `.config` file.
Comment 6 Adrian Bunk 2008-02-15 15:21:05 UTC
That's a completely different issue that should be handled in a new bug.


*** This bug has been marked as a duplicate of bug 9833 ***

Note You need to log in before you can comment on or make changes to this bug.