Bug 9962 - mount: could not find filesystem
mount: could not find filesystem
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-13 14:07 UTC by Rafael J. Wysocki
Modified: 2008-03-31 04:40 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.25-git0
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-13 14:07:40 UTC
Subject         : 2.6.26-git0: IDE oops during boot
Submitter       : Kamalesh Babulal <kamalesh@linux.vnet.ibm.com>
Date            : 2008-02-12 14:34
References      : http://lkml.org/lkml/2008/2/12/91
Handled-By      : Bartlomiej Zolnierkiewicz <bzolnier@gmail.com>

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Bartlomiej Zolnierkiewicz 2008-02-13 14:38:29 UTC
What makes you think that it is actually an IDE problem?  The initial problem (which Andi fixed) was with *ide_generic* oopsing and could be just work-arounded by disabling ide_generic (like reported by Pavel).

Asking Kamalesh to provide dmesg output instead would be far more useful than opening this bugzilla entry...
Comment 2 Rafael J. Wysocki 2008-02-13 15:02:26 UTC
As stated above, the Bugzilla entry is for tracking the regression.  If you think it should be reassigned, please let me know and I'll do that.
Comment 3 Bartlomiej Zolnierkiewicz 2008-02-13 15:58:49 UTC
Yes, it should be reassigned to "under investigation" department.
Comment 4 Bartlomiej Zolnierkiewicz 2008-02-13 16:09:48 UTC
Also the bug summary is totally wrong now since IDE OOPS has been already fixed,
the problem now is:

Creating root device.
Mounting root filesystem.
mount: could not  find filesystem
Kernel panic - not syncing: Attempted to kill init!

but hopefully we will know more soon.
Comment 5 Rafael J. Wysocki 2008-02-24 15:51:59 UTC
Handled-By : "Yinghai Lu" <yhlu.kernel@gmail.com>
Comment 6 Kamalesh Babulal 2008-03-31 03:12:36 UTC
I was tested the 2.6.25-rc7 kernel and this kernel bootups without the panic.
Comment 7 Rafael J. Wysocki 2008-03-31 04:40:44 UTC
OK, let's assume the problem has been fixed,then.

Note You need to log in before you can comment on or make changes to this bug.