Bug 9958 - parisc compile error
parisc compile error
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PA-RISC
All Linux
: P1 normal
Assigned To: Kyle McMartin
:
Depends on:
Blocks: 9832
  Show dependency treegraph
 
Reported: 2008-02-13 12:08 UTC by Adrian Bunk
Modified: 2008-03-16 12:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Adrian Bunk 2008-02-13 12:08:20 UTC
Subject         : parisc compile error
Submitter       : Adrian Bunk <bunk@kernel.org>
Date            : 2008-02-08 01:12
References      : http://lkml.org/lkml/2008/2/7/572
Caused-By       : Christoph Lameter <clameter@sgi.com>
                  commit 9e2779fa281cfda13ac060753d674bbcaa23367e
Handled-By      : Kyle McMartin <kyle@mcmartin.ca>
Comment 1 Rafael J. Wysocki 2008-02-13 12:44:08 UTC
This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 2 Natalie Protasevich 2008-03-15 17:40:04 UTC
Snapshot:
Date	Thu, 7 Feb 2008 18:20:15 -0500
From	Kyle McMartin <>	
Ads by Ad Bard
Subject	Re: parisc compile error

On Fri, Feb 08, 2008 at 01:12:32AM +0200, Adrian Bunk wrote:
> Commit 9e2779fa281cfda13ac060753d674bbcaa23367e broke parisc:
> 
> <--  snip  -->
> 
> ...
>   CC      arch/parisc/kernel/asm-offsets.s
> In file included from include/asm/pgtable.h:13,
>                  from arch/parisc/kernel/asm-offsets.c:36:
> include/linux/mm.h: In function 'is_vmalloc_addr':
> include/linux/mm.h:243: error: 'VMALLOC_START' undeclared (first use in this function)
> include/linux/mm.h:243: error: (Each undeclared identifier is reported only once
> include/linux/mm.h:243: error: for each function it appears in.)
> include/linux/mm.h:243: error: 'VMALLOC_END' undeclared (first use in this function)
> make[1]: *** [arch/parisc/kernel/asm-offsets.s] Error 1
> 

yes, it's in my batch of fixes.

thanks for the reminder.

cheers, kyle
Comment 3 Adrian Bunk 2008-03-16 12:45:58 UTC
the fix is now in Linus' tree

Note You need to log in before you can comment on or make changes to this bug.