Bug 9953 - [REGRESSION]fan turns at highspeed after suspend2ram
[REGRESSION]fan turns at highspeed after suspend2ram
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 9832
  Show dependency treegraph
 
Reported: 2008-02-13 05:44 UTC by Rafael J. Wysocki
Modified: 2008-02-15 11:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-02-13 05:44:26 UTC
Subject         : [REGRESSION]fan turns at highspeed after suspend2ram
Submitter       : Mirco Tischler <mt-ml@gmx.de>
Date            : 2008-02-10 18:21
References      : http://lkml.org/lkml/2008/2/10/182
Handled-By      : "Rafael J. Wysocki" <rjw@sisk.pl>
Patch           : http://lkml.org/lkml/2008/2/12/536

This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Len Brown 2008-02-15 11:24:41 UTC
The patch below shipped in 2.6.25-rc1-git4

closed.

commit 314ccd644cc14b9ebc1996afbabfb4d108004fd0
Author: Rafael J. Wysocki <rjw@sisk.pl>
Date:   Wed Feb 13 00:32:16 2008 +0100

    ACPI suspend: Execute _WAK with the right argument

    The _WAK global ACPI control method has to be called with the
    argument representing the sleep state being exited.  Make it happen.

    Special thanks to Mirco Tischler <mt-ml@gmx.de> for reporting the
    problem and debugging.

    Reported-by: Mirco Tischler <mt-ml@gmx.de>
    Signed-off-by: Rafael J. Wysocki <rjw@sisk.pl>
    Signed-off-by: Len Brown <len.brown@intel.com>

Note You need to log in before you can comment on or make changes to this bug.