Bug 9944 - suspend to ram doesn't work anymore on Thinkpad T61 with Intel X3100
suspend to ram doesn't work anymore on Thinkpad T61 with Intel X3100
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Processor
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks: 7216 9832
  Show dependency treegraph
 
Reported: 2008-02-12 14:02 UTC by Yves-Alexis Perez
Modified: 2008-02-17 04:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Yves-Alexis Perez 2008-02-12 14:02:31 UTC
Latest working kernel version: 2.6.24.2
Earliest failing kernel version: 2.6.25-rc1
Distribution: Debian Sid
Hardware Environment: Thinkpad T61
Software Environment: 
Problem Description:

Suspend to ram doesn't work anymore on my thinkpad t61 with 2.6.25-rc1. On 2.6.24 I had to pass acpi_sleep=s3bios at boot time and suspend with s2ram -f -a 3.

On 2.6.25-rc1 doing (on console, with X not running) that leads to a blank screen and the “sleep” led (the moon) on the thinkpad blinks (like when it is currently suspending), but nothing happens then.

If I can make some more tests, or if you need more info, please ask. I hope this is no duplicate.

Cheers,

--
Yves-Alexis

Steps to reproduce:
Comment 1 Anonymous Emailer 2008-02-12 14:14:23 UTC
Reply-To: akpm@linux-foundation.org


(Please respond via emailed reply-to-all, not via the bugzilla web interface)

On Tue, 12 Feb 2008 14:02:31 -0800 (PST)
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9944
> 
>            Summary: suspend to ram doesn't work anymore on Thinkpad T61 with
>                     Intel X3100
>            Product: Power Management
>            Version: 2.5
>      KernelVersion: 2.6.25-rc1
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Hibernation/Suspend
>         AssignedTo: power-management_other@kernel-bugs.osdl.org
>         ReportedBy: corsac@debian.org
> 
> 
> Latest working kernel version: 2.6.24.2
> Earliest failing kernel version: 2.6.25-rc1

Rafael, is your list opened yet?

> Distribution: Debian Sid
> Hardware Environment: Thinkpad T61
> Software Environment: 
> Problem Description:
> 
> Suspend to ram doesn't work anymore on my thinkpad t61 with 2.6.25-rc1. On
> 2.6.24 I had to pass acpi_sleep=s3bios at boot time and suspend with s2ram -f
> -a 3.
> 
> On 2.6.25-rc1 doing (on console, with X not running) that leads to a blank
> screen and the ___sleep___ led (the moon) on the thinkpad blinks (like when it
> is currently suspending), but nothing happens then.
> 
> If I can make some more tests, or if you need more info, please ask. I hope
> this is no duplicate.
> 

I have a t61p and suspend/hibernate is bad and deteriorating.  So
many things go wrong that I'm afraid to test it any more.

Comment 2 Rafael J. Wysocki 2008-02-12 14:30:29 UTC
On Tuesday, 12 of February 2008, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=9944
> 
>
> > Distribution: Debian Sid
> > Hardware Environment: Thinkpad T61
> > Software Environment: 
> > Problem Description:
> > 
> > Suspend to ram doesn't work anymore on my thinkpad t61 with 2.6.25-rc1. On
> > 2.6.24 I had to pass acpi_sleep=s3bios at boot time and suspend with s2ram -f
> > -a 3.
> > 
> > On 2.6.25-rc1 doing (on console, with X not running) that leads to a blank
> > screen and the ___sleep___ led (the moon) on the thinkpad blinks (like when it
> > is currently suspending), but nothing happens then.
> > 
> > If I can make some more tests, or if you need more info, please ask. I hope
> > this is no duplicate.
> > 
> 
> I have a t61p and suspend/hibernate is bad and deteriorating.  So
> many things go wrong that I'm afraid to test it any more.

There are at least two known suspend regressions, one of which affects the T61
for sure.  There's a fix for it, available at:
http://lkml.org/lkml/2008/2/11/472

The fix for the second issue is in the works.

Comment 3 Yves-Alexis Perez 2008-02-13 04:07:32 UTC
On Tue, Feb 12, 2008 at 10:30:30PM +0000, bugme-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=9944
> There are at least two known suspend regressions, one of which affects the T61
> for sure.  There's a fix for it, available at:
> http://lkml.org/lkml/2008/2/11/472
> 
> The fix for the second issue is in the works.

It seems that the fix works fine. I can get suspend and resume working
correctly. What is the second issue? It seems I don't trigger it.

Cheers,
Comment 4 Rafael J. Wysocki 2008-02-13 05:08:17 UTC
(In reply to comment #3)
> 
> It seems that the fix works fine. I can get suspend and resume working
> correctly. What is the second issue? It seems I don't trigger it.
> 

The _WAK method is called with a wrong argument, which need not matter for your system (see: http://lkml.org/lkml/2008/2/12/536).
Comment 5 Rafael J. Wysocki 2008-02-13 05:11:14 UTC
This entry is being used for tracking a regression from 2.6.24.  Please don't
close it until the problem is fixed in the mainline.

Regressions list annotation:
Handled-By : Venki Pallipadi <venkatesh.pallipadi@intel.com>
Patch : http://lkml.org/lkml/2008/2/11/472

Note You need to log in before you can comment on or make changes to this bug.