Bug 9938 - building fails on lguest
Summary: building fails on lguest
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_i386
URL:
Keywords:
: 9952 (view as bug list)
Depends on:
Blocks: 9832
  Show dependency tree
 
Reported: 2008-02-11 15:34 UTC by Cedric OLLIVIER
Modified: 2008-03-03 10:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.25-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Cedric OLLIVIER 2008-02-11 15:34:17 UTC
Latest working kernel version: 2.6.25-rc1
Earliest failing kernel version: 2.6.25-rc1
Distribution:Debian Testing
Hardware Environment: i386
Problem Description: lguest building fails with errors

ERROR: "LGUEST_PAGES_guest_gdt_desc" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_host_gdt_desc" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_host_cr3" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_regs" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_host_idt_desc" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_guest_gdt" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_host_sp" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_regs_trapnum" [drivers/lguest/lg.ko] undefined!
ERROR: "LGUEST_PAGES_guest_idt_desc" [drivers/lguest/lg.ko] undefined!

CONFIG_LGUEST_LGUEST may be selected by CONFIG_LGUEST

Steps to reproduce:
select CONFIG_LGUEST (without CONFIG_LGUEST_LGUEST) and compile
Comment 1 Anonymous Emailer 2008-02-11 15:57:26 UTC
Reply-To: akpm@linux-foundation.org

On Mon, 11 Feb 2008 15:34:18 -0800 (PST)
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9938
> 
>            Summary: building fails on lguest
>            Product: Other
>            Version: 2.5
>      KernelVersion: 2.6.25-rc1
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Configuration
>         AssignedTo: zippel@linux-m68k.org
>         ReportedBy: ollivier.cedric@gmail.com
> 
> 
> Latest working kernel version: 2.6.25-rc1
> Earliest failing kernel version: 2.6.25-rc1
> Distribution:Debian Testing
> Hardware Environment: i386
> Problem Description: lguest building fails with errors
> 
> ERROR: "LGUEST_PAGES_guest_gdt_desc" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_host_gdt_desc" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_host_cr3" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_regs" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_host_idt_desc" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_guest_gdt" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_host_sp" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_regs_trapnum" [drivers/lguest/lg.ko] undefined!
> ERROR: "LGUEST_PAGES_guest_idt_desc" [drivers/lguest/lg.ko] undefined!
> 
> CONFIG_LGUEST_LGUEST may be selected by CONFIG_LGUEST
> 
> Steps to reproduce:
> select CONFIG_LGUEST (without CONFIG_LGUEST_LGUEST) and compile
> 

Rusty has sneakily avoided creating a bugzilla account, but we still know
how to find him.
Comment 2 Adrian Bunk 2008-02-13 07:51:27 UTC
*** Bug 9952 has been marked as a duplicate of this bug. ***
Comment 3 Adrian Bunk 2008-02-27 12:50:44 UTC
Can you confirm that this is fixed in 2.6.25-rc3-git1?
Comment 5 Cedric OLLIVIER 2008-03-03 10:41:25 UTC
Yes, it's fixed in 2.6.25-rc3-git1
Comment 6 Rusty Russell 2008-03-03 18:46:48 UTC
On Tuesday 12 February 2008 10:57:19 Andrew Morton wrote:
> Rusty has sneakily avoided creating a bugzilla account, but we still know
> how to find him.

Rusty has created one now, sorry for the delay.  Bug me.

Cheers,
Rusty.

Note You need to log in before you can comment on or make changes to this bug.