Bug 991 - /proc/acpi files appear in /proc after ACPI init failure
/proc/acpi files appear in /proc after ACPI init failure
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Other
i386 Linux
: P2 high
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 09:26 UTC by Alex Galakhov
Modified: 2004-03-04 19:55 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.0-test1
Tree: Mainline
Regression: ---


Attachments
patch to disable acpi cleanly on load failure (1.77 KB, patch)
2003-12-16 00:02 UTC, Len Brown
Details | Diff

Description Alex Galakhov 2003-07-26 09:26:14 UTC
Distribution: Debian sid unofficial/unstable + kernel 2.6.0-test1 from kernel.org source 
Hardware Environment: Tyan Thunder II motherboard, 2xP2 CPUs 
Software Environment: See distribution 
Problem Description: The /proc/acpi directory does not exist. ACPI stuff that's usually in 
/proc/acpi is placed directly in /proc and seems to be not working (these directories are 
empty). All the ACPI stuff is compiled into the kernel (not modules). ACPI reports warnings 
about ACPI tables while booting. 
 
Steps to reproduce: Just boot the system and look at /proc/ after it is mounted.
Comment 1 Shaohua 2003-08-07 23:29:49 UTC
can you attach the DSDT and ESDT.
Comment 2 Len Brown 2003-11-12 18:17:44 UTC
does this still happen with a recent kernel? 
 
thanks, 
-Len 
 
Comment 3 Len Brown 2003-12-16 00:02:37 UTC
Created attachment 1679 [details]
patch to disable acpi cleanly on load failure

please test this patch on your system.	It should disable acpi on the failure
and so there
should be no acpi entries left hanging around in /proc.

Of course it may be an additional bug that ACPI doesn't load on this system...
Comment 4 Len Brown 2004-01-30 20:21:08 UTC
in 2.6.2-rc3 -- closing

Note You need to log in before you can comment on or make changes to this bug.