Bug 9898 - [pata_ali] Unspecified hang on Acer laptop
Summary: [pata_ali] Unspecified hang on Acer laptop
Status: CLOSED OBSOLETE
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-06 03:09 UTC by Florian Schneider
Modified: 2012-05-12 01:17 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: No


Attachments
dmesg output (17.64 KB, text/plain)
2008-02-06 03:12 UTC, Florian Schneider
Details

Description Florian Schneider 2008-02-06 03:09:36 UTC
Latest working kernel version: 2.6.23.14 (with blkdev)
Earliest failing kernel version: 2.6.24 (with libata)
Distribution: sidux
Hardware Environment: Acer Travelmate 632XV 
Software Environment:
Problem Description: System boots fine, but after some minutes complete system freeze. Nothing is mentioned in the logfiles. 

System informations:
lspci -nn | grep IDE
00:10.0 IDE interface [0101]: ALi Corporation M5229 IDE [10b9:5229] (rev c4)

Steps to reproduce: reboot and wait some minutes (<10)
Comment 1 Florian Schneider 2008-02-06 03:12:19 UTC
Created attachment 14721 [details]
dmesg output
Comment 2 Alan 2008-02-06 03:28:47 UTC
If you build a kernel for the system using the old IDE layer with 2.6.24 what do you see  and what does the log look like.

Also if you boot 2.6.24 and leave it in text mode you should get traces for any ATA failure which will be needed to debug it.
Comment 3 Anonymous Emailer 2008-02-06 03:31:50 UTC
Reply-To: akpm@linux-foundation.org

On Wed,  6 Feb 2008 03:09:36 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9898
> 
>            Summary: libata fails for ALi Corporation M5229 IDE
>            Product: IO/Storage
>            Version: 2.5
>      KernelVersion: 2.6.24
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: IDE
>         AssignedTo: io_ide@kernel-bugs.osdl.org
>         ReportedBy: hathe@sidux.com
> 
> 
> Latest working kernel version: 2.6.23.14 (with blkdev)
> Earliest failing kernel version: 2.6.24 (with libata)
> Distribution: sidux
> Hardware Environment: Acer Travelmate 632XV 
> Software Environment:
> Problem Description: System boots fine, but after some minutes complete
> system
> freeze. Nothing is mentioned in the logfiles. 
> 
> System informations:
> lspci -nn | grep IDE
> 00:10.0 IDE interface [0101]: ALi Corporation M5229 IDE [10b9:5229] (rev c4)
> 
> Steps to reproduce: reboot and wait some minutes (<10)
> 

A regression.

What makes you think it's due to IDE?
Comment 4 Bartlomiej Zolnierkiewicz 2008-02-06 05:17:26 UTC
This is libata problem (Alan, please change the "Component" information).
Comment 5 Alan 2008-02-06 05:22:44 UTC
Quite frankly I don't know if its a libata problem or something else completely at this point but I'll move it over for now as its certainly not an old IDE one 
Comment 6 Florian Schneider 2008-02-08 01:22:49 UTC
I'm sorry but I was wrong. I built a 2.6.24 kernel without libata but with blkdev and same freezes appear. I thought it was libata related as libata did not work for this notebook with 2.6.23.
At this moment I have no clue what the problem could be as I build the 2.6.24 kernel with quite the same config the working 2.6.23 has. There are no additional modules loaded with 2.6.24.
And as there are no information in any logfile and no traces are print in textmode when a freeze happens it is kind of hard to locate the problem.
As it is, you can close that bug here and I'll open a new one if/when I find the reason for my freezes.
I apologize for the trouble caused,
Greetings,Florian
Comment 7 Roy Kimbrell 2008-10-15 09:43:51 UTC

Just installed the latest updates to Hardy on a Sony Vaio VGN-A270P. The problem with USB devices continues. I have a 250G drive connected via USB. I attempted to copy about 100G to that drive. It ran for 10 or 20 minutes then the OS locked up as it had before (e.g., no mouse, pressing Caps Lock doesn't light the caps-lock LED, no effect from Ctrl-Alt-Del). The fixes, if any, in the newest Ubuntu updates did not fix the problem.

Uname -a reports....
Linux sony-vaio 2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

Note You need to log in before you can comment on or make changes to this bug.