Bug 9835 - (no_battery_info) After Hibernation the battery charging information is not working any more.
(no_battery_info)
After Hibernation the battery charging information is not working any more.
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Battery
All Linux
: P1 normal
Assigned To: acpi_power-battery
:
Depends on:
Blocks: 7216 9243
  Show dependency treegraph
 
Reported: 2008-01-28 04:43 UTC by Rolf Kutz
Modified: 2008-01-28 15:37 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24
Tree: Mainline
Regression: Yes


Attachments

Description Rolf Kutz 2008-01-28 04:43:48 UTC
Latest working kernel version: 2.6.24-rc7
Earliest failing kernel version: 2.6.24-rc8
Distribution: Kubuntu 7.10
Hardware Environment: Lenovo Thinkpad T60
Software Environment: Kubuntu with KDE
Problem Description: After hibernating the system and resuming, the charging information is not shown any more in guidance-power-manager.

Steps to reproduce: Hibernate laptop and resume.
Comment 1 Anonymous Emailer 2008-01-28 04:50:36 UTC
Reply-To: akpm@linux-foundation.org

On Mon, 28 Jan 2008 04:43:49 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9835
> 
>            Summary: After Hibernation the battery charging information is
>                     not working any more.
>            Product: Power Management
>            Version: 2.5
>      KernelVersion: 2.6.24
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Hibernation/Suspend
>         AssignedTo: power-management_other@kernel-bugs.osdl.org
>         ReportedBy: rk@vzsze.de
> 
> 
> Latest working kernel version: 2.6.24-rc7
> Earliest failing kernel version: 2.6.24-rc8
> Distribution: Kubuntu 7.10
> Hardware Environment: Lenovo Thinkpad T60
> Software Environment: Kubuntu with KDE
> Problem Description: After hibernating the system and resuming, the charging
> information is not shown any more in guidance-power-manager.
> 
> Steps to reproduce: Hibernate laptop and resume.
> 

This regression apparently occurred very late in 2.6.24 development.  It
should be easy to pinpoint?

Comment 2 Rolf Kutz 2008-01-28 15:33:59 UTC
Closing bug since it was a configuration problem (missing sds). Thank you for your time and help.
Comment 3 Rafael J. Wysocki 2008-01-28 15:37:11 UTC
References : http://marc.info/?t=120152665200005&r=1&w=4

Note You need to log in before you can comment on or make changes to this bug.