Bug 9792 - Problem with ACPI on Acer Aspire 5050 (Also mentions Aspire 5053 NWXMi)
Summary: Problem with ACPI on Acer Aspire 5050 (Also mentions Aspire 5053 NWXMi)
Status: CLOSED DUPLICATE of bug 8953
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-21 19:06 UTC by Thomas Ramapuram
Modified: 2008-06-13 22:03 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23.12-52.fc7
Tree: Mainline
Regression: ---


Attachments
Output of acpidump (133.85 KB, text/plain)
2008-01-21 19:07 UTC, Thomas Ramapuram
Details
Output of dmesg (17.59 KB, text/plain)
2008-01-21 19:08 UTC, Thomas Ramapuram
Details
Output of dmidecode (9.60 KB, text/plain)
2008-01-21 19:08 UTC, Thomas Ramapuram
Details
use the attached tool to dump BIOS PRT/MPS table (79.30 KB, application/x-gzip)
2008-01-21 21:44 UTC, ykzhao
Details
BIOS PRT/MPS table (3.17 KB, text/plain)
2008-01-22 02:06 UTC, Thomas Ramapuram
Details
Picture of acpi=noirq (386.47 KB, image/jpeg)
2008-01-22 20:28 UTC, Thomas Ramapuram
Details
Picuture of screen acpi_osi=Linux (365.99 KB, image/jpeg)
2008-01-22 20:29 UTC, Thomas Ramapuram
Details
lspci output (9.06 KB, text/plain)
2008-01-22 23:16 UTC, Thomas Ramapuram
Details
The Output of dmesg on Ubuntu 7.10 (55.06 KB, text/plain)
2008-03-10 02:34 UTC, Thomas Ramapuram
Details
dmidecode on Ubuntu 7.10 (9.56 KB, text/plain)
2008-03-10 02:37 UTC, Thomas Ramapuram
Details

Description Thomas Ramapuram 2008-01-21 19:06:44 UTC
Current Kernel Version: 
    2.6.23.12-52.fc7

Distribution: 
    Fedora Core 7

Hardware Environment: 
    (As mentioned in the BIOS)
    CPU Type AMD Turion 64X2 Mobile Tech TL 52
    Speed: 1600 Mhz
    IDE Mode Name: WDC WD1200BEUS-22RSTO
    ATAPI Model Name: MATSHITADVD-RAM U3-85QS
    System Bios Version: v 1.3309
    VGA Bios Version: ATI 008-050I-052-000
    Product Name: Aspire 5050
    Manifacturer : Acer

Software Environment:
    output of uname -a
    Linux localhost.localdomain 2.6.23.12-52.fc7 #1 SMP Tue Dec 18 21:18:02 EST 2007 i686 athlon i386 GNU/Linux
    I am running the 32 bit version of linux on a 64 bit processor.

Problem Description:
    Linux loads only with acpi=off noapic
    I was able to boot only once with the variable "acpi_osi=Linux noapic" with a marked diffrence in power management.  The changes noticed where:
    Fan did not start immedeatly.
    Laptop powered down when shutting down (Usually I have to manually press the power switch to power down) 

Steps to reproduce:
Comment 1 Thomas Ramapuram 2008-01-21 19:07:51 UTC
Created attachment 14523 [details]
Output of acpidump
Comment 2 Thomas Ramapuram 2008-01-21 19:08:26 UTC
Created attachment 14524 [details]
Output of dmesg
Comment 3 Thomas Ramapuram 2008-01-21 19:08:56 UTC
Created attachment 14525 [details]
Output of dmidecode
Comment 4 Zhang Rui 2008-01-21 19:32:25 UTC
what can you see when the laptop hangs with acpi enabled?
It would be great if you can get the dmesg via a serial console or get a photograph of your screen when the laptop hangs. :)

BTW: what if you boot with acpi=noirq and noapic?
Comment 5 ykzhao 2008-01-21 21:44:53 UTC
Created attachment 14526 [details]
use the attached tool to dump BIOS PRT/MPS table

Will you please use the attached tool to dump BIOS PRT/MPS table?
Thanks.
Comment 6 Thomas Ramapuram 2008-01-22 02:06:58 UTC
Created attachment 14530 [details]
BIOS PRT/MPS table

Hi,
Here is the output of the BIOS PRT/MPS table.  Hope it helps.
Comment 7 Thomas Ramapuram 2008-01-22 02:08:31 UTC
(In reply to comment #4)
> what can you see when the laptop hangs with acpi enabled?
> It would be great if you can get the dmesg via a serial console or get a
> photograph of your screen when the laptop hangs. :)
> 
> BTW: what if you boot with acpi=noirq and noapic?
> 

Got to wait till this evening for me to organize a camera.
Thomas
Comment 8 Thomas Ramapuram 2008-01-22 20:28:18 UTC
Created attachment 14540 [details]
Picture of acpi=noirq

I get a kernel panic.
Comment 9 Thomas Ramapuram 2008-01-22 20:29:43 UTC
Created attachment 14541 [details]
Picuture of screen acpi_osi=Linux

This is with the quite flag removed.
Comment 10 Zhang Rui 2008-01-22 23:08:58 UTC
(In reply to comment #8)
> Picture of acpi=noirq
did you boo the kernel with "acpi=off" or "acpi=off noapic"?

Can you please clear CONFIG_HOTPLUG_PCI and boot with pci=nommconf and pnpacpi=off (acpi is enabled)?
Please take a picture of the screen if it still hangs.
Comment 11 Zhang Rui 2008-01-22 23:09:23 UTC
Please attach the lspci output as well. :)
Comment 12 Thomas Ramapuram 2008-01-22 23:16:34 UTC
Created attachment 14542 [details]
lspci output

with the -v option.
Comment 13 Thomas Ramapuram 2008-01-22 23:24:30 UTC
(In reply to comment #10)
> (In reply to comment #8)
> > Picture of acpi=noirq
> did you boo the kernel with "acpi=off" or "acpi=off noapic"?
Is this a reply to acip=noirq Picutre?  In that case the option was 
title Fedora (2.6.23.12-52.fc7) test
        root (hd0,1)
        kernel /vmlinuz-2.6.23.12-52.fc7 ro root=/dev/VolGroup00/LogVol00 acpi=noirq noapic rhgb
        initrd /initrd-2.6.23.12-52.fc7.img

In the other picutre the option was the same as above but acpi=noirq was substitued with acpi_osi=Linux.

> 
> Can you please clear CONFIG_HOTPLUG_PCI and boot with pci=nommconf and
> pnpacpi=off (acpi is enabled)?
> Please take a picture of the screen if it still hangs.
> 

Ps: I have not compiled the kernel before.  I could do it but I'll need a little time to go through some tutorials.

If I could get some pointers it would be helpful.
Comment 14 Zhang Rui 2008-01-27 19:30:06 UTC
(In reply to comment #13)
> Ps: I have not compiled the kernel before.  I could do it but I'll need a
> little time to go through some tutorials.
> If I could get some pointers it would be helpful.
google "build a custom linux kernel", :)
Comment 15 Zhang Rui 2008-02-18 18:31:39 UTC
thomas, any updates on this?
I'll close this bug if you can not provide the info I mentioned in comment #10.
Comment 16 Thomas Ramapuram 2008-02-18 19:51:38 UTC
Give me one more day.  I was able to recompile the kernel.  I will take pictures and upload it.
Comment 17 Thomas Ramapuram 2008-02-27 08:12:59 UTC
I'm Sorry.  I dont think I'm able to do this.  Whenever I try to compile the kernel on my system.  The laptop shut's down.

If I'm able to Compile the Kernel.  I will request you to reopen the issue.  Thanks for your effort.

I'll keep trying.
Comment 18 Thomas Ramapuram 2008-03-10 02:32:53 UTC
Just wanted to let you know that this computer works funtastatic on Ubuntu 7.10.

The Sleep button works,
Hibernate works
The Lid Close Works.
The Fan is not running all the time.
Comment 19 Thomas Ramapuram 2008-03-10 02:34:11 UTC
Created attachment 15198 [details]
The Output of dmesg on Ubuntu 7.10
Comment 20 Thomas Ramapuram 2008-03-10 02:37:29 UTC
Created attachment 15199 [details]
dmidecode on Ubuntu 7.10
Comment 21 Zhang Rui 2008-03-10 19:42:40 UTC

*** This bug has been marked as a duplicate of bug 8953 ***

Note You need to log in before you can comment on or make changes to this bug.