Bug 9789 - Deadlock on _any_ ACPI event
Deadlock on _any_ ACPI event
Status: CLOSED DUPLICATE of bug 9787
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
All Linux
: P1 high
Assigned To: acpi_acpica-core@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 09:03 UTC by Nick
Modified: 2008-01-24 13:23 UTC (History)
0 users

See Also:
Kernel Version: 2.6.24-rc8
Tree: Mainline
Regression: ---


Attachments

Description Nick 2008-01-21 09:03:38 UTC
Latest working kernel version: 2.6.23 for sure (but I had some 2.6.24 kernel wroking)
Earliest failing kernel version: current 2.6.24, up to a7da60f41551abb3c520b03d42ec05dd7decfc7f   mainline commit

Hardware Environment: x86_64
Problem Description:
It's impossible to use any last kernel with ACPI compiled in: _any_ ACPI even hangs my laptop without any [net]console output or so.
Any ACPI even mean: lid closing, AC adapter removing/plugging in, button press.

Guess, needless to say that it's impossible to use laptop without ACPI:
no battery info, no automating AC adapter events, no hibernate on the button press.

Steps to reproduce:
It can be reproduced easily and almost 100%.  I'm just booting ACPI kernel and removing AC adapter - laptop is locked.

I'm trying 2.6.24-rc5 and lower now to try to find out the problem release.
But I can boot 2.6.23 anytime - and there is no the problem there.
Comment 1 Nick 2008-01-21 10:37:12 UTC

*** This bug has been marked as a duplicate of bug 9787 ***

Note You need to log in before you can comment on or make changes to this bug.