Bug 9786 - possible recursive locking detected - eventpoll
possible recursive locking detected - eventpoll
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2008-01-21 08:22 UTC by Denys Fedoryshchenko
Modified: 2008-04-10 13:23 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Denys Fedoryshchenko 2008-01-21 08:22:42 UTC
Latest working kernel version: 2.6.24-rc7
Earliest failing kernel version: 2.6.24-rc8
Distribution: Gentoo
Hardware Environment: Dell
Software Environment:
Problem Description:

Steps to reproduce:
I didnt catch how to reproduce, appeared while worked in screen

Here is dmesg

[625138.248260] ============================================= 
[625138.248542] [ INFO: possible recursive locking detected ] 
[625138.248686] 2.6.24-rc8-devel #2 
[625138.248821] --------------------------------------------- 
[625138.248963] screen/18164 is trying to acquire lock: 
[625138.249101]  (&q->lock){++..}, at: [<c01175ff>] __wake_up+0x15/0x42 
[625138.249454] 
[625138.249456] but task is already holding lock: 
[625138.249724]  (&q->lock){++..}, at: [<c01175ff>] __wake_up+0x15/0x42 
[625138.250073] 
[625138.250075] other info that might help us debug this: 
[625138.250343] 2 locks held by screen/18164: 
[625138.250477]  #0:  (&tty->atomic_read_lock){--..}, at: [<c0231a6c>] 
read_chan+0x18f/0x50b 
[625138.250960]  #1:  (&q->lock){++..}, at: [<c01175ff>] __wake_up+0x15/0x42 
[625138.251356] 
[625138.251357] stack backtrace: 
[625138.251623] Pid: 18164, comm: screen Not tainted 2.6.24-rc8-devel #2 
[625138.251764]  [<c0105e84>] show_trace_log_lvl+0x1a/0x2f 
[625138.251959]  [<c010682c>] show_trace+0x12/0x14 
[625138.252150]  [<c0107123>] dump_stack+0x6c/0x72 
[625138.252338]  [<c01384c0>] __lock_acquire+0x172/0xb8c 
[625138.252533]  [<c01392a7>] lock_acquire+0x5f/0x78 
[625138.252725]  [<c032afa7>] _spin_lock_irqsave+0x34/0x44 
[625138.252920]  [<c01175ff>] __wake_up+0x15/0x42 
[625138.253108]  [<c0186a16>] ep_poll_safewake+0x8e/0xbf 
[625138.253300]  [<c01876df>] ep_poll_callback+0x9f/0xac 
[625138.253491]  [<c0115d36>] __wake_up_common+0x32/0x5c 
[625138.253688]  [<c011761b>] __wake_up+0x31/0x42 
[625138.253878]  [<c022c803>] tty_wakeup+0x4f/0x54 
[625138.254070]  [<c0232c7c>] pty_unthrottle+0x15/0x21 
[625138.254258]  [<c022ffe3>] check_unthrottle+0x2e/0x30 
[625138.254445]  [<c0231cf4>] read_chan+0x417/0x50b 
[625138.254633]  [<c022ec67>] tty_read+0x66/0xac 
[625138.254819]  [<c01628dc>] vfs_read+0x8e/0x117 
[625138.255004]  [<c0162d10>] sys_read+0x3d/0x61 
[625138.255190]  [<c0104dee>] sysenter_past_esp+0x5f/0xa5 
[625138.255376]  =======================
Comment 1 Rafael J. Wysocki 2008-01-21 12:01:47 UTC
References      : http://lkml.org/lkml/2008/1/21/179
Comment 2 Stefan Richter 2008-01-21 15:04:33 UTC
Earlier report and discussion of the cause:
http://lkml.org/lkml/2008/1/3/350

Lockdep annotation patch:
http://lkml.org/lkml/2008/1/13/84
Comment 3 Stefan Richter 2008-01-22 14:56:40 UTC
Lockdep annotation patch reposted:
http://lkml.org/lkml/2008/1/22/345
Comment 4 Stefan Richter 2008-01-22 15:09:28 UTC
patch added to -mm
http://marc.info/?l=linux-mm-commits&m=120104316528878
Comment 5 Denys Fedoryshchenko 2008-01-31 17:15:59 UTC
I test patch and it seems fixing issue, for now tested only during 1 day, but seems not causing any issues.
Probably it must find way to mainline asap, otherwise this cosmetic(?) bug will cause a lot of fake bug reports like mine.

Note You need to log in before you can comment on or make changes to this bug.