Bug 9773 - pptp/ppp connection die at high speed on Athlon X2 6000+
Summary: pptp/ppp connection die at high speed on Athlon X2 6000+
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: Arnaldo Carvalho de Melo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-17 23:33 UTC by Wizard Vandal
Modified: 2008-01-25 18:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.23.12
Tree: Mainline
Regression: ---


Attachments

Description Wizard Vandal 2008-01-17 23:33:53 UTC
Distribution: debian sid, vanilla kernel
Hardware Environment: Athlon64 X2 6000+ Nforce5
Software Environment: pptp 1.7.0 pppd 2.4.4

Problem Description:
when I download data at high speed (1,5 MB/s or more) connection (pptp dies) drops and reconnect begins (persist option used for pppd) and after reconnect it dies again and again. connection made by "pppd call provider"

before upgrade of hardware (was Athlon64 3500+ NForce4) all works fine at any speed.

Connection will be working if I do some CPU aggressive work such as kernel compile at the same time when I download. When CPU load become low it will drop again.

kernel 2.6.24rc8 makes it worst. As I see it just hangs my console with message something like "waiting for ppp0 finish" or so... I don't remember exactly message.


Steps to reproduce:
I think you can use any X2 Athlon, make pptp connection and try to download something...
Comment 1 Anonymous Emailer 2008-01-17 23:47:54 UTC
Reply-To: akpm@linux-foundation.org

On Thu, 17 Jan 2008 23:33:54 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=9773
> 
>            Summary: pptp/ppp connection die at high speed on Athlon X2 6000+
>            Product: Networking
>            Version: 2.5
>      KernelVersion: 2.6.23.12
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: blocking
>           Priority: P1
>          Component: Other
>         AssignedTo: acme@ghostprotocols.net
>         ReportedBy: wizard580@gmail.com
> 
> 
> Distribution: debian sid, vanilla kernel
> Hardware Environment: Athlon64 X2 6000+ Nforce5
> Software Environment: pptp 1.7.0 pppd 2.4.4
> 
> Problem Description:
> when I download data at high speed (1,5 MB/s or more) connection (pptp dies)
> drops and reconnect begins (persist option used for pppd) and after reconnect
> it dies again and again. connection made by "pppd call provider"
> 
> before upgrade of hardware (was Athlon64 3500+ NForce4) all works fine at any
> speed.
> 
> Connection will be working if I do some CPU aggressive work such as kernel
> compile at the same time when I download. When CPU load become low it will
> drop
> again.
> 
> kernel 2.6.24rc8 makes it worst. As I see it just hangs my console with
> message
> something like "waiting for ppp0 finish" or so... I don't remember exactly
> message.
> 
> 
> Steps to reproduce:
> I think you can use any X2 Athlon, make pptp connection and try to download
> something...

(weird)
Comment 2 Wizard Vandal 2008-01-19 01:18:32 UTC
yes, it's weird. I've made upgrade only for better work in linux (and rarely playing new games in windows). And now I can't do my work. This work is depends on good network state and I can use only pptp connection.

sorry for offtopic.
Comment 3 Jarek Poplawski 2008-01-19 10:22:53 UTC
Andrew Morton wrote, On 01/18/2008 08:48 AM:

> On Thu, 17 Jan 2008 23:33:54 -0800 (PST) bugme-daemon@bugzilla.kernel.org
> wrote:
> 
>> http://bugzilla.kernel.org/show_bug.cgi?id=9773
>>
>>            Summary: pptp/ppp connection die at high speed on Athlon X2 6000+
>>            Product: Networking
>>            Version: 2.5
>>      KernelVersion: 2.6.23.12


...

>> kernel 2.6.24rc8 makes it worst. As I see it just hangs my console with
>> message
>> something like "waiting for ppp0 finish" or so... I don't remember exactly
>> message.

Could you please:

- check this after echo 1 > /proc/sys/kernel/sched_compat_yield
- check this with 2.6.22

Regards,
Jarek P.
Comment 4 Wizard Vandal 2008-01-25 01:16:46 UTC
echo 1 > /proc/sys/kernel/sched_compat_yield solved the problem...
since this parameter was introduced in 2.6.23 I think it will work in 2.6.22 (I can't test it right now)

can you tell me that it's fixable for 2.6.23/24 kernel?
Comment 5 Jarek Poplawski 2008-01-25 01:50:27 UTC
> echo 1 > /proc/sys/kernel/sched_compat_yield solved the problem...
> since this parameter was introduced in 2.6.23 I think it will work in 2.6.22
> (I
> can't test it right now)

If 2.6.23 works OK with this parameter, then of course no need to check
2.6.22. It would be only interesting when this problem had some other
then this parameter reason.

> can you tell me that it's fixable for 2.6.23/24 kernel?

You simply should use this parameter with 2.6.23/24 and probably later,
unless the default value is changed some day or some programs change
their behavior wrt. yield system call. So, it's not considered as a
kernel bug, and I think you can close this bugzilla report (unless you
don't agree with this...).

Regards,
Jarek P.
Comment 6 Wizard Vandal 2008-01-25 18:13:48 UTC
ok... I'm not too familiar with the kernel internals, so I must agree with you and hope this is not a kernel bug.

Note You need to log in before you can comment on or make changes to this bug.