Bug 97701 - [regression] won't boot unless radeon.audio=0
Summary: [regression] won't boot unless radeon.audio=0
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-04 16:22 UTC by Jouni Mettälä
Modified: 2015-05-11 17:53 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.1-rc2
Tree: Mainline
Regression: Yes


Attachments
picture of trace (316.99 KB, image/jpeg)
2015-05-04 16:22 UTC, Jouni Mettälä
Details
possible fix (1.00 KB, patch)
2015-05-04 18:40 UTC, Alex Deucher
Details | Diff

Description Jouni Mettälä 2015-05-04 16:22:24 UTC
Created attachment 175791 [details]
picture of trace

Boot regression between 4.1-rc1 and 4.1-rc2

04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV350 [Radeon 9550/9600/X1050 Series]

Attached picture shows trace.

I guess full bisect is not needed.

ps. https://lkml.org/lkml/2015/5/4/491 looks like it might be related.
Comment 1 Jouni Mettälä 2015-05-04 16:36:54 UTC
Reverting commit 0f55db36d49d45b80eff0c0a2a498766016f458b fixes it for me too.
Comment 2 Alex Deucher 2015-05-04 18:40:13 UTC
Created attachment 175801 [details]
possible fix

This patch should fix it.
Comment 3 Jouni Mettälä 2015-05-04 19:12:58 UTC
Patch fixed it.

Note You need to log in before you can comment on or make changes to this bug.