Bug 9755 - crash in kmem_cache_init
crash in kmem_cache_init
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-64
All Linux
: P1 normal
Assigned To: Anton Blanchard
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2008-01-15 13:02 UTC by Rafael J. Wysocki
Modified: 2008-01-26 16:04 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.24-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-01-15 13:02:16 UTC
Subject         : crash in kmem_cache_init
Submitter       : Olaf Hering <olaf@aepfle.de>
Date            : 2008-01-15 16:09
References      : http://lkml.org/lkml/2008/1/15/180

Probably caused by:

commit 04231b3002ac53f8a64a7bd142fde3fa4b6808c6
Author: Christoph Lameter <clameter@sgi.com>
Date:   Tue Oct 16 01:25:32 2007 -0700

    Memoryless nodes: Slab support

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=04231b3002ac53f8a64a7bd142fde3fa4b6808c6
Comment 1 Pekka Enberg 2008-01-23 13:07:13 UTC
This patch on top of Mel's slab N_NORMAL_MEMORY revert should fix the problem:
 
http://lkml.org/lkml/2008/1/23/332

Note You need to log in before you can comment on or make changes to this bug.