Bug 9753 - APIC error on CPU(0): 40(40)
APIC error on CPU(0): 40(40)
Status: REJECTED UNREPRODUCIBLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: i386
All Linux
: P1 normal
Assigned To: Ingo Molnar
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2008-01-15 06:48 UTC by Miha
Modified: 2013-04-09 06:23 UTC (History)
6 users (show)

See Also:
Kernel Version: Linux localhost 2.6.23-gentoo-r3 #3 SMP PREEMPT Tue Jan 15 15:03
Tree: Mainline
Regression: ---


Attachments

Description Miha 2008-01-15 06:48:01 UTC
00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation Mobile LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation Mobile IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Mobile SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
05:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
07:00.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
07:00.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
07:00.2 System peripheral: Ricoh Co Ltd Unknown device 0843 (rev 12)
07:00.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
07:00.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)


Here is my dmesg: http://gigabox.org/~mogix/dmes

Here are my interrupts: http://gigabox.org/~mogix/inter

I have Acer Aspire 7720.
I searched lots of forums but still no go. 
I always says APIC error on CPU(0): 40(40)
Comment 1 Thomas Gleixner 2008-01-15 23:21:18 UTC
APIC error on CPU0: 40(40): The APIC received an illegal interrupt vector. The error is detected in the APIC internally. Not much we can do about that.

Is the box working correctly aside of those APIC error messages ?
Are you just worried about the error messages in the syslog ? 

Thanks,
       tglx
Comment 2 Miha 2008-01-16 05:29:21 UTC
(In reply to comment #1)
> APIC error on CPU0: 40(40): The APIC received an illegal interrupt vector. The
> error is detected in the APIC internally. Not much we can do about that.
> 
> Is the box working correctly aside of those APIC error messages ?
> Are you just worried about the error messages in the syslog ? 
> 
> Thanks,
>        tglx
> 

Laptop is working correctly I just emerged KDE and running. But there is one problem when I shutdown it the kernel makes backtrace when it comes to Remounting filesystems. I then tried to boot with noapic nolapic and laptop shutdowns ok. But I don't have the second CPU. I have Core 2 Duo. And one other thing I can hear the disk clicking or something like that. I really don't know how to solve this. I tried with KDE 4 live cd and there are no APIC errors. But with others LiveCD-s the laptop just shutdowns.

Comment 3 Miha 2008-01-16 05:30:14 UTC
I get about 85 APIC errors and also in cat /proc/interrupts ERR in 30 minutes.
Comment 4 Miha 2008-01-16 05:38:19 UTC
Maybe some firmware problems or BIOS problems?
Comment 5 Thomas Gleixner 2008-01-16 06:21:25 UTC
> Maybe some firmware problems or BIOS problems?

Can you check, whether there is a BIOS update available for your system ?

Thanks,
	tglx

Comment 6 Miha 2008-01-16 06:32:05 UTC
OK, I booted only with this:

kernel /kernel7 root=/dev/sda5 acpi_osi=Linux noapic

I got to work two cores, but i get lots and lots of interrupt ERRors:

cat /proc/interrupts 
           CPU0       CPU1       
  0:       9590          0    XT-PIC-XT        timer
  1:       3751          0    XT-PIC-XT        i8042
  2:          0          0    XT-PIC-XT        cascade
  8:         40          0    XT-PIC-XT        rtc
  9:       4332          0    XT-PIC-XT        acpi
 10:          2          0    XT-PIC-XT        ohci1394, uhci_hcd:usb4
 11:      53006          0    XT-PIC-XT        ehci_hcd:usb1, ehci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb5, uhci_hcd:usb6, uhci_hcd:usb7, sdhci:slot0, ipw3945, HDA Intel, i915@pci:0000:00:02.0
 12:      85737          0    XT-PIC-XT        i8042
 14:       9506          0    XT-PIC-XT        libata
 15:        132          0    XT-PIC-XT        libata
217:          3          1   PCI-MSI-edge      eth0
219:       8409       8412   PCI-MSI-edge      ahci
NMI:          0          0 
LOC:     214609     222174 
ERR:      13035
MIS:          0


I checked BIOS on acer page there is an update BIOS version 1.21. But for Vista it says.

used libsmbios: getSystemId 
Libsmbios:    0.13.6
Error getting the System ID   : 
Service Tag:  LXAML0X061742258931601
Express Service Code: 9223372036854775807
Product Name: Aspire 7720
BIOS Version: V1.18

I'll try to update it. Hoping for best.


Comment 7 Miha 2008-01-16 09:36:25 UTC
Updating BIOS didn't help.

Comment 8 Ivo Sabev 2008-02-01 03:26:10 UTC
I have Aspire 5720 and I am featuring this problem also.
Comment 9 Jike Song 2008-02-04 19:50:54 UTC
Same problem on HPC NX6325.  Anyhow, it dosen't hurt anything, so I just ignore these messages.
Comment 10 wax 2008-05-19 02:52:57 UTC
i posted this comment in the ubuntu launchpad section asswell
This bug is realy anoying because the loging keeps the disc busy witch is not very nice on a laptop

i know there are several reasons why this bug could be appearing
I happend to get this error to in my log 100's of times. I tried blacklisting my firewire modules as i assumed they were the problem but the are not.

I found out this error only gets printed in my log when my cpu fan is turning and not when it is silent, this error also appears a lot when the fan just starts to rotate.

Hope this might help someone to find a sollution for at least on of these errors
Comment 11 Miha 2008-05-20 04:19:10 UTC
I disabled ACPI for FAN in my kernel 2.6.24 and there are no APIC Error more.

Thanks for solving this wax, thanks again.
Comment 12 wax 2008-05-21 08:41:18 UTC
i am glad i could help but...
could you please explain how to  dissable acpi for the fan?
Comment 13 Miha 2008-05-21 14:49:36 UTC
(In reply to comment #12)
> i am glad i could help but...
> could you please explain how to  dissable acpi for the fan?
> 

Well, actually it turned out that after suspending to RAM, it appeared again APIC error, but then I disabled also ACPI for CPU and now there are no APIC error more, but I can't suspend to RAM.

OK.. I disabled ACPI Fan (and Processor) in kernel like this:

/usr/src/linux -> make menuconfig
Power Management Options -> ACPI( Advanced Configuration and Power Interface) Support -> 
here you have item, Fan and Processor (and submenu after Processor Thermal Zone) I disabled this to, saved config, recompiled kernel.

If you disable Processor in this section also CPU Frequency won't work anymore, because it depends on it.
Comment 14 Zhang Rui 2008-06-03 17:57:17 UTC
Miha,
Please download the latest pmtools at:
http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/
and run "./acpidump > acpidump.txt"
and attach the
1. kernel .config
2. full dmesg output
3. acpidump.txt
Comment 15 Miha 2008-06-04 02:04:10 UTC
(In reply to comment #14)
> Miha,
> Please download the latest pmtools at:
> http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/
> and run "./acpidump > acpidump.txt"
> and attach the
> 1. kernel .config
> 2. full dmesg output
> 3. acpidump.txt
> 

Downloaded: - pmtools-20071116.tar.gz  20-Nov-2007 17:55   50K

Files:
- http://gigabox.org/pub/dmesg
- http://gigabox.org/pub/acpidump.txt
- http://gigabox.org/pub/config

lspci:
- http://gigabox.org/pub/lspci

cat /proc/interrupt
- http://gigabox.org/pub/inter

Comment 16 Zhang Rui 2008-06-04 18:49:41 UTC
>APIC error 40. this message disappears before doing suspend to ram if CONFIG_ACPI_FAN is cleared

this is weird, there is no ACPI fan device at all, and there is not difference whether you set CONFIG_ACPI_FAN or not.
Comment 17 Miha 2008-06-05 00:18:46 UTC
(In reply to comment #16)
> >APIC error 40. this message disappears before doing suspend to ram if CONFIG_ACPI_FAN is cleared
> 
> this is weird, there is no ACPI fan device at all, and there is not difference
> whether you set CONFIG_ACPI_FAN or not.
> 

Well, the only difference is that if I enable ACPI fan I get about 10000 more APIC error a minute. If it's disabled like now, i get about 100 APIC errors/minute.
Comment 18 wax 2008-06-14 09:44:59 UTC
Bug is solved over here after upgrading bios to version 1.40 from an acer aspire 7720z. Cpu also runs a lot cooler
Comment 19 Miha 2008-06-14 09:50:15 UTC
Well, Acer finally fixed BIOS. Now there are no APIC at all. Updated to 1.40 version from 1.21

Link: ftp://ftp.work.acer-euro.com/notebook/aspire_7720/vista/Bios
There are many bugs fixed referring to Changelog.

Thanks for help guys.

Comment 20 Natalie Protasevich 2008-06-14 20:50:28 UTC
Thanks for the update. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.