Bug 97391 - Computer Reboots instead of Shutdown
Summary: Computer Reboots instead of Shutdown
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-28 04:13 UTC by Brian Monroe
Modified: 2016-04-05 21:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.17.4 or later
Tree: Fedora
Regression: No


Attachments

Description Brian Monroe 2015-04-28 04:13:59 UTC
Description of problem: When asking for a shutdown, the laptop is rebooting


Version-Release number of selected component (if applicable):
kernel 3.17.4-300.fc21.x86_64 or later. 
hardware : HP EliteBook 9480m  

How reproducible: Shutdown the computer


Actual results: Reboot

Expected results: Stay shutdown

Additional info: After additional troubleshooting we noticed that the issue is likely related to the xHCI chipset. Disabling xHCI support in the BIOS and by extension usb3 support, can be used as a work around to resolve the issue. 

A Fedora bug was filed, but I wanted to report it upstream since it hasn't been resolved yet. It can be viewed here: https://bugzilla.redhat.com/show_bug.cgi?id=1168557
Comment 1 Greg Kroah-Hartman 2015-04-28 07:18:59 UTC
On Tue, Apr 28, 2015 at 04:13:59AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=97391
> 
>             Bug ID: 97391
>            Summary: Computer Reboots instead of Shutdown

Please send to the linux-usb@vger.kernel.org mailing list.
Comment 2 Brian Monroe 2015-04-28 18:24:14 UTC
Sent to list
Comment 3 Brian Monroe 2015-05-04 16:12:19 UTC
http://fpaste.org/218248/43075468/ - dmesg --kernel output after shutting down and getting reboot action instead.
Comment 4 Brian Monroe 2015-05-14 22:19:29 UTC
From the list, it was requested to build a kernel with xhci as a module to see if a kernel panic was happening during shutdown.  

I did this and tried to remove it and re-add (rmmod and modprobe) it to see if a kernel panic happens, but it doesn't.
Comment 5 Brian Monroe 2015-05-14 22:40:50 UTC
http://ur1.ca/lwkov - dmesg --kernel output after removing the xhci_pci module.
Comment 6 Brian Monroe 2015-09-02 00:13:40 UTC
This issue is still persistent in kernel version 4.1.6
Comment 7 Brian Monroe 2016-04-05 21:39:04 UTC
This issue is no longer persistent in kernel version 4.4.6

Note You need to log in before you can comment on or make changes to this bug.