Bug 9720 - DVB-USB UMT-010 driver has certain oops when installed
DVB-USB UMT-010 driver has certain oops when installed
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: v4l-dvb
Classification: Unclassified
Component: dvb-usb
All Linux
: P1 normal
Assigned To: dvb-usb
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 12:54 UTC by Austin Lund
Modified: 2008-08-04 17:24 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.22
Tree: Mainline
Regression: ---


Attachments

Description Austin Lund 2008-01-09 12:54:39 UTC
(Bug was first reported here: https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/115284)

In the umt-010 driver the struct umt_properties sets the number of URBs for transfer to 20.  But in dvb-usb.h MAX_NO_URBS_FOR_DATA_STREAM is set to 10.

Not surprisingly this causes an oops for all devices which use the umt-010 chipset when they are inserted.  

Either the .count variable must be decreased or the MAX_NO_URBS_FOR_DATA_STREAM must be increased.  When either is done the oops disappears. 

I don't have a functioning pll_desc for the tuner of my device, so I cannot test the actual results of this change.  But it does avoid a certain kernel oops.
Comment 2 Austin Lund 2008-08-04 17:24:12 UTC
This fix seems to be in 2.6.26.  There have been many reports that it is fixed.

Note You need to log in before you can comment on or make changes to this bug.