Bug 9705 - Cannot resume from STR on Linux
Cannot resume from STR on Linux
Status: CLOSED DUPLICATE of bug 7225
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2008-01-07 04:59 UTC by Alessandro Guido
Modified: 2009-04-02 04:56 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.24-rc7
Tree: Mainline
Regression: No


Attachments
dmesg (16.68 KB, application/octet-stream)
2008-01-07 05:02 UTC, Alessandro Guido
Details
New dmesg with pm_test = core (21.12 KB, text/plain)
2008-01-13 08:01 UTC, Alessandro Guido
Details

Description Alessandro Guido 2008-01-07 04:59:58 UTC
Most recent kernel where this bug did not occur: n/a
Distribution: Gentoo/Linux
Hardware Environment: Sony Vaio VGN-FS215S
Software Environment:
Problem Description:
My laptop can't resume form STR. With pm_trace I get this in dmesg:
  Magic number: 0:865:376
  hash matches drivers/base/power/main.c:97


Steps to reproduce:
echo mem > /sys/power/state
Comment 1 Alessandro Guido 2008-01-07 05:02:47 UTC
Created attachment 14326 [details]
dmesg

the problem also occurs without the nvidia proprietary module loaded.
Comment 2 Rafael J. Wysocki 2008-01-12 15:31:01 UTC
Please apply the patches from:
http://www.sisk.pl/kernel/hibernation_and_suspend/2.6.24-rc7/patches/
on top of 2.6.24-rc7, compile the kernel with CONFIG_PM_DEBUG set, install it,
boot it (without the nvidia module) and do:

# echo 8 > /proc/sys/kernel/printk
# echo core > /sys/power/pm_test
# echo mem > /sys/power/state

(it should run the suspend sequence without actually suspending, busy loop for 5 seconds and run the resume sequence).
Comment 3 Alessandro Guido 2008-01-13 08:01:11 UTC
Created attachment 14434 [details]
New dmesg with pm_test = core

This is the dmesg after:
# echo 8 > /proc/sys/kernel/printk
# echo core > /sys/power/pm_test
# echo mem > /sys/power/state
Comment 4 Rafael J. Wysocki 2008-01-13 13:10:28 UTC
This means the problem occurs when the system sleep state is actually entered or that it's fixed by one of the patches in the series.

Can you check if normal suspend works with these patches?

Also, can you please verify that s2ram doesn't help (http://suspend.sourceforge.net/docs.shtml)?
Comment 5 Alessandro Guido 2008-01-13 14:57:49 UTC
eh, actually it seems I found a way to make STR work on my laptop: suspending from X using the proprietary nvidia module!

using the free "nv" module doesn't work as doesn't work trying to suspend from console with nvidia.ko loaded but without X running.

So, is this the best I can get? I mean, should I try to debug it furtherly or will I never make any progress?

Btw I'm going to try if a plain 2.6.24-rc7 without those patches will work.
Comment 6 Alessandro Guido 2008-01-13 15:12:45 UTC
unpatched kernel works too
Comment 7 Rafael J. Wysocki 2008-01-13 15:51:19 UTC
Good.

It might be possible to make the suspend work with nv and s2ram, but I'm not sure if that's worthy of investing time into.

Anyway, this means the problem is we don't initialize the graphics appropriately during suspend, so that's a duplicate of Bug 7225.

*** This bug has been marked as a duplicate of bug 7225 ***
Comment 8 Rafael J. Wysocki 2008-01-13 16:00:06 UTC
s/during suspend/during resume/

Note You need to log in before you can comment on or make changes to this bug.