Bug 9697 - No battery on laptop because of "No handler for Region [EC__]" acpi error
No battery on laptop because of "No handler for Region [EC__]" acpi error
Status: CLOSED DUPLICATE of bug 9627
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks: 9243
  Show dependency treegraph
 
Reported: 2008-01-05 14:37 UTC by Mark
Modified: 2008-10-17 14:44 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.24-rc6
Tree: Mainline
Regression: Yes


Attachments
dmesg output (31.25 KB, text/plain)
2008-01-05 14:39 UTC, Mark
Details
exact kernel version (152 bytes, text/plain)
2008-01-05 14:40 UTC, Mark
Details
acpidump (22.63 KB, application/octet-stream)
2008-01-05 14:41 UTC, Mark
Details
my dsdt (20.44 KB, application/octet-stream)
2008-01-05 14:44 UTC, Mark
Details
working 2.6.23 dmesg (23.61 KB, text/plain)
2008-01-05 15:03 UTC, Mark
Details

Description Mark 2008-01-05 14:37:49 UTC
Most recent kernel where this bug did not occur: 2.6.23
Distribution:Ubuntu,Fedora,Debian
Hardware Environment:MSI ex600,pr200 and GX700 laptops
Problem Description:
The battery is not found because of:
[   25.866703] ACPI Error (evregion-0316): No handler for Region [EC__] (f7c108e8) [EmbeddedControl] [20070126]
[   25.866708] ACPI Error (exfldio-0289): Region EmbeddedControl(3) has no handler [20070126]
[   25.866713] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC__.BAT1._STA] (Node f7c13210), AE_NOT_EXIST

Steps to reproduce: The problem just appears by using the mentioned hardware.
Comment 1 Mark 2008-01-05 14:39:57 UTC
Created attachment 14297 [details]
dmesg output
Comment 2 Mark 2008-01-05 14:40:26 UTC
Created attachment 14298 [details]
exact kernel version
Comment 3 Mark 2008-01-05 14:41:34 UTC
Created attachment 14299 [details]
acpidump
Comment 4 Mark 2008-01-05 14:44:02 UTC
Created attachment 14300 [details]
my dsdt
Comment 5 Adrian Bunk 2008-01-05 14:53:50 UTC
Please attach the dmesg for the working 2.6.23 kernel.
Comment 6 Mark 2008-01-05 15:03:43 UTC
Created attachment 14301 [details]
working 2.6.23 dmesg
Comment 7 Alexey Starikovskiy 2008-01-07 08:50:24 UTC
Please check if the patch from 9627 helps.

*** This bug has been marked as a duplicate of bug 9627 ***
Comment 8 Mark 2008-01-07 12:50:27 UTC
Yup, thanks, the patch from http://bugzilla.kernel.org/show_bug.cgi?id=9627 does the job.

Note You need to log in before you can comment on or make changes to this bug.