Bug 9689 - hgafb module is broken & unmaintained
hgafb module is broken & unmaintained
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
All Linux
: P1 low
Assigned To: James Simmons
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 15:26 UTC by Roland Kletzing
Modified: 2008-06-04 14:39 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.24-rc6
Tree: Mainline
Regression: ---


Attachments

Description Roland Kletzing 2008-01-04 15:26:18 UTC
Most recent kernel where this bug did not occur: ?
Distribution: OpenSuSE 10.3 with 2.6.24-rc6
Hardware Environment: vmware workstation 6.x on fujitsu siemens lifebook e series
Software Environment: ???

Problem Description:
the module hgafb shows improper behaviour on unload and thus seems to be broken. (should either be fixed or depend on BROKEN then?)

furthermore, the author tells that he doesn`t maintain it anymore, so at least MAINTAINERS file isn`t up to date and could be changed appropriately.
 
this is the response from the author:
>Dear Roland,
>Thank you for pointing this problem. But I'm not maintaining the  
>driver because I've lost my HGA card in the year 2001.
>Best regards,
>Ferenc Bakonyi

Steps to reproduce:
modprobe hgafb;rmmod hgafb

dmesg:
hgafb: HGA card not detected.
hgafb: probe of hgafb.0 failed with error -22
Device 'hgafb.0' does not have a release() function, it is broken and must be fixed.
WARNING: at drivers/base/core.c:107 device_release()
Pid: 2500, comm: rmmod Not tainted 2.6.24-rc6-vanilla #11
 [<c01d2f23>] kobject_cleanup+0x24/0x41
 [<c01d2f40>] kobject_release+0x0/0x8
 [<c01d3b68>] kref_put+0x60/0x6d
 [<c02430c2>] platform_device_del+0x12/0x37
 [<e0ad44f2>] hgafb_exit+0xa/0x14 [hgafb]
 [<c0144737>] sys_delete_module+0x187/0x1b4
 [<c0166010>] remove_vma+0x36/0x3b
 [<c01669c0>] do_munmap+0x19b/0x1b4
 [<c0104f52>] sysenter_past_esp+0x6b/0xa9
 =======================
Comment 1 Roland Kletzing 2008-01-04 15:43:49 UTC
pardon, i have chosen wrong component, so it was assigned to wrong person
Comment 2 Roland Kletzing 2008-04-12 09:39:50 UTC
still applies for 2.6.25-rc8
Comment 3 Andrew Morton 2008-06-03 17:08:08 UTC
I merged Krzysztof Helt's hgafb-convert-to-new-platform-driver-api-bugzilla-9689.patch which
shodl address this.  Closed.
Comment 4 Roland Kletzing 2008-06-04 14:39:52 UTC
just for tracking, as the patch has been dropped due to two people adressing that at the same time :)

http://sourceforge.net/mailarchive/message.php?msg_id=20080602193608.5173cdc0.krzysztof.h1%40poczta.fm

Note You need to log in before you can comment on or make changes to this bug.